Bug 104593 - FILEOPEN: SVG image in ODT file is badly displayed on LibO
Summary: FILEOPEN: SVG image in ODT file is badly displayed on LibO
Status: RESOLVED DUPLICATE of bug 104339
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2016-12-12 02:52 UTC by Carlos Roberto
Modified: 2016-12-15 16:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
SVG test.odt (32.87 KB, application/vnd.oasis.opendocument.text)
2016-12-12 02:52 UTC, Carlos Roberto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Roberto 2016-12-12 02:52:59 UTC
Created attachment 129508 [details]
SVG test.odt

How to reproduce:

1- Open Attachment SVG test.odt with LibreOffice 5.1
2- No problem with image.
3- Open same attachment with LibreOffice 5.2
3- Image is corrupted.

Image should display normally on newer LibreOffice versions.
Comment 1 Carlos Roberto 2016-12-12 03:19:24 UTC
Reproducible with:

Version: 5.3.0.0.beta1+
Build ID: 85c8695677fbf7162857410213f9ae1a1a8a371b
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2016-12-08_15:28:35
Locale: pt-BR (pt_BR); Calc: group
Comment 2 tommy27 2016-12-12 06:37:43 UTC
tested under Win8.1 x64
works fine with LibO 5.1.1
bug present in a 5.2.3 and recent 5.4.0 alpha build.

it's just a FILEOPEN issue. if you save the file with a buggy versione (i.e. 5.2.x) and reopen in 5.1.x the image is still displayed correctly

status NEW.
regression, needs bibisecting.
Comment 3 Terrence Enger 2016-12-13 17:41:59 UTC
I see the problem in Linux, specifically debian-stretch 64-bit, in
bibisect-50max version oldest.
Comment 4 raal 2016-12-15 16:06:02 UTC
This seems to have begun at the below commit.
Adding Cc: to Xisco Faulí; Could you possibly take a look at this one? Thanks

author	Xisco Fauli <anistenis@gmail.com>	2016-03-06 18:03:27 (GMT)
committer	Xisco Faulí <anistenis@gmail.com>	2016-03-07 08:48:50 (GMT)
commit d5649ae7b76278cb3155f951d6327157c7c92b65 (patch)
tree 6312127def6dcf68afff21c05d72f88ecac7a2d4
parent 3c465c259c617e30b01c5ea25b5203a605cd4269 (diff)
SVGIO: tdf#97539: clip-path elements might contain...
 36a44fb50a205bc567c71666d48b6ffc3f5e79ec is the first bad commit
commit 36a44fb50a205bc567c71666d48b6ffc3f5e79ec
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Wed Mar 9 12:07:56 2016 -0800

    source sha:d5649ae7b76278cb3155f951d6327157c7c92b65

 git bisect log
# bad: [6380ca07b05f68dedcaa379302cfe1fa478571c4] source sha:60b74fe1775e647545d2da1fcc58a4c63ec18aa5
# good: [1f670510f08cb800cbae2a1dd6ea70d3542e4721] source sha:49c2b9808df8a6b197dec666dfc0cda6321a4306
git bisect start 'origin/master' 'oldest'
# good: [38f37b8ec1a2d199bb957cfd2581df7d1b273b74] source sha:c0da1080b61a1d51654fc34fdaeba373226065ff
git bisect good 38f37b8ec1a2d199bb957cfd2581df7d1b273b74
# bad: [11ae494d8c566f23e0ef84ba0cc25fb1388b67f7] source sha:470cfa9860232ab70e017e6084d80f80d469555c
git bisect bad 11ae494d8c566f23e0ef84ba0cc25fb1388b67f7
# bad: [d247d25062e6cc4afccdc3c4be84a2b98523b36a] source sha:150c1dcab007dd8acc1551791f42eef692f9e531
git bisect bad d247d25062e6cc4afccdc3c4be84a2b98523b36a
# bad: [dc23450cfb87b61fcbd905a7079d8a0d32759e6b] source sha:5c1234eac2b9f3a3ea032e4828a15bedca6b9ebe
git bisect bad dc23450cfb87b61fcbd905a7079d8a0d32759e6b
# good: [2b75279dd1a9671b07feaa00b25faa59a7056258] source sha:b1d9fe788e635619b379627abebeacd270ca7770
git bisect good 2b75279dd1a9671b07feaa00b25faa59a7056258
# good: [279488432485bfea69e420aa9655e49bd6eb6bfd] source sha:2491b3217677d51ff3b4ee1a04fcde7a3b8f52a9
git bisect good 279488432485bfea69e420aa9655e49bd6eb6bfd
# bad: [a95825ae549351195bd42886f1be6e64d4ad0e09] source sha:0c9c5911b6df0226ef5c8d5465fd02a2bb581eb6
git bisect bad a95825ae549351195bd42886f1be6e64d4ad0e09
# good: [bd07d9d968c551916048fded1f5765c5a6cf569c] source sha:5f0c3172b3d2a5d3a71ab19caa5b462b539cbbe6
git bisect good bd07d9d968c551916048fded1f5765c5a6cf569c
# good: [35ed784a221112a13ccc02de4eb7933ca502c238] source sha:eb0774032011e45bf97f3102bf2005b4ae85f07d
git bisect good 35ed784a221112a13ccc02de4eb7933ca502c238
# good: [19f138db7a3bcdbc7c5432d1802ed52aeddd6692] source sha:ac47ff033498a991cd8d7e70a2d0ebf308d5ca46
git bisect good 19f138db7a3bcdbc7c5432d1802ed52aeddd6692
# bad: [bfe6f80f82653c046f0832bac032b07eb7ca1db9] source sha:9e3a15c728255a7874179c7104de366b0e056928
git bisect bad bfe6f80f82653c046f0832bac032b07eb7ca1db9
# good: [06f813441271e303a6f704cd7da8b0479d98b46a] source sha:3c465c259c617e30b01c5ea25b5203a605cd4269
git bisect good 06f813441271e303a6f704cd7da8b0479d98b46a
# bad: [36a44fb50a205bc567c71666d48b6ffc3f5e79ec] source sha:d5649ae7b76278cb3155f951d6327157c7c92b65
git bisect bad 36a44fb50a205bc567c71666d48b6ffc3f5e79ec
# first bad commit: [36a44fb50a205bc567c71666d48b6ffc3f5e79ec] source sha:d5649ae7b76278cb3155f951d6327157c7c92b65
Comment 5 raal 2016-12-15 16:10:01 UTC
The same commit as in bug 104339. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 104339 ***