Bug 104607 - CRASH: Writer crashes closing a document (GTK+/GTK3)
Summary: CRASH: Writer crashes closing a document (GTK+/GTK3)
Status: RESOLVED DUPLICATE of bug 104488
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.2.2 release
Hardware: All Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2016-12-12 15:20 UTC by Xisco Faulí
Modified: 2016-12-13 10:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
GDB trace of the crash with 5.4 master (21.70 KB, text/plain)
2016-12-12 15:51 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-12 15:20:58 UTC
Steps:
1. Open attachment 129525 [details]
2. Scroll to the bottom of the document
3. Scroll up
4. File -> Close

Observed behaviour: LibreOffice crashes


Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Telesto 2016-12-12 15:25:20 UTC
No repro with:
Version: 5.4.0.0.alpha0+
Build ID: 84f2ff67a7e404febf710b1dc7f66d06745c503f
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_23:20:01
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Buovjaga 2016-12-12 15:30:21 UTC
No crash.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 10th 2016

Version: 5.4.0.0.alpha0+
Build ID: cb598029835477326b190bc99abd31a487cc5a91
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_00:49:18
Locale: fi-FI (fi_FI); Calc: group
Comment 3 Xisco Faulí 2016-12-12 15:50:59 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but I can with gtk3 and gtk2
Comment 4 Buovjaga 2016-12-12 15:51:35 UTC
Created attachment 129532 [details]
GDB trace of the crash with 5.4 master

Ok, I could repro with GTK3, but as mentioned by Xisco, there needs to be an additional step of saving the file as .DOCX and then continuing from step 2.
Xisco reproduced on GTK2 as well. Gen does not cause it.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1fce5b024e9f25c3fcef2537a22474ece0dc416f
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 10th 2016
Comment 5 Xisco Faulí 2016-12-12 22:35:42 UTC
Caolán, would you mind to take a look at this one whenever you have time?
Comment 6 Xisco Faulí 2016-12-13 10:08:43 UTC

*** This bug has been marked as a duplicate of bug 104488 ***