Bug 104620 - CRASH: Writer crashes scrolling down a document (a11y)
Summary: CRASH: Writer crashes scrolling down a document (a11y)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All Linux (All)
: highest critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:5.4.0
Keywords: accessibility, bibisectRequest, haveBacktrace, regression
: 104656 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-12 22:27 UTC by Xisco Faulí
Modified: 2017-08-03 10:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (60.16 KB, text/plain)
2016-12-13 09:55 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-12 22:27:20 UTC
Steps:
1. Open attachment 86269 [details]
2. Scroll down

Observed behaviour: LibreOffice crashes right away

Reproduced in:

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Aron Budea 2016-12-12 22:30:32 UTC
Confirmed with 5.4 daily build (2016-12-10_00:00:32) / Ubuntu 16.04.
Comment 2 Xisco Faulí 2016-12-12 22:33:55 UTC
I can't reproduce it in

Version: 5.3.0.0.alpha1+
Build ID: ada8a2123ea655142be74a11c23e042a0109d5f8
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Caolán, would you mind to take a look whenever you have time?
Comment 3 Julien Nabet 2016-12-13 09:03:34 UTC
Xisco, I'll give it a try but if you have a bt to attach, it could be interesting.
Comment 4 Xisco Faulí 2016-12-13 09:55:22 UTC
Created attachment 129566 [details]
backtrace
Comment 5 Xisco Faulí 2016-12-13 09:58:28 UTC
it looks bug 104607 and this one crash at core/sw/source/core/access/accmap.cxx. Adding to See Also
Comment 6 Xisco Faulí 2016-12-13 10:08:58 UTC

*** This bug has been marked as a duplicate of bug 104488 ***
Comment 7 Michael Stahl (CIB) 2016-12-16 16:42:39 UTC
this isn't a duplicate of the other bug, being master-only and having a completely different stack.

regression from:

commit ae06f4be6bbdebc10a88c386064d548848e57f80
Author:     Michael Stahl <mstahl@redhat.com>
AuthorDate: Wed Dec 7 14:04:24 2016 +0100

    tdf#101464 tdf#91260 sw: a11y for partially off-page drawing object

fixed on master.
Comment 8 Commit Notification 2016-12-16 16:43:30 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdd1a03b450f9f8a0ead46c38bec58f6879b2c5d

tdf#101464 tdf#91260 tdf#104620 sw: fix null SwPageFrame crash

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Michael Stahl (CIB) 2016-12-16 16:46:25 UTC
*** Bug 104656 has been marked as a duplicate of this bug. ***
Comment 10 Julien Nabet 2016-12-17 12:58:18 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this anymore (gtk2/gtk3)
Comment 11 Xisco Faulí 2017-08-03 10:30:48 UTC
Verified as per comment 10