Bug 104656 - Crash when opening attachment tdf#69651
Summary: Crash when opening attachment tdf#69651
Status: VERIFIED DUPLICATE of bug 104620
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-12-13 22:00 UTC by Julien Nabet
Modified: 2016-12-17 12:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with symbols (15.95 KB, text/plain)
2016-12-13 22:00 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2016-12-13 22:00:01 UTC
Description:
On pc Debian x86-64 with master sources updated today, I get a crash when opening https://bugs.documentfoundation.org/attachment.cgi?id=86269

Steps to Reproduce:
1) Retrieve https://bugs.documentfoundation.org/attachment.cgi?id=86269
2) Open it with LO

Actual Results:  
Crash

Expected Results:
No Crash


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Julien Nabet 2016-12-13 22:00:58 UTC
Created attachment 129606 [details]
bt with symbols
Comment 2 Julien Nabet 2016-12-13 22:02:14 UTC
Michael: I noticed that bt called a part of this patch
https://cgit.freedesktop.org/libreoffice/core/commit/?id=ae06f4be6bbdebc10a88c386064d548848e57f80
Thought you might be interested in this one.
Comment 3 Xisco Faulí 2016-12-13 22:19:57 UTC

*** This bug has been marked as a duplicate of bug 104488 ***
Comment 4 Julien Nabet 2016-12-14 06:11:37 UTC
Xisco: it's not the same bt, that's why I created a brand new bugtracker.
I wanted to reproduce the one you quoted.
Comment 5 Xisco Faulí 2016-12-14 11:21:14 UTC
Hello Julien,
talking from total ignorance, could you explain me why the bt are different? I reported this same issue in bug 104620 but I closed it as dupe of bug 104488 as both seemed to crash at the same point: 

#8  0x00007fff9ea4902c in SwAccessibleContext::Dispose (this=this@entry=0x7fffc0640620, bRecursive=bRecursive@entry=true, bCanSkipInvisible=bCanSkipInvisible@entry=true) at /home/buildslave/source/libo-core/sw/source/core/access/acccontext.cxx:1079
#9  0x00007fff9ea4c042 in SwAccessibleDocument::Dispose (this=0x7fffc0640620, bRecursive=<optimized out>, bCanSkipInvisible=<optimized out>) at /home/buildslave/source/libo-core/sw/source/core/access/accdoc.cxx:384
#10 0x00007fff9ea5eed3 in SwAccessibleMap::~SwAccessibleMap (this=0x1898740, __in_chrg=<optimized out>) at /home/buildslave/source/libo-core/sw/source/core/access/accmap.cxx:1673
#11 0x00007fff9ea5f2b1 in SwAccessibleMap::~SwAccessibleMap (this=0x1898740, __in_chrg=<optimized out>) at /home/buildslave/source/libo-core/sw/source/core/access/accmap.cxx:1752
#12 0x00007fff9f18dd90 in SwViewShellImp::~SwViewShellImp (this=0x22554d0, __in_chrg=<optimized out>) at /home/buildslave/source/libo-core/sw/source/core/view/viewimp.cxx:109
Comment 6 Julien Nabet 2016-12-14 13:11:35 UTC
My bt seems different than yours:
#0  Size::Height (this=this@entry=0x70) at /home/julien/lo/libreoffice/include/tools/gen.hxx:184
#1  0x00002aaad5b19d87 in Size::getHeight (this=this@entry=0x70) at /home/julien/lo/libreoffice/include/tools/gen.hxx:190
#2  0x00002aaad5b3814a in SwRect::Bottom (this=this@entry=0x60) at /home/julien/lo/libreoffice/sw/inc/swrect.hxx:250
#3  0x00002aaad5b9dcb8 in SwRect::IsOver (this=this@entry=0x7fffffff1b10, rRect=SwRect = {...}) at /home/julien/lo/libreoffice/sw/source/core/bastyp/swrect.cxx:132
#4  0x00002aaad5b9dd3b in SwRect::Intersection (this=this@entry=0x7fffffff1b10, rRect=SwRect = {...}) at /home/julien/lo/libreoffice/sw/source/core/bastyp/swrect.cxx:62
#5  0x00002aaad5b25e9c in sw::access::SwAccessibleChild::GetBox (this=this@entry=0x7fffffff1ae8, rAccMap=...)
    at /home/julien/lo/libreoffice/sw/source/core/access/accfrmobj.cxx:267
#6  0x00002aaad5b18874 in SwAccessibleContext::ChildrenScrolled (this=this@entry=0x55555cb22090, pFrame=<optimized out>, rOldVisArea=SwRect = {...})
    at /home/julien/lo/libreoffice/sw/source/core/access/acccontext.cxx:141
#7  0x00002aaad5b18df6 in SwAccessibleContext::ScrolledWithin (this=0x55555cb22090, rOldVisArea=SwRect = {...})
    at /home/julien/lo/libreoffice/sw/source/core/access/acccontext.cxx:295
#8  0x00002aaad5b18a6b in SwAccessibleContext::ChildrenScrolled (this=this@entry=0x55555c7fa400, pFrame=<optimized out>, rOldVisArea=SwRect = {...})
    at /home/julien/lo/libreoffice/sw/source/core/access/acccontext.cxx:200
#9  0x00002aaad5b18c55 in SwAccessibleContext::ChildrenScrolled (this=this@entry=0x55555c7fa400, pFrame=<optimized out>, rOldVisArea=SwRect = {...})
    at /home/julien/lo/libreoffice/sw/source/core/access/acccontext.cxx:266
#10 0x00002aaad5b18c55 in SwAccessibleContext::ChildrenScrolled (this=this@entry=0x55555c7fa400, pFrame=<optimized out>, rOldVisArea=SwRect = {...})
    at /home/julien/lo/libreoffice/sw/source/core/access/acccontext.cxx:266
#11 0x00002aaad5b18d3a in SwAccessibleContext::Scrolled (this=this@entry=0x55555c7fa400, rOldVisArea=SwRect = {...})
    at /home/julien/lo/libreoffice/sw/source/core/access/acccontext.cxx:276
#12 0x00002aaad5b1b7db in SwAccessibleDocumentBase::SetVisArea (this=0x55555c7fa400) at /home/julien/lo/libreoffice/sw/source/core/access/accdoc.cxx:96
#13 0x00002aaad5b303a2 in SwAccessibleMap::GetDocumentView_ (this=0x55555c6ef4f0, bPagePreview=bPagePreview@entry=false)
    at /home/julien/lo/libreoffice/sw/source/core/access/accmap.cxx:1811
Comment 7 Xisco Faulí 2016-12-14 13:46:17 UTC
this is odd, anyway, confirming with 

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 8 Michael Stahl (allotropia) 2016-12-16 16:46:25 UTC

*** This bug has been marked as a duplicate of bug 104620 ***