Bug 104699 - FILEOPEN: DOC: Checkbox missing
Summary: FILEOPEN: DOC: Checkbox missing
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2016-12-15 14:19 UTC by Xisco Faulí
Modified: 2019-05-15 09:32 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample (9.50 KB, application/msword)
2016-12-15 14:19 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-12-15 14:19:42 UTC
Created attachment 129671 [details]
sample

Steps:
1. Open attached document
2. Check the number of checkboxes

Expected behaviour: There should be 3 checkboxes ( 2 above and 1 below) 

Reproduced in 

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-12-15 14:21:31 UTC
Regression introduced by:

author	Luboš Luňák <l.lunak@collabora.com>	2014-11-07 15:14:21 (GMT)
committer	Luboš Luňák <l.lunak@collabora.com>	2014-11-09 18:44:25 (GMT)
commit	6a5dbe73537642b06bcde782118a34b4593d17eb (patch)
tree	ae6f0d75dde1ab0a8cc524edbad19338ea90ddf0
parent	123e49d6e307c41a5f59878335563ad7203b23ff (diff)
do not iterate over all bookmarks in SwTxtNode::Update()
3f9872185e introduced new API for fast finding of marks to a specific text node,
so use that (code itself based on cb46aaf2d7).
This makes mailmerge faster (since it can create a huge document, and especially
with the change to use UNO bookmarks to mark starts of MM documents inside
the larger single document there can be a large number of marks).

Adding Cc: to Luboš Luňák
Comment 2 m.a.riosv 2016-12-15 21:45:27 UTC
Hi Xisco, looks like a dup of #87183
Comment 3 Luke 2016-12-21 05:35:53 UTC
m.a.riosv,
Bug 87183 is not a regression and was verified in 4.3. This is a regression that was introduced in 4.4.
Comment 4 Tamás Zolnai 2017-08-22 19:40:54 UTC
I just tested this bugdoc on master (version 6.0) and it works nicely.
Xisco, can you check whether you still reproduce this issue. Otherwise it would be good to close this bug.
Comment 5 Xisco Faulí 2017-08-30 18:05:14 UTC
Yes, it's fixed in master:

Version: 6.0.0.0.alpha0+
Build ID: 78960ad06faca055a6d97afbc764c902d5d07f6f
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-08-30_06:31:19
Locale: es-ES (es_ES); Calc: group

Closing as RESOLVED WORKSFORME and setting backportRequest:5:4
Comment 6 Justin L 2017-09-02 20:28:11 UTC
bibisecting suggests that this was fixed on Aug 11ish, but I can't guess which one of those is the fix.