Bug 104898 - Wrong position of Hebrew Niqqud in Arial and Times-New-Roman fonts
Summary: Wrong position of Hebrew Niqqud in Arial and Times-New-Roman fonts
Status: RESOLVED DUPLICATE of bug 67317
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-23 23:07 UTC by Ofir
Modified: 2016-12-24 01:24 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
ODP with Hebrew word that has Niqqud (11.82 KB, application/x-zip-compressed)
2016-12-23 23:08 UTC, Ofir
Details
PDF exported from PowerPoint 2013 showing the expected result (93.07 KB, application/pdf)
2016-12-23 23:08 UTC, Ofir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ofir 2016-12-23 23:07:09 UTC
Description:
The attached ODP has Hebrew word with Niqqud [1].
The first slide uses the Times New Roman font.
The second slide uses the Arial font.

On a machine without the fonts, LO substitute the fonts and place the Niqqud in the correct position.

On a machine with the above fonts installed, some of the Niqqud signs are placed next to the characters instead of decorating the characters.

[1] https://en.wikipedia.org/wiki/Niqqud

Steps to Reproduce:
1. Install the Times New Roman and Arial fonts. On Ubuntu you can use the ttf-mscorefonts-installer package.
Open the attached ODP in Impress.
2. Compare the Niqqud with the attached PDF.

Actual Results:  
Some of the Niqqud signs are treated as a separate character.

Expected Results:
The Niqqud signs should decorate the characters.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
Comment 1 Ofir 2016-12-23 23:08:12 UTC
Created attachment 129910 [details]
ODP with Hebrew word that has Niqqud
Comment 2 Ofir 2016-12-23 23:08:43 UTC
Created attachment 129911 [details]
PDF exported from PowerPoint 2013 showing the expected result
Comment 3 Ofir 2016-12-24 00:10:44 UTC
LO 5.2.4.2 on Windows 7 doesn't have this issue.
Changing the platform to Linux.

Tested on Ubuntu 16.04 with the ttf-mscorefonts-installer  package.
Comment 4 Ofir 2016-12-24 01:24:25 UTC
It was OK on LO 5.1.4.2
Broken on LO 5.2.3
Fixed on LO 5.3.0.0.beta2

*** This bug has been marked as a duplicate of bug 67317 ***