Bug 67317 - RTL: Hebrew Niqqud is not displayed correctly in Arial Unicode MS font
Summary: RTL: Hebrew Niqqud is not displayed correctly in Arial Unicode MS font
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:5.3.0
Keywords:
: 104898 (view as bug list)
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 18:36 UTC by Elad Tsur
Modified: 2016-12-24 01:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Incorrect rendering (279.98 KB, image/png)
2013-07-25 21:19 UTC, Elad Tsur
Details
Correct rendering (281.42 KB, image/png)
2013-07-25 21:19 UTC, Elad Tsur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Elad Tsur 2013-07-25 18:36:19 UTC
Problem description: 

Hebrew niqqud and cantillation marks aredisplayed as separate characters instead of on the letters. This issue is OS X specific.


Steps to reproduce:

1. Copy some Hebrew text with niqqud and/or cantillation marksto the clipboad, for example:

בְּרֵאשִׁ֖ית בָּרָ֣א אֱלֹהִ֑ים אֵ֥ת הַשָּׁמַ֖יִם וְאֵ֥ת הָאָֽרֶץ

2. Paste into any LibreOffice component.

Current behavior:

Each mark appear as a separate character.

Expected behavior:

The marks should be rendered on the letters.
              
Operating System: Mac OS X
Version: 4.1.0.4 release
Comment 1 Elad Tsur 2013-07-25 21:16:55 UTC
After further investigation, the problem appear with the default Arial MS Unicode font, but not with other fonts such as Lucida Grande. See attached screenshots.
Comment 2 Elad Tsur 2013-07-25 21:19:09 UTC
Created attachment 83012 [details]
Incorrect rendering
Comment 3 Elad Tsur 2013-07-25 21:19:42 UTC
Created attachment 83013 [details]
Correct rendering
Comment 4 Khaled Hosny 2013-07-27 17:59:04 UTC
Is this issue LibreOffice specific? What happens if you try the same text and font in TextEdit, for example?
Comment 5 QA Administrators 2014-02-02 02:06:21 UTC Comment hidden (obsolete)
Comment 6 Elad Tsur 2014-02-02 03:00:23 UTC
The same text using the same font in TextEdit is also rendered incorrectly. However, when pasting the plain text LibreOffice defaults to the broken Arial Unicode MS while TextEdit defaults to Lucida Grande which renders correctly.
Comment 7 Owen Genat (retired) 2014-07-22 09:44:41 UTC
(In reply to comment #1)
> After further investigation, the problem appear with the default Arial MS
> Unicode font

Confirmed under MacOS 10.6.8 using v4.3.0.3 Build ID: fcd3838c4097f7817b5b3984fd88a44e1edd8548. I am seeing what is illustrated in the incorrect rendering attachment for Arial Unicode MS. Problem does not occur with Liberation Mono.

Status set to NEW. It is unclear to me whether this is an issue with LO or with the Arial Unicode MS font. Summary amended for clarity.
Comment 8 LD 2015-02-26 18:37:44 UTC
(In reply to Owen Genat from comment #7)
> (In reply to comment #1)
> It is unclear to me whether this is an issue with LO or
> with the Arial Unicode MS font. Summary amended for clarity.

The problem is definitely with the Arial Unicode MS font. This can be verified by pasting in some hebrew text into Text Edit (or LO). With Lucida Grande or SBL Hebrew (etc) the text displays correctly, however it is badly rendered in Arial Unicode MS.

Thus my question (as an end user) would be how to change LO's behaviour such that Arial Unicode MS is not the default font for such text?
Comment 9 tommy27 2016-04-16 07:27:44 UTC Comment hidden (obsolete)
Comment 10 eisa01 2016-11-06 16:54:00 UTC
Text has correct rendering with Arial MS Unicode with the new text layout engine in bug 89870

Verified by switching between the old and new layout in the advanced settings

Version: 5.3.0.0.alpha1+
Build ID: 17e9dc436bc6ad8d3a5bbde15d4d47262650aa2c
CPU Threads: 2; OS Version: Mac OS X 10.12; UI Render: default; Layout Engine: new; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-11-06_01:25:01
Locale: en-US (en_NO.UTF-8); Calc: group
Comment 11 Ofir 2016-12-24 01:24:25 UTC
*** Bug 104898 has been marked as a duplicate of this bug. ***