Bug 104907 - Scrolling will be slow when multiple images are stacked above each other
Summary: Scrolling will be slow when multiple images are stacked above each other
Status: RESOLVED DUPLICATE of bug 86798
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2016-12-24 13:52 UTC by Telesto
Modified: 2017-10-04 14:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (2.97 MB, application/vnd.oasis.opendocument.text)
2016-12-24 13:52 UTC, Telesto
Details
another example (4.77 MB, application/vnd.oasis.opendocument.text)
2017-01-16 08:10 UTC, Mikhail Novosyolov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-24 13:52:08 UTC
Description:
It's a bit of theoretical example. Scrolling will be slow (and maxing out CPU) when multiple images are layers above each other (which happens when importing multiple images using drag and drop)

Steps to Reproduce:
1.Open example file
2.Scroll around
3.Take notice of CPU usage

Actual Results:  
Slow scrolling; high CPU usage

Expected Results:
Response scrolling; low CPU usage (similar to 4.1.0.4; 5%)


Reproducible: Always

User Profile Reset: No

Additional Info:
Found in:
Version: 5.4.0.0.alpha0+
Build ID: 9cfb2f2f03b5ec086487fd483298466db0b09010
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-20_23:58:02
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.6.3 
Build ID: e8938fd3328e95dcf59dd64e7facd2c7d67c704d
Locale: nl_NL

and in
Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba

and in
Versie: 4.2.0.4 
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

but not in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-24 13:52:30 UTC
Created attachment 129919 [details]
Example file
Comment 2 Buovjaga 2017-01-01 20:46:33 UTC
Yep, confirmed the difference between 5.4 and 3.6.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: fc0d4e6bc43d5f982452df07930f5ecf5927ad22
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on December 31st 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 3 Telesto 2017-01-07 17:07:52 UTC
Probably not a regression, because of all the changes made to image rendering.
Comment 4 Mikhail Novosyolov 2017-01-16 08:10:33 UTC
Created attachment 130467 [details]
another example
Comment 5 Mikhail Novosyolov 2017-01-16 08:11:45 UTC
Attached another document with the same problem. Repsruduced in LO 5.1, 5.2 and 5.3 in KDE and Unity (Linux). Changing rendering to OpenGL does not help. 

I think the priority should not be low.
Comment 6 Mikhail Novosyolov 2017-07-31 08:49:05 UTC
still remains in libreoffice 5.4
Comment 7 Xisco Faulí 2017-10-04 14:51:39 UTC
Regression introduced by 2e5167528f7566dd9b000e50fc1610b7bf99132a which is the
same as in bug 86798

*** This bug has been marked as a duplicate of bug 86798 ***