Bug Hunting Session
Bug 104912 - Merge text direction related buttons into single button
Summary: Merge text direction related buttons into single button
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Text-Direction-Unification
  Show dependency treegraph
 
Reported: 2016-12-24 18:27 UTC by Volga
Modified: 2019-04-11 12:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2016-12-24 18:27:35 UTC
Description:
Currently we have four text direction related buttons: “Left-to-Right” and “Right-to-Left” to switch text directionality within a line, “Text direction from left to right” and “Text direction from top to bottom” to make text horizontally or vertically. But they have some limitations. For example, “Text direction from top to bottom” button works only in text box, and it enable Han styled direction only, i.e. right-to-left vertical direction. Additionaly, put such operation into seperate buttons could positioning more spaces on screen.

Steps to Reproduce:
-

Actual Results:  
-

Expected Results:
All the text direction related operations on toolbar should be merge into single button “Text direction”, click this button will open a drop list to show all text directions (As Set Line Spacing button performanced). Left-to-Right and Right-to-Left should devide into Inline Directionality group within this drop list.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Volga 2016-12-25 06:20:57 UTC
Since LibreOffice started enabling left-to-right (vertical) direction in bug 33278, this improvement is necessary, and the new button should works in page level.
Comment 2 Volga 2017-06-23 11:43:24 UTC
An illustration from MS Office 2010 can be found in this page, which formatted as animated GIF.
http://www.mgzwz.com/post-383.html
Comment 3 Heiko Tietze 2019-04-08 09:13:34 UTC
LTR/RTL depends on horizontal vs. vertical and get disabled. And this option is restruicted to text boxes.

If we merge LTR/RTL into one control (dropdown) we cannot assign a shortcut anymore (wouldnt assign one to this rarely used function but we do have it today).

Putting all together I think it's a WF.
Comment 4 Thomas Lendo 2019-04-08 20:57:44 UTC
If a single group button is made, the old ones must be kept to ensure that shortcuts don't get lost and most used commands by the user can still be inserted to the toolbar manually.
Comment 5 Heiko Tietze 2019-04-11 12:23:09 UTC
No further opinion, let's resolve it as WF.