Bug 33278 - Text direction should allow LTR (vertical)
Summary: Text direction should allow LTR (vertical)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Khaled Hosny
QA Contact:
URL:
Whiteboard: target:5.3.0
Keywords:
: 61846 (view as bug list)
Depends on:
Blocks: Font-Rendering 103735 Vertical-Text 111409
  Show dependency treegraph
 
Reported: 2011-01-19 11:53 UTC by Alexandre Demers
Modified: 2017-09-17 02:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrong typesetting for Traditional Mongolian in LibreOffice 5 (212.81 KB, application/zip)
2015-08-17 18:03 UTC, Volga
Details
DelehiOffice screenshot (58.38 KB, image/png)
2017-03-28 10:50 UTC, aron
Details
DelehiOffice2 (128.44 KB, image/png)
2017-03-28 10:52 UTC, aron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Demers 2011-01-19 11:53:32 UTC
When creating a caption, many options are available as Text direction. However, LTR (vertical) is not available. It would be great if it was added since the user may need it for some special cases.
Comment 1 Björn Michaelsen 2011-12-23 11:45:50 UTC Comment hidden (obsolete)
Comment 2 Alexandre Demers 2011-12-23 13:43:07 UTC
This feature request is not implemented yet nor was it reviewed by dev.
Comment 3 Joel Madero 2014-07-13 01:33:33 UTC Comment hidden (obsolete)
Comment 4 Urmas 2014-09-04 05:20:33 UTC
The only script with this direction is ancient Mongolian. Does anyone need it in modern documents?
Comment 5 Alexandre Demers 2014-09-04 22:06:53 UTC
(In reply to comment #4)
> The only script with this direction is ancient Mongolian. Does anyone need
> it in modern documents?

This feature request was added when I was writing an essay during my master degree. At some point, because of the writing protocol we had to follow, it would have been easier and quicker to flip the caption using this feature in a special manner. However, I can't remember exactly of the case I was facing at the time, so it may be simpler to close this feature request for now. If someone faces a case where it is needed, he may reopen it.
Comment 6 aronsoyol 2014-10-08 02:49:14 UTC
(In reply to Urmas from comment #4)
> The only script with this direction is ancient Mongolian. Does anyone need
> it in modern documents?

Yes, this feature is very important for us - 3,000,000 pepole living Inner Mongolian of China. We are using vertical Mongolian script even now. So please do not give up and complete support for vertical Mongolian script. 
Thank you very much.
Comment 7 Volga 2015-08-17 17:22:35 UTC
(In reply to aronsoyol from comment #6)
> (In reply to Urmas from comment #4)
> > The only script with this direction is ancient Mongolian. Does anyone need
> > it in modern documents?
> 
> Yes, this feature is very important for us - 3,000,000 pepole living Inner
> Mongolian of China. We are using vertical Mongolian script even now. So
> please do not give up and complete support for vertical Mongolian script. 
> Thank you very much.

The Mongolian script is not only used for Mongolian in Inner Mongolia of PRC, but also used for Manchu, Sibe and Daur, you can find these materials in Inner Mongolia, Liaoning, Jilin, Xinjiang of PRC, so this typesetting is very useful for their people who speaking in these languages.
Comment 8 Volga 2015-08-17 17:45:11 UTC
(In reply to Urmas from comment #4)
> The only script with this direction is ancient Mongolian. Does anyone need
> it in modern documents?

Yes, this script is widely used in Mongolian speaking people in PRC, you're easy to find these documents.

If you want to find them, you can copy these strings from here to Google, Bing, Yahoo Search etc:

    ᠮᠣᠩᠭᠣᠯ filetype:pdf
Comment 9 Volga 2015-08-17 18:03:48 UTC
Created attachment 117979 [details]
Wrong typesetting for Traditional Mongolian in LibreOffice 5

As my attachment shown, there is no way of setting LTR (vertical) layout in LibreOffice, I suggest you should add a menu at the "Text direction from top to bottom" button, to choose which text direction is avilable.
Comment 10 Volga 2015-08-17 18:10:28 UTC
(In reply to General Kutuzov from comment #8)
> (In reply to Urmas from comment #4)
> > The only script with this direction is ancient Mongolian. Does anyone need
> > it in modern documents?
> 
> Yes, this script is widely used in Mongolian speaking people in PRC, you're
> easy to find these documents.
> 
> If you want to find them, you can copy these strings from here to Google,
> Bing, Yahoo Search etc:
> 
>     ᠮᠣᠩᠭᠣᠯ filetype:pdf

Another way of finding them is avaliable:

    site:hb.mgyxw.net filetype:pdf
Comment 11 Volga 2015-11-07 10:15:47 UTC
Modern Hangul also uses LTR column in vertical writing mode.

https://en.wikipedia.org/wiki/File:Hyeoruinu.jpg
Comment 12 Volga 2015-11-08 03:12:52 UTC
I think the “Text direction from top to buttom” button should adding an option to allow user to choose RTL or LTR column mode for vertical layout.
Comment 13 Volga 2016-02-20 10:34:17 UTC
Recent version of MS Office have found a serious bug for LTR (vertical), so there is your way.

http://abkai.net/core/en/read-me-first/
Comment 14 Volga 2016-03-09 08:58:33 UTC
(In reply to General Kutuzov from comment #13)
> Recent version of MS Office have found a serious bug for LTR (vertical), so
> there is your way.
> 
> http://abkai.net/core/en/read-me-first/

More on this problem (if you can read Chinese or using online translation):
http://abkai.net/blog/word-20102013%E5%92%8Cwps-2013%E4%B8%AD%E6%BB%A1%E6%96%87%E7%AB%96%E6%8E%92%E7%89%88%E7%9A%84%E9%97%AE%E9%A2%98/

So LO should be performanced better for text direction
Comment 15 Volga 2016-05-01 09:48:10 UTC
Unicode has a Technical Note related to this layout, I think you should implement.

http://www.unicode.org/notes/tn22/
Comment 16 Volga 2016-08-21 14:59:23 UTC
(In reply to Urmas from comment #4)
> The only script with this direction is ancient Mongolian. Does anyone need
> it in modern documents?

Inner Mongolian University has already implemented LTR (vertical) layout in their Office suite. Click here for more informations if you can read Chinese:

http://www.mglip.com/profro01.htm
Comment 17 Volga 2016-08-21 15:05:24 UTC
Since Firefox has already implemented this writing direction, this can be implemented in LibreOffice based on Gecko’s implementation.
Comment 18 Volga 2016-08-30 03:39:32 UTC
On SourceForge there is a repository which has a sample to use LTR line direction for vertical texts.

https://sourceforge.net/projects/tmeditor/
Comment 19 Volga 2016-10-01 14:17:50 UTC
SignWriting also uses this direction. On Wikimedia Incubator some editors have already implemented it. 

https://incubator.wikimedia.org/wiki/Wp/ase
Comment 20 Michael Bauer 2016-10-27 15:41:27 UTC
*** Bug 61846 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2016-10-29 13:20:38 UTC
Khaled Hosny committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=930a3d462b05e111da37d31de7f60998ce9454b3

tdf#33278: Enable UI for vertical left-to-right

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Volga 2016-11-04 03:36:33 UTC
Where to enable it?
Comment 23 Khaled Hosny 2016-11-04 03:42:15 UTC
The same place you enable RTL (vertical).
Comment 24 Volga 2016-11-04 04:09:52 UTC
I found no way to use in the text box
1. Add Text direction from top to bottom item in Format menu (I have done several days ago)
2. Insert a text box and input ᠮᠣᠩᠭᠣᠯ ᠪᠢᠴᠢᠭ with separate line
3. Make it vertically with that menu item
4. Format > Paragraph > Alignment, then I don’t found it.
Comment 25 Volga 2016-11-05 10:21:49 UTC
OK I got it on Page dialog, but it cannot applied into textbox.
Comment 26 aron 2017-03-28 03:41:31 UTC
we have already solved the layout problem of traditional Mongolian and release our Original version of LibreOffice which is called DelehiOffice. 

We consider to merge our code to LibreOffice at right timing.
Comment 27 aron 2017-03-28 10:38:30 UTC
DelehiOffice
http://www.mongolfont.com/office/
Comment 28 aron 2017-03-28 10:50:25 UTC
Created attachment 132216 [details]
DelehiOffice screenshot
Comment 29 aron 2017-03-28 10:52:39 UTC
Created attachment 132217 [details]
DelehiOffice2
Comment 30 Volga 2017-09-17 02:30:38 UTC
(In reply to aron from comment #26)
> we have already solved the layout problem of traditional Mongolian and
> release our Original version of LibreOffice which is called DelehiOffice. 
> 
> We consider to merge our code to LibreOffice at right timing.

Hello aron, 
Can you submit your works to our Gerrit server? Our gerrit server is gerrit.libreoffice.org.