Bug 104985 - verification failure on MacOs
Summary: verification failure on MacOs
Status: RESOLVED DUPLICATE of bug 97530
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.2.3.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-29 18:15 UTC by larus
Modified: 2017-01-02 16:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description larus 2016-12-29 18:15:59 UTC
When i click the dmg for version 5.2.3_MacOS_x86-64.dmg the verification is slow, then nothing happens.  The computer slows way down, even after i cancel.  Restart is necessary.  I tried loading an older version but same problem occurs.  What to do?
Comment 1 Julien Nabet 2016-12-30 11:28:16 UTC
Did you retrieve LO from TDF official website https://www.libreoffice.org/download/libreoffice-fresh/ ?
Which MacOs version do you use? (just to be sure have you rebooted your Macos)
Does it happen with other softwares?
Comment 2 Julien Nabet 2016-12-30 14:39:07 UTC
Please don't respond from your mailer but from https://bugs.documentfoundation.org/show_bug.cgi?id=104985#

Response received in private email:
"
I'm on version 10.10.5

I did download from the official site.  I just re-downloaded it and again, the verification completes, then...nothing, other than the fan coming on, the computer slows down.  Even after cancelling (doesn't matter how long i wait), the computer is barely operable.  After restart, it's back to normal.
"

Since I don't have more questions, I'll put it back to UNCONFIRMED.
Comment 3 Julien Nabet 2016-12-30 14:39:37 UTC
Alex: thought you might have some idea for this one.
Comment 4 larus 2017-01-01 18:11:45 UTC
At this point, as i have no access to my ods files, and re-downloading LO isn't resolving the issue, i'm not sure what else to do but find a different program.  Perplexing and frustrating.  Any suggestions?
Comment 5 Julien Nabet 2017-01-01 18:23:31 UTC
Has LO ever worked on your machine or is it recent it doesn't work?
If it's recent, did you change anything in software (MacOs upgrade, install some softs, drivers, fonts, ...) or in hardware (new graphic card for example).

Do you reproduce for other softwares (eg: Firefox)?
Comment 6 Julien Nabet 2017-01-01 18:24:22 UTC
Just to be sure, did you download and try to open dmg file from your local hardisk and not from network share?
Comment 7 larus 2017-01-01 20:25:10 UTC
It worked until i got the update, replaced the old with the new version.  The only update recently is Adobe flash player.  I did open the dmg from the hardisk.  I don't understand what's meant by "reproduce for other softwares".  I use Firefox as a browser with add-ons: "https everywhere", "Disconnect" and "Adblockplus".  I could disable these and when i can get back to somewhere with the bandwidth, try downloading the dmg again.  The odd thing was that i had an old dmg of version 5.0.0 and the same verification failure with subsequent operation problem occurred.
Comment 8 Julien Nabet 2017-01-01 21:19:23 UTC
(In reply to larus from comment #7)
> It worked until i got the update, replaced the old with the new version. 
> The only update recently is Adobe flash player.  I did open the dmg from the
> hardisk.  I don't understand what's meant by "reproduce for other
> softwares".  I use Firefox as a browser with add-ons: "https everywhere",
> "Disconnect" and "Adblockplus".  I could disable these and when i can get
> back to somewhere with the bandwidth, try downloading the dmg again.  The
> odd thing was that i had an old dmg of version 5.0.0 and the same
> verification failure with subsequent operation problem occurred.

Sorry I wanted to know if you have install pb with other softwares.
It could be interesting you disable the plugins you quoted and download again LO dmg just for the test.
You may also try with Safari.

To be sure, you retrieved the exact file as it should, you can check with http://download.documentfoundation.org/libreoffice/stable/5.2.4/mac/x86_64/LibreOffice_5.2.4_MacOS_x86-64.dmg.mirrorlist (MD5, SHA-1 or SHA-256)
For MD5 for example, this link http://news.softpedia.com/news/How-to-Check-MD5-Sum-on-Mac-OS-X-431080.shtml explains how to do this.
Comment 9 Alex Thurgood 2017-01-02 09:42:52 UTC
This problem seems to be particular to OSX 10.10 and possibly 10.9.5 - it seems that the DMG file gets quarantined by Gatekeeper and an xattr attribute set which prevents the installation from completing.

Almost certainly a duplicate, but finding it is the key...
Comment 10 Alex Thurgood 2017-01-02 09:56:43 UTC
@larus : 

1) Unset Gatekeeper preferences before installing LO

2) When launching LO for the first time, try using a right mouse button click, and choosing open from the Applications folder.

3) If LO launches successfully, reset the Gatekeeper preferences back to the default.
Comment 11 Alex Thurgood 2017-01-02 10:39:01 UTC

*** This bug has been marked as a duplicate of bug 97530 ***
Comment 12 larus 2017-01-02 16:07:38 UTC
Thanks!  Such a simple fix for an exasperating problem.