Bug 97530 - Installs, then hangs while verifying (OSX 10.10 and earlier)
Summary: Installs, then hangs while verifying (OSX 10.10 and earlier)
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression, wantBacktrace
: 99397 101739 104985 106055 (view as bug list)
Depends on:
Blocks: Installer
  Show dependency treegraph
 
Reported: 2016-02-03 16:08 UTC by pisica
Modified: 2018-07-25 16:21 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pisica 2016-02-03 16:08:18 UTC
I downloaded 5.0.4 to upgrade LO and it simply will not load. I can install it without a problem and then when I open it, it brings up the "Verifying LibreOffice" window and the icon bounces and eventually stops bouncing. That's it. I can't open it. Selecting 'open' by ctrl-clicking the icon itself has the same result.

The first time, I got a pop-up window saying that it was damaged and should go into the trash, but that hasn't appeared since.

Same thing happened when I tried to install the previous version.

And yes, I have the security setting selected to open from 'Mac App store and identified developers'.

I'm using OSX Yosemite 10.10.5.
Comment 1 Bernhard Gschaider 2016-02-11 11:31:04 UTC
I have the same problem with a recently downloaded LibreOffice_5.1.0_MacOS_x86-64.dmg  on a Mac OS X 10.0.5 machine. Verification is almost complete and then it hangs. CoreServicesUIAgent gets all the memory it can get (up to 8 Gig) until the machine almost freezes
Comment 2 pisica 2016-02-11 14:30:02 UTC
(In reply to Bernhard Gschaider from comment #1)

I eventually got it to download. I tried again a few days later and had the same issues (hanging, etc.), but eventually a pop-up message appeared - the one about downloading software that wasn't from the Mac store. My settings had already been to allow apps downloaded from the Mac store and identified developers, but once I cleared the download hang, I changed that permission to allow apps downloaded from anywhere. And then the download worked without a problem! Maybe try that and see if it works for you?
Comment 3 Bernhard Gschaider 2016-02-11 16:13:12 UTC
That's right. Now it works:
1. Switching off the app-verification
2. Opening LibreOffice
3. Switching it back on

Now LibreOffice works without problems.

But there still seems to be a problem with the package verification
Comment 4 mrwlists 2016-02-23 19:12:35 UTC
I have the same problem with "LibreOffice 5.1.0 for Mac OS X x86_64".

This is the package from the official download page.

It is very slow to "verify", and eventually hangs the machine, very badly, with the 'verify' progress bar still showing.

Yosemite 10.10.5
Comment 5 info 2016-02-25 20:54:10 UTC
Same here - 5.0.4 also shows the same problem now when I try to install this older version from DMG that worked previously.

Have to use OpenOffice now.
Comment 6 jammon 2016-02-27 18:30:36 UTC
I had the same problem and found it described here: https://ask.libreoffice.org/en/question/64253/libreoffice-513-stuck-on-verifying-mac-os-x-yosemite-10105/
Comment 7 Julien Nabet 2016-07-03 11:57:01 UTC
With MacOs X 10.11.5, I could install LO 5.1.4 without problem.

Alex: do you reproduce this with last stable 5.0.6 or "fresh" 5.1.4?
Comment 8 mrwlists 2016-07-03 13:57:22 UTC
@Julien Nabet

Thank you for noting this. I'm not Alex, but:

I, too, can install LO 5.1.4 without problem with MacOS X 10.11.5.

I was unable to install LO 5.1.0 with MacOS X 10.10.5. I cannot determine whether a change in LO or Mac OS is responsible for this welcome change.
Comment 9 Julien Nabet 2016-07-03 15:18:39 UTC
Thank you for your feedback mrwlists.
Let's put this one to WFM then.

pisica: don't hesitate to reopen this tracker if you can still reproduce this with LO 5.1.4
Comment 10 Vasili Sviridov 2016-09-11 12:32:34 UTC
Still reproducible with 5.2.1.2 on OSX 10.10.5
Had to resort to `xattr -d com.apple.quarantine /Applications/LibreOffice.app` to be able to launch it. Same symptoms, non-stop memory consumption of CoreServiceUIAgent, which brings the OS to a halt.
Comment 11 Buovjaga 2016-10-21 17:46:16 UTC
Correcting status to NEW.
Comment 12 Alex Thurgood 2016-10-23 10:01:34 UTC
*** Bug 99397 has been marked as a duplicate of this bug. ***
Comment 13 steve -_- 2016-10-23 16:32:46 UTC
macOS 10.10.5

Downloaded LO 5.2.2 form website
copied LO.app to programs folder
double click LO icon

→ bouncing icon + finder window "Verifying 'LibreOffice'"
verify never finishes. argh!
known workaround, adjust security settings in macOS > System Preferences > Security.

works as expected on 10.12 (without adjust security settings)

Can someone explain how this makes any sense?
Comment 14 Alex Thurgood 2017-01-02 10:39:01 UTC
*** Bug 104985 has been marked as a duplicate of this bug. ***
Comment 15 Alain Lafuente 2017-02-14 18:59:32 UTC
same with mac Under mac 10.10.5 The verification never ends
Comment 16 Julien Nabet 2017-02-14 19:01:31 UTC
Version must correspond to the oldest version the bug can be encountered.
Comment 17 Alex Thurgood 2017-02-17 10:22:13 UTC
*** Bug 106055 has been marked as a duplicate of this bug. ***
Comment 18 Libre 2017-09-07 05:39:56 UTC
While installing on Yosemite version 10.10.5

I found that Libreoffice 5.3.1 installs with no problems.When I check for updates it states from my ISP Execulink.ca "LibreOffice 5.3 is up to date." even though there are 2 higher versions 5.3.4 and 5.4.1.

Libreoffice 5.3.1 sha256 hash is 12003dac2c3b23e736f1c8500f47f99be0d5aaabc965e7a06fc2b695e2dd6d74

Libreoffice 5.3.4
f3b33e08c2671afc72d910c43d360fc3a5c28f522016fe4ad4c2641548f93a42

Libreoffice 5.4.1
ba0499e8f994ac514f18937a06b0c22c3971e031f402753038e26c42b4c0e0cc
Comment 19 Xisco Faulí 2017-10-27 11:08:00 UTC
*** Bug 101739 has been marked as a duplicate of this bug. ***
Comment 20 steve -_- 2017-11-26 00:28:15 UTC
This is happening to other software as well and I tend to think this is an apple bug specific to macOS 10.10.

Thoughts? Should we close this as NOTOURBUG?
Comment 21 Buovjaga 2017-11-26 11:54:17 UTC
(In reply to steve -_- from comment #20)
> This is happening to other software as well and I tend to think this is an
> apple bug specific to macOS 10.10.
> 
> Thoughts? Should we close this as NOTOURBUG?

Bisecting might bring more light, but as it would have to be done on 10.10, I don't think it will happen.

Comment 18 says 5.3.1 installs without the workaround on 10.10.

Can others confirm this?
Comment 22 caraffande 2017-11-26 12:08:22 UTC
No, for me the problem is still present. Version 5.4.2.2.
No other software with the same problem on my machine.
Comment 23 steve -_- 2017-12-10 10:43:57 UTC
@caraffande which version of macOS are you using and if you are on 10.10 are you planning on updating to a newer OS?
Comment 24 kisch 2017-12-29 16:00:11 UTC
I just ran into the same problems on MacOS 10.9.5,
trying to install LibreOffice 5.4.3.2 as well as 5.4.4.2 from the official libreoffice.org DMGs.
So it's not confined to MacOS 10.10.

Workaround from comment #3 saved the day.
Comment 25 steve -_- 2018-01-07 12:10:35 UTC
Maybe not confined to 10.10, but could still be confined to pre 10.11 and fixed in 10.11.
Comment 26 Tor Lillqvist 2018-06-28 10:30:27 UTC
As 10.10 is rather old by now I suggest downgrading the importance.
Comment 27 Caolán McNamara 2018-07-25 16:21:39 UTC
Lets take tml's advice here, we never figured what was wrong, but it works in contemporary releases of macOS