Download it now!
Bug 105012 - Tangut glyph orientation failed with OpenGL disabled
Summary: Tangut glyph orientation failed with OpenGL disabled
Status: RESOLVED DUPLICATE of bug 111444
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.beta2
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions Vertical-Text
  Show dependency treegraph
 
Reported: 2016-12-31 03:28 UTC by Volga
Modified: 2017-10-28 18:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Tangut N4694 V3.002 (4.05 MB, application/x-7z-compressed)
2017-01-04 10:22 UTC, Volga
Details
Tangut N4694 V3.003 (4.05 MB, application/x-7z-compressed)
2017-01-17 02:16 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2016-12-31 03:28:22 UTC
Description:
LibreOffice get proper glyph orientation for Tangut in bug 100936 on vertical layout, but it does not have any effect when OpenGL is disabled.

Steps to Reproduce:
1. Open attachment 128899 [details] with LODev 5.3.0 Beta2
2. Replacing the font face as Tangut N4694

Actual Results:  
When OpenGL is disabled, Tangut glyph looks sideways in vertical texts (see attachment 129889 [details]).

Expected Results:
Tangut glyph should be upright on vertical layout even if OpenGL is disabled.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Android 4.3; Mobile; rv:50.0) Gecko/50.0 Firefox/50.0
Comment 1 Buovjaga 2017-01-03 19:57:12 UTC Comment hidden (obsolete)
Comment 2 Volga 2017-01-04 10:15:47 UTC Comment hidden (obsolete)
Comment 3 Volga 2017-01-04 10:22:26 UTC
Created attachment 130145 [details]
Tangut N4694 V3.002

(In reply to Buovjaga from comment #1)
> (In reply to Volga from comment #0)
> > 2. Replacing the font face as Tangut N4694
> 
> Where can we get it? I tried getting it from http://ccamc.co/fonts.php link
> http://pan.baidu.com/s/1o80eDZG but the link has expired.

You can get the font directly from here.
Comment 4 Buovjaga 2017-01-04 19:56:16 UTC
Repro on Win, but not on Lin.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 1a58cdf8af1aba52ce0a376666dd7d742234d7cf
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 4th 2016

Win 10
Version: 5.4.0.0.alpha0+
Build ID: 7ed40deee74a9869b7da073ad473241187420ff8
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-30_23:18:54
Locale: fi-FI (fi_FI); Calc: group
Comment 5 Volga 2017-01-05 03:49:54 UTC
Then we need to investigate what prevent the proper layout on Windows.
Comment 6 Volga 2017-01-07 15:39:58 UTC
I have also found the problem with this ODT file if I used Tangut N4694, several characters is designed proportional, but they looks shifted to left within an em-box, see bug 104828.
Comment 7 Volga 2017-01-17 02:16:47 UTC
Created attachment 130486 [details]
Tangut N4694 V3.003
Comment 8 Volga 2017-01-28 13:18:06 UTC
(In reply to Volga from comment #5)
> Then we need to investigate what prevent the proper layout on Windows.

It seems to me that our GDI handles failed to process some special text oritation specified by our text layout engine.
Comment 9 Khaled Hosny 2017-03-03 13:37:00 UTC
Is this still an issue latest master/5-3 branches?
Comment 10 Volga 2017-03-03 22:36:02 UTC
Yes.
Comment 11 Khaled Hosny 2017-03-04 23:54:13 UTC
This is a limitation of Windows GDI and existing fonts; so far all Tangut fonts I have seen do not support vertical direction (lack the required tables) which causes GDI to not provide a vertical mode version of the font which in turn means GDI will render the glyphs rotated. There is nothing we can do here until Tangut fonts with vertical support are available. Note this will now happen even when OpenGL is disabled since we now route all vertical text through GDI to fix other vertical text bugs.
Comment 12 Volga 2017-03-05 22:09:47 UTC
On this page I found Tangut N4694 works fine on Firefox, so how does FF performanced?
https://wikisource.org/wiki/Tangut_Script_With_Chinese_Equivalents
Comment 13 Khaled Hosny 2017-03-05 22:55:21 UTC
Firefox does not use GDI, does it?
Comment 14 Volga 2017-03-20 13:54:53 UTC
I got the latest version of Tangut Yinchuan font, which added support for vertical text layout. But I still feel unhappy with GDI rendering.

Version: 5.3.1.2 (x64)
Build ID: e80a0e0fd1875e1696614d24c32df0f95f03deb2
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
Locale: zh-CN (zh_CN); Calc: group
Comment 15 Volga 2017-03-22 02:50:00 UTC
Hi Mark, can you reproduce with the latest version of Tangut Yinchuan font?
Comment 16 Volga 2017-03-30 03:53:57 UTC

*** This bug has been marked as a duplicate of bug 100936 ***
Comment 17 Xisco Faulí 2017-10-28 18:22:42 UTC

*** This bug has been marked as a duplicate of bug 111444 ***