Bug Hunting Session
Bug 111444 - Tangut chatacters do not rotate in vertical layout (Tangut Yinchuan)
Summary: Tangut chatacters do not rotate in vertical layout (Tangut Yinchuan)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 100936 105012 (view as bug list)
Depends on:
Blocks: Font-Rendering Vertical-Text
  Show dependency treegraph
 
Reported: 2017-08-07 16:04 UTC by Volga
Modified: 2017-12-13 04:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (9.59 KB, application/vnd.oasis.opendocument.text)
2017-08-07 16:07 UTC, Volga
Details
Snapshot (47.91 KB, image/png)
2017-08-07 16:07 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2017-08-07 16:04:53 UTC
Description:
When Tangut chatacters displaying in vertical layout, all of them failed to rotate, althrough Tangut Yinchuan font give support for vertical layout.


Steps to Reproduce:
1. Open LibreOffice Writer
2. Insert -> Frame -> Frame Interactively
3. Insert Tangut characters copied from https://en.wikipedia.org/wiki/Pearl_in_the_Palm
4. Select Tangut characters and set the font face as Tangut Yinchuan

Actual Results:  
When I enabled vertical text direction, Tangut characters looks sideways instead of upright on screen.

Expected Results:
According to http://www.unicode.org/Public/vertical/revision-17/, their vertical orientation properties (17000..187FF) are U, which means they should be upright in vertical writing modes.


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.3 (x64)
Build ID:7556cbc6811c9d992f4064ab9287069087d7f62c
CPU 线程:4; 操作系统:Windows 6.19; UI 渲染:默认; 
Locale: zh-CN (zh_CN); Calc: group

Tangut Yinchuan font available at BabelStone
http://www.babelstone.co.uk/Fonts/Yinchuan.html


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Comment 1 Volga 2017-08-07 16:07:07 UTC
Created attachment 135219 [details]
Test file
Comment 2 Volga 2017-08-07 16:07:58 UTC
Created attachment 135220 [details]
Snapshot
Comment 3 V Stuart Foote 2017-08-07 16:14:48 UTC
*** Bug 100936 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2017-08-07 16:17:14 UTC
And we'll set this to NEW
Comment 5 Volga 2017-09-23 17:22:45 UTC
This bug seems introduced in 5.3.2, which forced GDI rendering for vertical layout.
Comment 6 Xisco Faulí 2017-10-28 18:22:42 UTC
*** Bug 105012 has been marked as a duplicate of this bug. ***
Comment 7 Volga 2017-11-21 11:08:54 UTC Comment hidden (obsolete)
Comment 8 Volga 2017-12-07 06:02:09 UTC
Still reproduce in
Version: 6.1.0.0.alpha0+ (x64)
Build ID: 1d8cb97fea57b81a1ab151b88c2180e646bd401b
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-12-07_02:07:17
Locale: zh-CN (zh_CN); Calc: group threaded
Comment 9 Volga 2017-12-13 04:00:37 UTC
Fixed in 

Version: 6.0.0.0.beta2+ (x64)
Build ID: b030bf19e29f031b0a640dd92c38d654785f1a99
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86_64@42, Branch:libreoffice-6-0, Time: 2017-12-12_05:03:02
Locale: zh-CN (zh_CN); Calc: group threaded