Bug 105013 - time of digital signature is zero in File > Properties > General
Summary: time of digital signature is zero in File > Properties > General
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, needsDevEval, regression
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2016-12-31 05:31 UTC by Terrence Enger
Modified: 2019-07-30 22:56 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
details from bibisect-41max (4.28 KB, text/plain)
2016-12-31 05:31 UTC, Terrence Enger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Terrence Enger 2016-12-31 05:31:37 UTC
Created attachment 130048 [details]
details from bibisect-41max

STR
---
(0) Download test.odt attached to tdf#104795.

(1) Open test.odt from the command line.  Program displays Writer
    window.

(2) Take menu options File > Properties and navigate to tab General.
    Program displays dialog Properties with property "Digitally
    signed" ...

    Observed : The time of digital signature is 00:00:00.

    Expected : The time of Digital Signature should be 23:06:31.
               Alternatively, the time should not be shown at all.

Note for comparison that the time of day of the signature is included
in dialog "Digital Signatures" accessible via the button <Digital
Signatures> on this tab or via menu options File > "Digital
Signatures".

I see this behaviour in daily build

    Version: 5.4.0.0.alpha0+
    Build ID: ea860d52ade14b4a16289c81a0f8586799c6617f
    CPU Threads: 2; OS Version: Linux 4.8; UI Render: default; VCL: x11; 
    TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master,
        Time: 2016-12-31_01:52:05
    Locale: en-CA (en_CA.utf8); Calc: group

and in a range of about 14 commits in bibisect-41max:

          commit    s-h       date
          --------  --------  -------------------
    good  b0245924  5aaaf069  2013-04-18 19:03:10
    bad   aee0ea18  824caac7  2013-04-18 21:29:29

I am setting keywords regression, bibisected.
Comment 1 Terrence Enger 2016-12-31 05:46:47 UTC
Setting importance minor because this seems to be the only bug report
in 3-1/2 years.

Adding keyword needsDevEval, just a guess that this might not be too
hard to fix.
Comment 2 Terrence Enger 2016-12-31 06:10:11 UTC
Do not worry about the !!br0ken!! email address in tab General: it has
already been reported in tdf#104795.

After ignoring the assertion failures reported in tdf#105011, I also
see the zero time-of-day in
    Version: 5.4.0.0.alpha0+
    Build ID: 0c565095983b0cc8b96a78012c611b7a03962204
    CPU Threads: 2; OS Version: Windows 6.0; UI Render: default; 
    TinderBox: Win-x86@39, Branch:master, Time: 2016-12-16_01:40:04
    Locale: en-CA (en_CA); Calc: group
so I am setting O/S = All.
Comment 3 Jacques Guilleron 2017-01-01 10:00:10 UTC
Hi Terrence,

Confirmed with same steps in:
LO 5.4.0.0.alpha0+ Build ID: 5903235d57acb13d9d5286d23b443a01aeab9a3c
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-19_00:08:35
Locale: fr-FR (fr_FR); Calc: CL
and Windows 7 Home.

All my wishes for this new year,

Jacques
Comment 4 Terrence Enger 2017-03-10 14:59:44 UTC
@xisco,

I do not know how to map source hash 5aaaf069 to a LibreOffice version
number, but I think that current master cannot be right.
Comment 5 Xisco Faulí 2017-03-10 15:08:47 UTC
(In reply to Terrence Enger from comment #4)
> @xisco,
> 
> I do not know how to map source hash 5aaaf069 to a LibreOffice version
> number, but I think that current master cannot be right.

oh, I didn't read this part: and in a range of about 14 commits in bibisect-41max...
Comment 6 Samuel Mehrbrodt (CIB) 2017-06-28 09:05:58 UTC
Probably regression from 9830fd36dbdb72c79703b0c61efc027fba793c5a
Comment 8 QA Administrators 2018-09-14 02:46:48 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2018-09-14 09:06:26 UTC
still repro in LO 6.1.1.1
Comment 10 Oliver Brinzing 2019-07-26 14:58:11 UTC
reproducible with LO 6.1.6.3 but no longer with:

Version: 6.2.5.2 (x64)
Build ID: 1ec314fa52f458adc18c4f025c545a4e8b22c159
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (de_DE); UI-Language: en-US
Comment 11 Terrence Enger 2019-07-30 22:56:11 UTC
I too see the expected time of signature in local build of master from
2019-07-15.  I am setting status VERIFIED WORKSFORME.