Bug Hunting Session
Bug 105058 - English US Dictionary is outdated
Summary: English US Dictionary is outdated
Status: RESOLVED DUPLICATE of bug 89695
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-03 00:55 UTC by phly95
Modified: 2017-01-03 15:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phly95 2017-01-03 00:55:45 UTC
Description:
The English US dictionary hasn't been updated since 2011. This means there are plenty of new words that aren't in the LibreOffice spellcheck dictionary such as the words:
cyberattack, iPhone, Xbox, Uber, Lyft, TechCrunch, and many, many more.
Microsoft Word recognizes all of these words natively. 

Speaking of which, "natively" is also not in the LibreOffice dictionary.

Steps to Reproduce:
1. Enable US English Dictionary
2. Type in cyberattack, iPhone, Xbox, Uber, Lyft, TechCrunch, or natively
3. According to LibreOffice, these words don't exist

Actual Results:  
Words are marked incorrectly with no correct spelling suggestions.

Expected Results:
Words should be marked correctly or if typed incorrectly, these words should be given as suggestions.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 V Stuart Foote 2017-01-03 14:40:06 UTC
(In reply to phly95 from comment #0)

> The English US dictionary hasn't been updated since 2011.

Not correct.

https://cgit.freedesktop.org/libreoffice/dictionaries/tree/en

However the additional words are probably valid entries to add. And the infrastructure for the thesaurus list and UI could use some attention as well (see bug 99999).

=-ref-=

https://cgit.freedesktop.org/libreoffice/dictionaries/commit/en/en_US.dic?id=c875ba1abbe81955d5510aef909a62c01d4515de

https://cgit.freedesktop.org/libreoffice/dictionaries/commit/en/en_US.dic?id=2f0ddaeeb4323ac99afd35d2c4fda643c9ee8bcf
Comment 2 V Stuart Foote 2017-01-03 14:45:13 UTC

*** This bug has been marked as a duplicate of bug 89695 ***
Comment 3 Marco A.G.Pinto 2017-01-03 15:48:46 UTC
Hello!

I update the GB speller monthly:
https://github.com/marcoagpinto/aoo-mozilla-en-dict

In the GitHub above there are also the most recent version of US, CA and AU done by Kevin Atkinson.

I am planning to submit them to Gerrit in my next update.

What I am scared of is that someone will always complain about a word here and there, and will take months to give a +2 (the time taken for my GB to be approved was enough for me to release a couple of new versions or so).

So, when is the proper date for me to submit GB+US+CA+AU and it be approved in good time?

Thanks!

Kind regards,
    >Marco A.G.Pinto
     ---------------