Bug 105096 - calc file doesn't attach to email
Summary: calc file doesn't attach to email
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.2.5
Keywords: bibisected, regression
: 86922 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-01-04 12:17 UTC by Istvan Pasztor
Modified: 2018-02-04 15:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Istvan Pasztor 2017-01-04 12:17:30 UTC
Description:
From calc menu : File->Send->[EmailDocument,Email as XLS] 
the file isn't attached to thunderbird 45.5.1, on ubuntu 14.04LTS.

Steps to Reproduce:
1. Open a document
2. Go to File->Send->[EmailDocument,Email as XLS] 
3. See the result in opened thunderbird frame.

Actual Results:  
The file is not attached

Expected Results:
The file had to attach.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36
Comment 1 Buovjaga 2017-01-05 10:48:14 UTC
It works on Windows 7, for what it's worth. Same version of Thunderbird and LibreOffice.
Comment 2 Justin L 2017-01-05 13:21:17 UTC
used daily_dbgutil_bibisect and Ubuntu 16.04 to see that this was fixed in 5.3

> author Caolán McNamara <caolanm@redhat.com>	2016-09-13 09:42:16 (GMT)
> commit 5f58670b43e5284d9460b561e774175c7a2dd7ab
>   add xdg-email as the default email route because xdg-email is apparently the
>   only route that knows how to support adding an attachment to thunderbird

CC to Caolán McNamara in case he wants to backport this to 5.2.
Comment 3 Justin L 2017-01-05 13:24:45 UTC
This worked still in 5.0.  

Likely broken by author Bjoern Michaelsen <bjoern.michaelsen@canonical.com> 2015-10-16 11:15:55 (GMT)  commit 3cf557c12d27f1b2250e69a543136da098112d80
  drop gconf integration as per ESC decision
Comment 4 Commit Notification 2017-01-05 21:36:18 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69954cc174f10fbf511a1aa14cf784e54259861c&h=libreoffice-5-2

Resolves: tdf#105096 add xdg-email as the default email route

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Cor Nouws 2018-02-04 15:20:27 UTC
*** Bug 86922 has been marked as a duplicate of this bug. ***