Download it now!
Bug 105129 - ".~lock files" constantly opening and slowing performance on all windows systems, not in Linux system.
Summary: ".~lock files" constantly opening and slowing performance on all windows syst...
Status: RESOLVED DUPLICATE of bug 104830
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-05 18:29 UTC by K-Bob
Modified: 2017-07-11 08:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["TransformItems(unsigned short,SfxItemSet const &,com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> &,SfxSlot const *)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description K-Bob 2017-01-05 18:29:22 UTC
Description:
.~lock files keep coming up and slowing things down whenever I open a file. I think it was from opening files created in Office XP Professional, mostly .doc, or maybe even .rtf. I was working on some customer computers, and they had MS Office XP Professional, with the "Compatibility Pack" that allows them to read .docx etc. from newer versions of M.S. Office from what I understand. It seems ever since working with these files I have had this issue, and LibreOffice still works but performance is bad. Now it seems ".~lock files" are opening on files that were not part of the original problem, but all, and on all my windows installations. This is not happening on my Linux Machines. Here is one of the "bug reports" I sent: crashreport.libreoffice.org/stats/crash_details/488e487e-8420-4e49-b4a9-2246280c2a70

Appologies, I sent multiple bug reports because I was so irritated. Never again will I open a file created on one of those machines. 

Steps to Reproduce:
1.Just opening a ".docx", ".doc" or ".rtf" file
2.Seems to happen randomly
3.

Actual Results:  
None

Expected Results:
None


Reproducible: Always

User Profile Reset: No

Additional Info:
None


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Buovjaga 2017-01-13 12:20:39 UTC
What do you mean "keep coming up"? Lock files are created for every file that you open in LibreOffice, it is perfectly normal. This happens on all operating systems, Windows, Linux..

How is that crash report related to the lock files?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 2 K-Bob 2017-01-17 03:29:25 UTC
What information do you want?  You have the crash report and the best description I can give you.  I get constant crashes opening files, all types of files.  This after Uninstalling, Deleting all LibreOffice Folders and reinstalling.  Isn't the info you need in the crash report?
Comment 3 K-Bob 2017-01-17 03:31:21 UTC
(In reply to K-Bob from comment #2)
> What information do you want?  You have the crash report and the best
> description I can give you.  I get constant crashes upon closing files, all types
> of files it seems.  This after Uninstalling, Deleting all LibreOffice Folders and
> reinstalling.  Isn't the info you need in the crash report?
Comment 4 K-Bob 2017-01-17 03:33:09 UTC
Whoops, sorry, I was trying to Edit a post. The issue I am having is then Closing a file, and often multiple files are being Recovered upon restart, or something to that effect.
Comment 5 Julien Nabet 2017-01-17 20:33:25 UTC
Just to be sure, if you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows) and work on brand new file (at least not with files from Ms Office compat...), is it ok?
Comment 6 K-Bob 2017-01-22 18:44:16 UTC
Thanks Julien Nabet, I did the Re-naming thing in the Wiki you provided when this all started, but did not consider creating a new document and testing it that way.  I will follow up ASAP, good thing is it still works. Some of this seems to be subsiding, I now see that some of these files are from Linux L.O. and there is no problem there. Some of the docs I had issues with, I did a Select all, and "Clear Direct Formatting" and that also seems to have fixed some of them. I had no issues with M.S. Office docs, Until using the Windows XP Professional and Office 2003 Professional with the "Compatibility Pack" on some other machines.

I was doing some work on customers pc's, gathering information on Specs etc for re-installs.  Using the XP Word Processor to do this. Do you have suggestions how to do this and avoid the problems? After having issues started only using rtf and text doc's.  Should I use a Portable L.O. or just keep using rtf and text, preferably "rtf" because the limits of "Text" files?

Thanks! Sorry my feedback is not all that good, my health is suffering.  I don't know if this classifies as a Bug at this point, but it surely is a problem with Windows XP Professional and Office 2003 Professional with the "Compatibility Pack" IMO, as that is the only time I have ever had issues with Word docs this bad. Some little compatibility issues with msoffice that are to be expected, but nothing like this.
Comment 7 Julien Nabet 2017-01-25 20:55:37 UTC
K-Bob: you can use odt format, the native LO Writer format. I think any recent MsOffice version is compatible with it.
Comment 8 Xisco Faulí 2017-07-11 08:33:32 UTC
The crash report is the same as in bug 104399 which is a duplicated of bug 104830. Closing this one as DUPLICATED as well.

*** This bug has been marked as a duplicate of bug 104830 ***