Bug Hunting Session
Bug 104399 - Crash in: TransformItems(unsigned short,SfxItemSet const &,com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> &,SfxSlot const *)
Summary: Crash in: TransformItems(unsigned short,SfxItemSet const &,com::sun::star::un...
Status: RESOLVED DUPLICATE of bug 104830
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.4.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.2 target:5.2.5
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-04 19:50 UTC by Roman Kuznetsov
Modified: 2017-01-09 05:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature: ["TransformItems(unsigned short,SfxItemSet const &,com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> &,SfxSlot const *)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2016-12-04 19:50:39 UTC
This bug was filed from the crash reporting server and is br-101564fc-79d5-4f91-bd1f-5db6b123b708.
=========================================

crash LibreOffice Writer AFTER i closed it
Comment 1 Xisco Faulí 2016-12-05 16:09:39 UTC Comment hidden (obsolete)
Comment 2 Markus Mohrhard 2016-12-28 23:51:15 UTC
This is another case of the crash on shutdown related to the clipboard handler.
Comment 3 Commit Notification 2016-12-29 18:25:01 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db1726216ba200c8a55c23a9d8c2ffd2066263a7

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Pierre C 2016-12-30 12:08:20 UTC
LO often crashes after closing a document. not always, and not predictable.
Comment 5 Commit Notification 2017-01-05 19:39:52 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdd309c23de58af306450edfac5d3e74e5c2a913&h=libreoffice-5-3

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-01-05 20:35:52 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9c3998c2260995cccce060d1226b47ac2dc8c2d&h=libreoffice-5-2

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Markus Mohrhard 2017-01-09 05:03:06 UTC

*** This bug has been marked as a duplicate of bug 104830 ***