Bug Hunting Session
Bug 104969 - Crash in: ScTransferObj::~ScTransferObj()
Summary: Crash in: ScTransferObj::~ScTransferObj()
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.0 target:5.3.0.2 target:5.2.5
Keywords:
: 102936 104924 105030 105097 105252 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-28 23:11 UTC by Stefan_Lange_KA@T-Online.de
Modified: 2018-01-16 09:27 UTC (History)
10 users (show)

See Also:
Crash report or crash signature: ["ScTransferObj::~ScTransferObj()"]


Attachments
Test sheet document to reproduce the crash (163.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-12-29 09:26 UTC, Stefan_Lange_KA@T-Online.de
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan_Lange_KA@T-Online.de 2016-12-28 23:11:39 UTC
This bug was filed from the crash reporting server and is br-2b8c1af2-20b9-41a0-91f5-4226c1db7c8a.
=========================================

Crash in LO 5.3.0 RC1
Version: 5.3.0.1 (x64)
Build-ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; Layout-Engine: neu; 
Gebietsschema: de-DE (de_DE); Calc: group

What happened?
I have edited a sheet document. When all was done I have saved and closed it without any problems.
LO 5.3.0 remained open with no opened documents. When I have closed the programm the crash occured.

I think that this crash is not important because of no data are lost or destroyed. But because it happens frequently, it is annoying. Unfortunately I have no way to reproduce the crash at this time.
Comment 1 Stefan_Lange_KA@T-Online.de 2016-12-29 09:26:01 UTC
Created attachment 129996 [details]
Test sheet document to reproduce the crash

With the attached file the crash can be reproduced:
- start LO 
- open the file
- go to sheet "Altix IV und V"
- insert a new row before row 6
- copy row 7 to clipboard and paste it into row 6
- save or save as the document 
- close the document
- close LO --> LO crashes

other behavior, when the same is done in sheet "Altix I bis III" (insert row, copy + paste row, save or save as + close the document, close LO): 
LO doesn't crash, but after LO is closed, 2 processes remain opened (visible in the Task Manager).
When one then tries to start LO (one time or repeatedl)y, it seems that LO doesn't start, but in the Task Manager appear 4 or more Libre Office processes, belonging pairwise one to anoter. Only when the "old" processes are cancelled in the Task Manager, LO really opens. It says, that it was terminated not normally last time and produces a crash report, see 
crashreport.libreoffice.org/stats/crash_details/0dc37319-2e36-4ba2-8b8d-f6231a1aaabc
Comment 2 Stefan_Lange_KA@T-Online.de 2016-12-29 12:19:43 UTC
Simple way to reproduce the crash:
- open LO
- File -> New -> Spreadsheet
- enter something in cell A1
- copy cell A1 into clipboard
- paste clipboard content into any other cell (e.g. A2 or B1)
- save the document and close LO --> crash

The crash can be reproduced with LO 5.3.0 RC1 and also with LO 5.4.0 alpha0+, but not with LO 5.2.4.2.

Version: 5.4.0.0.alpha0+
Build ID: d0288a482a3dc0f50f535565e4c66a95bb140942
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-26_23:25:18
Locale: de-DE (de_DE); Calc: group
Comment 3 Commit Notification 2016-12-29 18:23:02 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db1726216ba200c8a55c23a9d8c2ffd2066263a7

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Stefan_Lange_KA@T-Online.de 2016-12-30 09:25:47 UTC
I have tested with
Version: 5.4.0.0.alpha0+
Build ID: a7c51323b7343f82b5aea6098f5d5e31a8bad0e9
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-29_23:35:20
Locale: de-DE (de_DE); Calc: group

The test was only partially successful:

Result 1:
The crashes produced with the "simple way" described in Comment_2 and with sheet "Altix IV und V" in the test file "Testtabelle_Abbruch_Close_LO_V4.ods" (Comment_1, upper section) occur no longer. Very good!

Result 2:
The "other behavior" described in the lower section of Comment_1 still remains. Shutdown of LibreOffice is not completed: 2 processes remain "active" and hinder a new start of the programm. Not so good!

Shall I report a new bug for the second case ("other behavior")? Regardless, I will try to find a simpler way to reproduce this case.
Comment 5 Stefan_Lange_KA@T-Online.de 2016-12-30 17:20:47 UTC
Simple way to reproduce the case "other behavior" (Shutdown LO hangs):
- open LO
- File -> New -> Spreadsheet
- enter something in cell A1
- insert a comment to cell A1 (this is the difference to the first case)
- copy cell A1 into clipboard
- paste clipboard content into any other cell (e.g. A2 or B1)
- save the document and close LO --> Shutdwon of LO hangs: LO Windows is closed, but in the task manager remain 2 processes and hinder a new start of LO

reproduced with LO 5.3.0 RC1 and with LO 5.4.0
Version: 5.4.0.0.alpha0+
Build ID: a7c51323b7343f82b5aea6098f5d5e31a8bad0e9
CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-29_23:35:20
Locale: de-DE (de_DE); Calc: group
Comment 6 Markus Mohrhard 2017-01-02 19:20:38 UTC
(In reply to Stefan_Lange_KA@T-Online.de from comment #4)
> I have tested with
> Version: 5.4.0.0.alpha0+
> Build ID: a7c51323b7343f82b5aea6098f5d5e31a8bad0e9
> CPU Threads: 1; OS Version: Windows 6.19; UI Render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2016-12-29_23:35:20
> Locale: de-DE (de_DE); Calc: group
> 
> The test was only partially successful:
> 
> Result 1:
> The crashes produced with the "simple way" described in Comment_2 and with
> sheet "Altix IV und V" in the test file
> "Testtabelle_Abbruch_Close_LO_V4.ods" (Comment_1, upper section) occur no
> longer. Very good!
> 
> Result 2:
> The "other behavior" described in the lower section of Comment_1 still
> remains. Shutdown of LibreOffice is not completed: 2 processes remain
> "active" and hinder a new start of the programm. Not so good!
> 
> Shall I report a new bug for the second case ("other behavior")? Regardless,
> I will try to find a simpler way to reproduce this case.

Yes, please make it a new bug report. This one is about the ScTransferObj crash and the other one would be about the ScPostIt crash.
Comment 7 Stefan_Lange_KA@T-Online.de 2017-01-02 19:59:12 UTC
I have bug 105055 for the second case.
Comment 8 Xisco Faulí 2017-01-02 22:33:18 UTC
*** Bug 105055 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2017-01-02 22:36:09 UTC
*** Bug 105030 has been marked as a duplicate of this bug. ***
Comment 10 Stefan_Lange_KA@T-Online.de 2017-01-02 23:30:24 UTC
I don't know enough about the internals and can't evaluate if bug 105055 is a duplicate of bug 104969 really or not.

Originally bug 105055 (Shutdown of LO hangs) was part of bug 104969, because I have produced both cases with the same test document - see comments 1, 2 and 5!

The ways to reproduce both problems are nearly the same (copy + paste a cell without or with inserted comment) but the results are different:

1. copy + paste cell without comment --> LO crashes while shutdown --> fixed by patch from Markus Mohrhard in LO 5.4.0 (see comment_3)

2. copy + paste cell with comment --> shutdown of LO hangs and new start of LO is hindered --> not fixed by the patch!!!

Therefore I have reported the new bug 105055 for the second case, see also the last sentence in comment 6 from Markus Mohrhard!
Comment 11 Markus Mohrhard 2017-01-04 14:49:23 UTC
*** Bug 105097 has been marked as a duplicate of this bug. ***
Comment 12 V Stuart Foote 2017-01-04 15:54:18 UTC Comment hidden (obsolete)
Comment 13 Pedro 2017-01-04 16:00:18 UTC
(In reply to V Stuart Foote from comment #12)
> *** Bug 105097 has been marked as a duplicate of this bug. ***

I was a bit confused :)

So this is fixed in Master? I hope it is cherry picked for 5.3.0.2
I know there is no data loss but it undermines the stability image of LibreOffice...
Comment 14 V Stuart Foote 2017-01-04 16:03:04 UTC
Hmm, so Status showed Assigned but with no assignee.

anyhow cherry picks are in for review

5.3
https://gerrit.libreoffice.org/#/c/32667/1

5.2
https://gerrit.libreoffice.org/#/c/32668/1

...to Resolved Fixed
Comment 15 Buovjaga 2017-01-05 13:22:48 UTC
Testing was requested, so: no crash here.

Version: 5.4.0.0.alpha0+
Build ID: 3afe82bd63fde41d2a88418fb64e4ff587b05436
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-04_23:42:57
Locale: fi-FI (fi_FI); Calc: group
Comment 16 Commit Notification 2017-01-05 19:39:33 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdd309c23de58af306450edfac5d3e74e5c2a913&h=libreoffice-5-3

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.3.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2017-01-05 20:35:36 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f9c3998c2260995cccce060d1226b47ac2dc8c2d&h=libreoffice-5-2

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399

It will be available in 5.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Aron Budea 2017-01-08 22:40:21 UTC
Just for reference, this crash originated from the commit referenced below, a fix for bug 103852:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=c53cf1dfc5eacd8fee6b2b549ec6b59ad927e01c
Comment 19 JoNi 2017-01-09 14:12:33 UTC
*** Bug 104924 has been marked as a duplicate of this bug. ***
Comment 20 Markus Mohrhard 2017-01-11 11:21:14 UTC
*** Bug 105252 has been marked as a duplicate of this bug. ***
Comment 21 Stefan_Lange_KA@T-Online.de 2017-01-13 17:05:52 UTC
I have tested with

Version: 5.3.0.1.0+
Build-ID: 4c8be6327f6d71d426bbf9887fd7d8a24ffd06a3
CPU-Threads: 4; BS-Version: Windows 6.2; UI-Render: Standard; Layout-Engine: neu; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2017-01-13_13:05:28
Gebietsschema: de-DE (de_DE); Calc: group

and with

Version: 5.2.5.1 (x64)
Build-ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group

Results of both tests: OK! LO crashes no longer.
Comment 22 Buovjaga 2017-01-13 17:34:21 UTC
Great, now we have verification for all branches.
Comment 23 Xisco Faulí 2017-01-16 19:30:16 UTC
*** Bug 102936 has been marked as a duplicate of this bug. ***