Bug 105140 - HSQLDB: Aggregate functions don't work - COLLECT, FUSION, INTERSECTION
Summary: HSQLDB: Aggregate functions don't work - COLLECT, FUSION, INTERSECTION
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Database-HSQLDB
  Show dependency treegraph
 
Reported: 2017-01-06 09:25 UTC by Robert Großkopf
Modified: 2020-09-26 11:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Open the database. 3 queries - all do not work because the functions aren't supported. (5.58 KB, application/vnd.oasis.opendocument.database)
2017-01-06 09:25 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2017-01-06 09:25:09 UTC
Created attachment 130193 [details]
Open the database. 3 queries - all do not work because the functions aren't supported.

While testing queries for Firebird I have reported bug105112. The behavior there is similar to the behavior of HSQLDB:
There are functions you could chose in the GUI, which are unknown in the internal database. For HSQLDB these functions are COLLECT, FUSION and INTERSECTION. 

There has been a report (bug90686) closed as RESOLVED NOTABUG. A better solution would be only to show the functions, which will be available for the internal database. Users, who have the first contact with Base, will use the internal database and don't know much about functions. For those people the GUI is created.

People, who will connect Base with an external database, will have more experience. The will know how to write down a special function in SQL directly and don't need the creation through GUI.

Currently we have a GUI, that should make it easier for users, but confuses with special functions, which (could be I 'm not right) are special ORACLE-functions.

1. Solution: Put away COLLECT, FUSION and INTERSECTION
2. Solution: For internal database only show the functions, which will work with them, so a special GUI for HSQLDB and Firebird is needed.
Comment 1 Robert Großkopf 2017-01-06 09:27:22 UTC
I have set this to an ask for an enhancement, because it would make the GUI more usable but works at this moment as expected - with errors in the internal database.
Comment 2 Alex Thurgood 2017-01-06 10:50:45 UTC
Seems reasonable to me - we already do this for the LO dbf driver which has a limited function set compared to others in use in other products. This limited function set is also visible in the GUI.