Bug 90686 - FUSION and COLLECT functions are not supported by HSQLDB (shouldn't be on the Query Design View)
Summary: FUSION and COLLECT functions are not supported by HSQLDB (shouldn't be on the...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-17 21:09 UTC by mrmister001
Modified: 2015-04-18 01:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrmister001 2015-04-17 21:09:56 UTC
Hello,
I've been searching actively help about this topic in several forums and as far as I know FUSION and COLLECT functions are not supported by HSQLDB 1.8, so basically they shouldn't be there (in the query design view), because they are not supported, you cannot use them, and them are useless.
I think I am a 90% sure, however I have my 10% of doubts. I have confirmed this information in several forums, so I am almost certain this is a bug and it should be solved ASAP.
If I am wrong, instead of giving me a bunch of documentation, I'd really appreciate someone attach a demo database with a piece of HSQLDB code showing that FUSION and COLLECT functions are usable in LibreOffice and supported by HSQLDB 1.8
If not, this is a bug, and those functions should be removed from the drop down list in the query design view.
Comment 1 m.a.riosv 2015-04-17 23:08:33 UTC
Hi mrmister001,

please this is an open project, not too much friendly on how you request for your solution, usually it's fine think twice what one is writing, we are volunteers not your servants.

As expert you must know that Base it's not a database engine itself, but a bridge to connect with database engines, being HSQLDB embedded with LibreOffice.

In this situation, query design view it's not specific for HSQLDB, but for all databases that can be connect from Base, nearly all. As there is now way for Base to know about what SQL capabilities are available for every database engine, they must be available.

So you need to study the documentation for the database engine to use.

If you feel you are able to patch the LibreOffice code to get it:
http://www.libreoffice.org/community/developers/

You can't find samples?, then trial and error perhaps is the way.

OTOH this is not the right place to ask for help, if you can't find help in LibreOffice and AOo forums, maybe would be better try with places like specialized SQL forums.
Comment 2 mrmister001 2015-04-18 01:52:52 UTC
m.a.riosv:
I think I've worked with you in the past, showing an error in the LibreOffice Base queries, when they were translated to spanish, they used to produce an error in certain conditions. You solved that problem I think, not very sure about that.

Sorry, you said something that hurted me, so I have to reply you.
Let's talk about servants.
Due I'm cultured enough to know slavery ended centuries ago, let me tell you that your phrase "we are volunteers not your servants" is totally out of scope. This is not a help forum, this is to show bugs. In fact, that is personal remark, out of the scope. A personal remark because you totally missunderstood the sense of my message, and you launched me a dart. Sad.
Personal commentaries, ironies, and so on, hurt people.

Then you said "As expert"... sorry, no, I am not an expert.

******************************************************************
Here is the part of your message that clearly explain the problem:
******************************************************************
In this situation, query design view it's not specific for HSQLDB, but for all databases that can be connect from Base, nearly all. As there is now way for Base to know about what SQL capabilities are available for every database engine, they must be available.

Is exactly what you say. Of course, I did not realice that before. Yes, you are right. 
I missunderstood the sense of Base. You can use different database engines, so these functions must be available, even if database engine by default don't allow these functions.

Whith those 4 lines you wrote, everything would have been clarified.
But really, talking about servants and people, and ironies like that, is out of the sense of the message. 
I don't consider myself a King neither the rest of the people must serve me.
Just for your information.
* Peace *