Bug Hunting Session
Bug 105176 - SIDEBAR: Line width preset drop down control only shows size in points
Summary: SIDEBAR: Line width preset drop down control only shows size in points
Status: RESOLVED DUPLICATE of bug 72662
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: implementationError
Depends on:
Blocks: Sidebar-Properties-Line
  Show dependency treegraph
 
Reported: 2017-01-07 15:49 UTC by bordfeldt
Modified: 2019-03-07 21:15 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
sidebar linebar properties line width (59.15 KB, image/jpeg)
2017-01-07 15:50 UTC, bordfeldt
Details
Writer table properties dialog (119.78 KB, image/jpeg)
2018-02-04 15:34 UTC, bordfeldt
Details
Line porperties - line width in cm and not in points (128.12 KB, image/png)
2019-03-07 17:36 UTC, bordfeldt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bordfeldt 2017-01-07 15:49:58 UTC
Description:
In Draw in the sidebar in the line-properties section the line width is displayed in points although in options -> LO Draw -> General the unit of measurement is set to centimeters.  

Steps to Reproduce:
1. Open an new draw file.
2. Draw a line.
3. Try to change the line width with the sidebar.
4. Measures are in points not in centimeters.

Actual Results:  
line width shown in points although in the options the unit of measurement ist set to centimeters

Expected Results:
sidebar properties should show the units according to the properties made in options


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 bordfeldt 2017-01-07 15:50:47 UTC
Created attachment 130241 [details]
sidebar linebar properties line width
Comment 2 Buovjaga 2017-01-13 18:05:49 UTC
Confirmed.

I guess it can be called implementationError as it's a new thing in Sidebar.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 57779b5f3a49fedd952aed70ddcce22f48b98ea5
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 13th 2016
Comment 3 Yousuf Philips (jay) (retired) 2017-01-19 13:57:15 UTC
There are a few other places through the sidebar where the measurements arent the same as the user set measurement unit, like the margin and spacing drop down lists in the page deck. Having the unit part calculated for every possible measurement unit that a user can select isnt a really good option in my view. @UX: Any input?
Comment 4 Heiko Tietze 2017-01-19 14:53:35 UTC
(In reply to Yousuf Philips (jay) from comment #3)
> There are a few other places through the sidebar where the measurements
> arent the same as the user set measurement unit, like the margin and spacing
> drop down lists in the page deck. Having the unit part calculated for every
> possible measurement unit that a user can select isnt a really good option
> in my view. @UX: Any input?

Unifying the units is on out the todo list. In bug 72662 it's argued why units have to be different and in bug 44267 a more precise input including conversion feature is requested.
Comment 5 Yousuf Philips (jay) (retired) 2017-02-04 14:19:28 UTC
So lets make this bug fix the main issue from the bug description, as i'm for that.

Probably we could change the labels from exact point values to size values like extra thin, thin, small, medium, large, extra large. But the custom line width field would most definitely need to be fixed.

From an a11y perspective, opening and selecting a value in the popup causes focus to go to an unknown location in the sidebar and i cant tab to the next field and only alt+tab twice gets the control focus again, so i would be in favour of replacing the control is a standard drop down list. @Alex, @Brandon, @Stuart: What's is your take on this?
Comment 6 bordfeldt 2018-02-04 15:33:37 UTC
Problem still present in 6.0.0.3. There are some more places where differnt units of measurement are used: i.e. in the table properties dialog in writer (see attached screenshot). I think it's confusing for users to work with different units.
Comment 7 bordfeldt 2018-02-04 15:34:30 UTC
Created attachment 139574 [details]
Writer table properties dialog
Comment 8 Buovjaga 2018-05-28 10:47:11 UTC
*** Bug 115266 has been marked as a duplicate of this bug. ***
Comment 9 Luke 2019-03-04 17:29:17 UTC
The natural unit for line width is point. This is the accepted, natural unit across multiple applications and fields. The current sidebar behavior is correct. The bug here is the inconsistency, which would be resolved by fixing bug 72662

*** This bug has been marked as a duplicate of bug 72662 ***
Comment 10 Heiko Tietze 2019-03-05 07:51:56 UTC
(In reply to Luke from comment #9)
> The natural unit for line width is point.

At least we face a (minor) inconsistency with an option that is not applied correctly. Or do you have a good use case to change pt into cm, mr. bordfeldt?
Comment 11 bordfeldt 2019-03-07 17:35:16 UTC
Hello Heiko, now I see a little bit clearer.

I think font height, table borders, line width and so on should be in points.

The measurements of graphical objects like images, rectangles and so on should be in the localised measurement unit, i.e. cm in german.

The problem for me are still the inconsistencies i.e. table borders in points, line width in cm. See attached screenshot.

There are two further problems with the line properties in cm:
1. The default line width is 0,0 cm. The line should be invisible, but is visible. So the default line width should be i.e. 0,05 cm. The next problem resulting out of this, that the line is visible on the monitor but invisible on paper, after printing the document.
2. The default step to increase the line width is 0,1 cm which is to big. Is there a possibility to set this step in options?

Perhaps these problems are solved by changing the unit to points.
Comment 12 bordfeldt 2019-03-07 17:36:26 UTC
Created attachment 149805 [details]
Line porperties - line width in cm and not in points
Comment 13 Luke 2019-03-07 21:15:12 UTC
0,00 cm. is the precision issue. Two decimal places is not enough precision to represent line width in inches or cm. See Bug 44267


This among other reasons is why every other Office Suite uses points for line width, line spacing, and font size. See bug 72662 for a further discussion on changing the unit for these types.