Bug 105193 - Extreme slowness when copying and pasting browser images.
Summary: Extreme slowness when copying and pasting browser images.
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Paste Writer-Images
  Show dependency treegraph
 
Reported: 2017-01-08 18:35 UTC by Raphael
Modified: 2017-07-05 00:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Text and image copied (178.71 KB, image/png)
2017-01-08 18:42 UTC, Raphael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raphael 2017-01-08 18:35:29 UTC
Description:
When copying and pasting text with images, from wikipedia for example, considering a text of 374 words and 2387 characters and a png image of 11.4kb, the writer takes ~ 158 seconds, in calc the same selection takes ~ 154 seconds, the image Is not downloaded properly in the writer and calc the image is not displayed, times are extremely above normal, knowing that the pc is well above the minimum requirements, and the internet plan is 15Mb.

Resolving this bug can be a good optimization since many users use this form of copying and pasting to shorten times.
And it's a bug that has been reported at other times by multiple users using older versions.

If you copy and paste the hd image, LibreOffice does not have this problem.
In other LibreOffice apps only text is downloaded in ~ 2 seconds, including Impress.

Steps to Reproduce:
1. Open the browser.
2. Open the wikipedia or other sites, copy and paste.
3. Writer or Calc will stop for 2 minutes

Actual Results:  
Os resultados atuais são velocidades impraticáveis no ambiente pessoal e ambientes empresariais principalmente.

Expected Results:
The software should copy and paste from the web or other places, making your core work as fast as possible, something between 0 and 2 seconds, being limited only by the features of the environment as an example in an old computer or extremely slow internet.


Reproducible: Always

User Profile Reset: Yes

Additional Info:
Processor: Q9300
Os: Debian Linux 8.6 x64
Browser: Firefox 50.1
Memory: 6GB


LibreOffice Release 4.2.4.2


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Raphael 2017-01-08 18:42:27 UTC
Created attachment 130262 [details]
Text and image copied

Result: Text and image copied in Writer, where an image is not displayed.
Comment 2 Timur 2017-01-09 09:00:48 UTC
Handling of images with links from web is already discusses in other bugs, please search before confirming. I can find Bug 42527, Bug 99499 now, but there are more.
Comment 3 Buovjaga 2017-01-13 18:32:30 UTC
Your need might be answered by bug 51609

Raphael: please try with a single image copied from the web: in LibreOffice Paste special - bitmap. Does it work ok?
Comment 4 MM 2017-01-17 19:11:32 UTC
Tested a wiki page which has a lot more text and some pictures. https://en.wikipedia.org/wiki/Boeing_757

I copied *all* with firefox 50.1 and pasted them with writer v5.2.4.2 and v5.3.0.1 under ubuntu 16.04 x64. With v5.2 it takes about 14 secs and with v5.3 about 8 secs.

So for me, page is copied reasonably fast, pictures are shown.
Comment 5 Thomas Lendo 2017-06-23 23:30:13 UTC
Writer works for me without problems, needs 5-10 seconds:
- https://de.wikipedia.org/wiki/Victor_Adler with about 5000 words
- https://en.wikipedia.org/wiki/Boeing_757 with about 11000 words
Text and images are pasted in a correct way.
Comment 6 Thomas Lendo 2017-07-05 00:53:35 UTC
Closing as resolved invalid due to no answer to needinfo status.

Please reopen this bug if necessary after answering the question in comment 3.