Download it now!
Bug 105211 - Incorrect import of Apple Pages document in Writer
Summary: Incorrect import of Apple Pages document in Writer
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libetonyek (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Mac OS X (All)
: medium normal
Assignee: osnola
URL:
Whiteboard:
Keywords:
: 107631 (view as bug list)
Depends on:
Blocks: Format-Filters
  Show dependency treegraph
 
Reported: 2017-01-09 16:19 UTC by preachervent
Modified: 2018-03-21 12:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Page 1 of African Wildlife sample document in Pages 6.3.1 (1.59 MB, image/png)
2018-03-21 10:36 UTC, Alex Thurgood
Details
Page 2 of African Wildlife sample document in Pages 6.3.1 (511.71 KB, image/png)
2018-03-21 10:37 UTC, Alex Thurgood
Details
Page 3 of African Wildlife sample document in Page 6.3.1 (401.02 KB, image/png)
2018-03-21 10:37 UTC, Alex Thurgood
Details
Same African Wildlife Pages document, opened in LO6021 - first page (283.13 KB, image/png)
2018-03-21 10:38 UTC, Alex Thurgood
Details
Same African Wildlife Pages document, opened in LO6021 - second page (259.89 KB, image/png)
2018-03-21 10:39 UTC, Alex Thurgood
Details
Pages09 export from Pages 631 opened in LO6021 - first page (1.16 MB, image/png)
2018-03-21 10:47 UTC, Alex Thurgood
Details
Pages09 export from Pages 631 opened in LO6021 - second page (251.31 KB, image/png)
2018-03-21 10:49 UTC, Alex Thurgood
Details
sample document (215.32 KB, application/vnd.apple.pages)
2018-03-21 12:01 UTC, David Tardon
Details
same document exported as Pages (iWork 09) (512.93 KB, application/zip)
2018-03-21 12:15 UTC, osnola
Details

Note You need to log in before you can comment on or make changes to this bug.
Description preachervent 2017-01-09 16:19:38 UTC
While LibreOffice opens Apple Pages '09 with no issues, opening the most recent version of Pages (ver. 5.6.2) is not so good. It opens the document, BUT every line is on a single page. If a document is 300 lines, each line is on a separate page, making a 6-7 page document in Pages 300 pages in LibreOffice.
Comment 1 Alex Thurgood 2017-01-09 16:33:29 UTC
@preachervent : please provide a sample Pages document so that we can test.

To my knowledge, the filter we use for importing recent Pages documents is not optimized for that version.
Comment 2 Alex Thurgood 2017-01-09 16:34:15 UTC
Also please try with a current release version of LibreOffice, as you have reported this against version 4.2.4.2 which is obsolete.
Comment 3 Alex Thurgood 2017-01-09 16:51:25 UTC
Confirming with

Version: 5.4.0.0.alpha0+
Build ID: b66b1e896c177df3c5de5d33037416152fc8a381
CPU Threads: 2; OS Version: Mac OS X 10.12.2; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group

I tried opening the sample document WildAfricanAnimals provided by Pages. I also exported this document from the current Pages version to Pages09 format and also tried to open that with LibreOffice.


The exported PAges09 document opened fairly well, all of the images and most of the text was correctly imported.

However, the latest Pages version available on OSX 10.12.2 was virtually illegible - several pages of garbled text at the top of each page, despite the original document only containing 3 pages.
Comment 4 Alex Thurgood 2017-05-05 08:22:11 UTC
*** Bug 107631 has been marked as a duplicate of this bug. ***
Comment 5 raal 2017-10-24 15:59:11 UTC Comment hidden (obsolete)
Comment 6 osnola 2018-03-11 09:37:55 UTC
Indeed, currently the line spacing's property is badly retrieved(ie. 80% is converted in 0.8pt, ...) ; so if you want to see the text, you need first to "select all" the text and choose another spacing (for instance with Format, Spacing, Line Spacing: 1)
Comment 7 David Tardon 2018-03-21 08:08:36 UTC
The description is too vague to be actionable and without any sample document. Moreover, it looks like comment 0 and comment 3 talk about different problems. Closing.
Comment 8 Alex Thurgood 2018-03-21 10:35:12 UTC
Ok, so here are some screenshots for comparison:

- first three screenshots are the default African Wildlife template proposed in Appel Pages 6.3.1

- the next 2 screenshots are how the same file appears in LO6021.

As one can see from these screenshots, the images are garbled, in the wrong position, and there appears to be no text content displayed. Additionally, despite the original document containing 3 pages in total, there are only 2 displayed in LO.
Comment 9 Alex Thurgood 2018-03-21 10:36:26 UTC
Created attachment 140772 [details]
Page 1 of African Wildlife sample document in Pages 6.3.1
Comment 10 Alex Thurgood 2018-03-21 10:37:06 UTC
Created attachment 140773 [details]
Page 2 of African Wildlife sample document in Pages 6.3.1
Comment 11 Alex Thurgood 2018-03-21 10:37:46 UTC
Created attachment 140774 [details]
Page 3 of African Wildlife sample document in Page 6.3.1
Comment 12 Alex Thurgood 2018-03-21 10:38:45 UTC
Created attachment 140775 [details]
Same African Wildlife Pages document, opened in LO6021 - first page
Comment 13 Alex Thurgood 2018-03-21 10:39:30 UTC
Created attachment 140776 [details]
Same African Wildlife Pages document, opened in LO6021 - second page
Comment 14 Alex Thurgood 2018-03-21 10:47:26 UTC
Created attachment 140779 [details]
Pages09 export from Pages 631 opened in LO6021 - first page

For comparison's sake, I exported the original Pages 631 document from Pages631 format to Pages09 format, then opened the resulting file in LO6021.
Comment 15 Alex Thurgood 2018-03-21 10:49:27 UTC
Created attachment 140780 [details]
Pages09 export from Pages 631 opened in LO6021 - second page

As one can see from these screenshots, LO fails to correctly display the Pages09 formatted document, although it does get the three superposed images on the first page nearly correct, however, none of the text content appears to be present.
Comment 16 osnola 2018-03-21 11:29:13 UTC
Hello Alex,
can you also provide the Pages' files, so we can test if the problem are corrected or not...
Comment 17 David Tardon 2018-03-21 12:01:45 UTC
Created attachment 140786 [details]
sample document

It's probably this template. I can see the problem with it, but I see no obvious connection with the original description in comment 0...
Comment 18 David Tardon 2018-03-21 12:02:44 UTC
Anyway, the layout of that doc is fixed in latest libetonyek.
Comment 19 osnola 2018-03-21 12:15:33 UTC
Created attachment 140788 [details]
same document exported as Pages (iWork 09)

There seems to remain problems when we export this document as iWork 09 ; probably, a problem with some prefixes (sl:XXX instead of sf:XXX or the opposite ), I will take a look...