Bug 105267 - UI: German Calc has shortcuts that are not usable on a German keyboard
Summary: UI: German Calc has shortcuts that are not usable on a German keyboard
Status: RESOLVED DUPLICATE of bug 82117
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2017-01-12 02:40 UTC by Gilward Kukel
Modified: 2019-03-18 11:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gilward Kukel 2017-01-12 02:40:43 UTC
Description:
These keys don't exist on a German keyboard:
; ' [ ] (these characters are created using modifier keys)

This means that the German version of Calc should not use shortcuts with these keys (at least not as the only shortcut of a command). But it does.

Steps to Reproduce:
set the user interface to German

Actual Results:  
Ctrl+; is the shortcut for "Insert current date"
Ctrl+Shift+; is the shortcut for "Insert current time"
Ctrl+' is the shortcut for "Fill single edit"
Ctrl+[ is the shortcut for "Mark Precedents"
Ctrl+] is the shortcut for "Mark Dependents"


Expected Results:
The German version of Calc should use shortcuts with keys that exist on a German keyboard.

My suggestions (same shortcuts as in the German version of Excel):
Ctrl+.  for "Insert current date"
Ctrl+Shift+.  for "Insert current time"
Ctrl+,  for "Fill single edit"
Alt+Shift+7  for "Mark Precedents"
Alt+Shift+6  for "Mark Dependents"

They are all free.


Reproducible: Always

User Profile Reset: yes

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Heiko Tietze 2017-05-02 16:40:01 UTC
Dup of bug 82117?
Comment 2 Harald Koester 2017-05-08 22:23:21 UTC
(In reply to Heiko Tietze from comment #1)
> Dup of bug 82117?
Yes!

I added the suggestions of Gilward to a list of proposals which I attached to bug 82117.

*** This bug has been marked as a duplicate of bug 82117 ***