Bug 105350 - Writer doesn't correctly open DOC with images from WPS (OK if first saved in MSO)
Summary: Writer doesn't correctly open DOC with images from WPS (OK if first saved in ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Opening
  Show dependency treegraph
 
Reported: 2017-01-15 18:55 UTC by Maxim
Modified: 2021-06-25 01:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice Writer opens this DOC file incorrectly and destroys formatting in it (DOC) (176.50 KB, application/wps-office.doc)
2017-01-15 19:05 UTC, Maxim
Details
PDF version of original DOC file which LibreOffice Writer opens incorrectly and destroys formatting in it (142.52 KB, application/pdf)
2017-01-15 19:07 UTC, Maxim
Details
LibreOffice Writer opens this DOC file uncorrectly and destroys formatting (DOC, after saving in LO Writer) (174.00 KB, application/wps-office.doc)
2017-01-15 19:09 UTC, Maxim
Details
PDF version of DOC file which LibreOffice Writer opens incorrectly and then saves incorrectly too; formatting is destroyed (197.88 KB, application/pdf)
2017-01-15 19:16 UTC, Maxim
Details
PDF exported from Microsoft Office 2019 (136.95 KB, application/pdf)
2021-06-25 00:42 UTC, stragu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maxim 2017-01-15 18:55:03 UTC
Description:
LibreOffice Writer uncorrectly opens some DOC files and destroys formatting.

Steps to Reproduce:
1. Open some DOC file.
2.
3.

Actual Results:  
Formatting of DOC file is destroyed, images look terrible.

Expected Results:
LibreOffice Writer uncorrectly opened DOC files again and again.


Reproducible: Always

User Profile Reset: Yes

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2700.0 Iron Safari/537.36
Comment 1 Maxim 2017-01-15 19:05:15 UTC
Created attachment 130459 [details]
LibreOffice Writer opens this DOC file incorrectly and destroys formatting in it (DOC)

This is a DOC file before saving in LibreOffice Writer.
Comment 2 Maxim 2017-01-15 19:07:40 UTC
Created attachment 130460 [details]
PDF version of original DOC file which LibreOffice Writer opens incorrectly and destroys formatting in it

It's a PDF version of such file.
Comment 3 Maxim 2017-01-15 19:09:00 UTC
Created attachment 130461 [details]
LibreOffice Writer opens this DOC file uncorrectly and destroys formatting (DOC, after saving in LO Writer)

This is a DOC file after saving in LibreOffice Writer.
Comment 4 Maxim 2017-01-15 19:16:13 UTC
Created attachment 130462 [details]
PDF version of DOC file which LibreOffice Writer opens incorrectly and then saves incorrectly too; formatting is destroyed
Comment 5 Timur 2017-01-16 17:05:49 UTC
Bug reporter may not confirm it's own bug, please refrain from doing so and wait (patiently) until someone else changes from Unconfirmed to New. 

Bugzilla is not "document based" as in "Writer incorrectly opens some DOC files", rather issue "issue based" so specific issue must be narrowed-down and described, if it's page 1 image or page 2 image or whatever.

Reporter should note how the document was created and in which program, from scratch or by coping from somewhere or by saving from some other format.
It's true attachment 130459 [details] doesn't open correctly. But blame may be on how it was created. 
When it's saved in MSO, it opens properly in LO.

I set as Needinfo. When reply on document history is provided, please set back as Unconfirmed. 

Please bear in mind that:
- it's highly unlikely that any bugs of type "multiple problems with this file/bad rendering/this should look like", will ever be fixed
- each issue (section break, paragraph break, text box, picture...) should be reported separately, but only after a search for already reported bugs
- if bugs don't exist, they should be reported separately, even if they happen with the same file
- example file should be reduced to minimum test case for a specific problem, with clear file history or steps to reproduce from scratch
- FILEOPEN problems are differenet from FILESAVE, and DOC is different filter from DOCX
- DOC or DOCX should come from MSO, not from LO or some other software
- if there's a problem with saving to DOC/DOCX, there should be original ODT to test, direct saving to DOC/DOCX doesn't reveal how it was supposed to look like.
Comment 6 Maxim 2017-01-16 18:48:29 UTC
Thank you for this information.

1) DOC file which LibreOffice Writer opens incorrectly and destroys formatting in it is created in WPS Office for Linux.
2) The sizes and formatting of images are incorrect in this document in LO Writer.
3) Formatting of characters are incorrect after first (highest) image in this document in LO Writer.
4) Formatting of paragraphs are incorrect after first (highest) image in this document in LO Writer.
Comment 7 Maxim 2017-01-16 18:54:51 UTC
5) It's a FILEOPEN problem.
Comment 8 Xisco Faulí 2017-01-16 19:19:47 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 36afb355ac37122d32d624db079def123ef548a2
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and

LibreOffice 3.3
Comment 9 Timur 2017-01-17 09:07:50 UTC
Xisco, can you please explain what you confirmed here? 
Problem with rendering is obvious BUT it's WPS file, do we support that and regard as a standard? Why should we? 
And you confirmed against what I wrote that single specific issue must be narrowed-down and described.
Please comment on what I wrote "When it's saved in MSO, it opens properly in LO".
Comment 10 Xisco Faulí 2017-07-13 10:42:39 UTC Comment hidden (obsolete)
Comment 11 Timur 2017-07-13 11:06:32 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2017-07-13 11:31:31 UTC
(In reply to Timur from comment #11)
> (In reply to Timur from comment #9)
> > Xisco ... it's WPS file, do we support that and regard as a standard? 
> Any official policy on this? Or just filter:wps? Or something else?

Discussed in the ESC on Jan 21, 2017. Agreed to leave them open: https://listarchives.libreoffice.org/global/projects/msg02143.html
Comment 13 QA Administrators 2018-07-14 02:46:15 UTC Comment hidden (obsolete)
Comment 14 Maxim 2018-07-15 07:08:52 UTC Comment hidden (obsolete)
Comment 15 Maxim 2018-07-16 18:23:00 UTC
The bug is not present in DOC and DOCX files.

Version: 6.0.5.2
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 2; OS: Linux 3.8; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.utf8); Calc: group
Comment 16 Xisco Faulí 2018-07-16 18:35:22 UTC
(In reply to Maxim from comment #15)
> The bug is not present in DOC and DOCX files.
> 
> Version: 6.0.5.2
> Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
> CPU threads: 2; OS: Linux 3.8; UI render: default; VCL: gtk2; 
> Locale: en-US (en_US.utf8); Calc: group

Hi Maxim,
I'm not following you.
In comment 14 you said it's still present and it's not anymore with the same version?
Comment 17 Maxim 2018-07-17 09:48:17 UTC
(In reply to Xisco Faulí from comment #16)

Hi, Xisco. I'm sorry, it was my mistake in comment #14. Please delete or hide this comment. Thank you.

Bug 105350 is fixed.
Comment 18 Xisco Faulí 2018-07-17 12:41:15 UTC
Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.
Comment 19 Timur 2018-07-17 16:10:50 UTC
Nothing changed, LO still opens this file in the same (wrong) way as  attachment 130462 [details] while correct would be  attachment 130460 [details].
No idea why Maxim said it works and if Xisco checked.
Comment 20 Xisco Faulí 2018-07-17 17:11:39 UTC
No, I didn't check...
Comment 21 QA Administrators 2019-07-18 02:48:57 UTC Comment hidden (obsolete)
Comment 22 stragu 2021-06-25 00:42:15 UTC
Created attachment 173183 [details]
PDF exported from Microsoft Office 2019

For reference, what it looks like when exporting the original file to PDF with a recent version of Microsoft Word.
Comment 23 stragu 2021-06-25 01:00:13 UTC
Reproduced on:

Version: 7.0.6.2 (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Vulkan; VCL: win
Locale: en-AU (en_AU); UI: en-US
Calc: threaded

and:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: e3086b58eb5427d520b86c185f9d911bb6f7a3a0
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-21_15:37:11
Calc: threaded

and:

Version: 7.2.0.0.beta1 / LibreOffice Community
Build ID: c6974f7afec4cd5195617ae48c6ef9aacfe85ddd
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

First image takes the whole width, second and third images are small and overlap.

Changing the filter keyword from docx to doc, and adding a Meta bug.