Bug 105460 - FILEOPEN text color in SmartArt is different than in PP
Summary: FILEOPEN text color in SmartArt is different than in PP
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.2
Keywords: filter:pptx
Depends on:
Blocks: OOXML-SmartArt
  Show dependency treegraph
 
Reported: 2017-01-21 00:44 UTC by Haleh Alemasoom
Modified: 2022-10-29 23:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
original slide + bug image (47.36 KB, application/zip)
2017-01-21 00:44 UTC, Haleh Alemasoom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Haleh Alemasoom 2017-01-21 00:44:56 UTC
Created attachment 130590 [details]
original slide + bug image

- open the attached pptx in Impress
- text color is changed after opening in Impress
Comment 1 tommy27 2017-01-21 04:19:01 UTC
I confirm it in LibO 5.2.4.2 and a recent 5.4.0.0 alpha build under Win8.1 x64
not a new issue anyway... it's already present in 3.5.0 too
did not test earlier versions
Comment 2 Michael Meeks 2018-08-13 18:55:08 UTC
Aron - IIRC we fixed a similar issue to this recently (?) =)
Comment 3 Aron Budea 2018-08-13 21:10:10 UTC
Bug still exists in 6.2 daily build.

To be clear, it's only the color of the text that is wrong (black instead of white), the color of the center shape is blue in PowerPoint as well. Yes, only the text color was mentioned, but the screenshot could be confusing, as it shows the original center shape as yellow.

Version: 6.2.0.0.alpha0+
Build ID: fe9f10a96fe25dd151b1040de14719a0b8e8e7a7
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-13_02:08:26
Locale: en-US (en_US); Calc: CL
Comment 4 Roman Kuznetsov 2018-12-23 10:32:10 UTC
*** Bug 114614 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2020-12-23 03:45:03 UTC Comment hidden (obsolete)
Comment 6 Roman Kuznetsov 2021-01-19 11:36:15 UTC
still repro (black forn color instead white) in

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 94f6765d6ecc3145fa2d266231124003cf953118
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: ru-RU
Calc: threaded
Comment 7 Regina Henschel 2022-10-28 12:18:16 UTC
Please try a daily build (LO 7.5). I cannot reproduce the problem in Version: 7.5.0.0.alpha0+ (X86_64) / LibreOffice Community
Build ID: 17dfc9a9da009cc23d2222e3fb4e2cef9c97d581
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (en_US); UI: en-US
Calc: CL threaded

PowerPoint 365 and LO 7.5 show the SmartArt with same colors.
Comment 8 Aron Budea 2022-10-29 23:20:26 UTC
Indeed, this got fixed thanks to the following commit in 7.4, reverse bibisected to its 7.3 backport using repo bibisect-linux-64-7.3.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7d6212e218d4d5c76c8bc60983b548a6893fc6a5
author		Tünde Tóth <toth.tunde@nisz.hu>	2022-02-18 10:30:54 +0100
committer	László Németh <nemeth@numbertext.org>	2022-02-28 15:39:07 +0100

tdf#103800 PPTX shape import: fix regression of text color