Download it now!
Bug 105530 - Editing conditional formatting 2nd time
Summary: Editing conditional formatting 2nd time
Status: RESOLVED DUPLICATE of bug 105351
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-01-25 18:19 UTC by Karl
Modified: 2017-07-17 09:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Simple spreadsheet with conditional color-scale (9.15 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-25 23:13 UTC, Karl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karl 2017-01-25 18:19:57 UTC
I have applied a color scale condition to a range of cells.
But the color scale is wrong, I want to change it.
Now I put the cursor on one of those cells and click the conditional-formatting icon, then select "condition"or "color scale".

I expect to see the EXISTING condition to be visible. but it is NOT.
The EXISTING condition is only visible if I select "manage" and search for one of my wrongly formatted cells in a very very long and tedious list of conditionally-formatted cells.
Comment 1 Xisco Faulí 2017-01-25 19:31:06 UTC Comment hidden (obsolete)
Comment 2 Karl 2017-01-25 23:13:23 UTC
Created attachment 130683 [details]
Simple spreadsheet with conditional color-scale
Comment 3 Karl 2017-01-25 23:39:20 UTC
I suspect that there is something un-initialized.


Do the following:
0. Go to a colored field, e.g. C6 if you are not already there.

1.  Format->Conditional Formatting->Condition
  ( Notice the current condition is not filled out )

2. Now, go to
     Conditional Formatting->Manage 
       find the cell. 
       Select "Edit"
     The previous condition will pop up.
        Select "Cancel"

3. Then repeat the first step:
   Format->Conditional Formatting->Condition
  ( Notice the current condition is filled in the form )

I have also tested this on Libreoffice 5.0.3.2 on Linux. The bug is NOT present there.

 - Karl
Comment 4 Karl 2017-01-26 00:36:33 UTC
Windows build for 5.3.0.2 also seems to have this bug.
Comment 5 Xisco Faulí 2017-01-26 09:36:33 UTC

*** This bug has been marked as a duplicate of bug 105351 ***