Bug 105351 - FORMATTING: Unable to change Data Bar conditional formatting
Summary: FORMATTING: Unable to change Data Bar conditional formatting
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
URL:
Whiteboard: target:5.4.0 target:5.3.1 target:5.2....
Keywords: bibisected, bisected, regression
: 105530 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-01-15 18:57 UTC by Matt Perry
Modified: 2018-07-26 04:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Perry 2017-01-15 18:57:17 UTC
Description:
When a cell has a Data Bar conditional format applied to it, editing the conditional format again will not show the current values in the conditional formatting window.

Steps to Reproduce:
1. Create new spreadsheet
2. Set the value of cell A1 to 5
3. Select cell A1, then choose from the menus Format -> Conditional Formatting -> Data Bar.
4. In the conditional formatting window, select the dropdown on the left that says "Automatic" and change it to "Value". In the text field below it enter 0.
5. Select the dropdown on the right that says "Automatic" and change it to "Value". In the text field below it enter 10.
6. Click OK to close the window. Cell A1 will have a data bar appear within it.
7. Select cell A1, then choose from the menus Format -> Conditional Formatting -> Data Bar.

Actual Results:  
After completing step 7, the conditions set for cell A1 are not shown in the conditional formatting window.

Expected Results:
The conditions set for cell A1 should be shown and editable.


Reproducible: Always

User Profile Reset: No

Additional Info:
This is a regression. It worked properly in LO 5.2.3


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Zineta 2017-01-18 12:55:11 UTC
According to the given steps bug reproducible in all  LO versions >5.2.3,
In my opinion too it's regression.
OS:Windows 7
Comment 2 Xisco Faulí 2017-01-18 13:21:52 UTC
Regression introduced by:

author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-09-18 14:14:35 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-09-19 10:10:09 (GMT)
commit	5b8c22379e2eae74f7ed78326ab89483db5c6624 (patch)
tree	60cbfdd24bca243b4a911ff1dab298ef91590b5b
parent	96646c351e20fa6699fa368457a05ee70f76f103 (diff)
tdf#96453, tdf#100793 rework transfer of data between cond format dlgs
The xml based transfer of information was a bad idea from the start. It
can obviously not transport the temporary conditional format information
from the manager dialog. Therefore the whole handling here was
completely broken and deleted formats came back, changed formats were
not saved and added formats got applied directly to the document.

Now the document fornat list and the one from the manager are indepedent
again and as long as the manager has not been closed with ok nothing is
written to the document.

Adding Cc: to Markus Mohrhard
Comment 3 Timur 2017-01-23 15:41:39 UTC
Adding those bugs to See Also, which is useful info for those bugs.
Comment 4 Xisco Faulí 2017-01-24 12:23:19 UTC
*** Bug 104675 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2017-01-25 12:37:14 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0367acdcc59e14b0b067976a08202e8afef0ecf3

Resolves: tdf#105351 pass matching index key to conditional format dialog

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Eike Rathke 2017-01-25 12:48:53 UTC
Pending review
https://gerrit.libreoffice.org/33528 for 5-3
https://gerrit.libreoffice.org/33529 for 5-3-0
https://gerrit.libreoffice.org/33533 for 5-2
Comment 7 Commit Notification 2017-01-25 19:16:02 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f1705a22aa5f26f2590ee937f0e07201f8415696&h=libreoffice-5-3

Resolves: tdf#105351 pass matching index key to conditional format dialog

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-01-25 19:17:31 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d0b841e5501881c5676e27da08fddcb5f9d4bc1a&h=libreoffice-5-2

Resolves: tdf#105351 pass matching index key to conditional format dialog

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-01-25 20:37:44 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-3-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df4efcbbb820f7e2c15afd15ccf29b4f613bca44&h=libreoffice-5-3-0

Resolves: tdf#105351 pass matching index key to conditional format dialog

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Xisco Faulí 2017-01-26 09:36:33 UTC
*** Bug 105530 has been marked as a duplicate of this bug. ***
Comment 11 Zineta 2017-01-27 14:40:19 UTC
OK 

Version: 5.3.1.0.0+
Build ID: cba6653d460cc3800d1bd84ca9d39279b928e473
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-3, Time: 2017-01-26_08:58:36
Locale: bs-BA (bs_BA); Calc: group
Comment 12 Zineta 2017-01-30 08:05:34 UTC
Also, tested on:
Version: 5.4.0.0.alpha0+
Build ID: c6dd735afb2e1b3837c4f8c5659f52fafab4c56f
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-30_01:52:54
Locale: bs-BA (bs_BA); Calc: group
 Confirming that resolved.
Comment 13 Commit Notification 2018-07-26 04:35:23 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3715ca5943ee05d4df7bfd0cf47071b2ee4081b6

uitest for bug tdf#105351

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.