Bug Hunting Session
Bug 100793 - FORMATTING - conditional formatting gets corrupted upon copy/paste/insert
Summary: FORMATTING - conditional formatting gets corrupted upon copy/paste/insert
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: target:5.3.0 target:5.2.4 target:6.2.0
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-07-06 21:38 UTC by Thomas Maeder
Modified: 2019-12-07 18:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shots of conditional formatting edit dialogs (1.60 MB, application/pdf)
2016-07-06 21:38 UTC, Thomas Maeder
Details
demo file (83.35 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-11 20:23 UTC, Thomas Maeder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Maeder 2016-07-06 21:38:11 UTC
Created attachment 126095 [details]
Screen shots of conditional formatting edit dialogs

Upon copying/pasting within a range, some conditional formatting ranges get corrupt, and can no longer be changed.

Bug - pages (attachment) & comments
1) Original "clean" file - see ranges C10:190, D10:D190 and E10:F190
2) Modified file (copy/paste whole lines only)
    --> range C10:C190 is still clean, but D & E-F are now corrupt
3) Try to correct for D - open dialog
4) …enter correct range D10:D190 & click OK
5) …and change unsuccessful - range stays the same at D78:D190, D10:D73

Workaround:
6) Copy/paste line from original clean file: entries for C74, D74 & E74:F74
7) Changed C74 to C10:C190, then deleted original C75:C190,C10:C73 -> OK!
8) Now deleted bad ranges D78:D190,D10:D73 and E78F190,E10:F73
    -> reveals other little bug: they come back if main dialog not closed now
9) Now edit D74
10) …to D10:D190 & click OK
11) Change successful
     --> now other little bug: the previously-deleted ranges come back
       (as the main dialog was not closed before editing D74)
12) Delete bad range D78:D190,D10:D73 (will come back, as main dialog not closed)
13) Edit E74:F74
14) …to E10:F190 & click OK
15) Change successful, but bad range D78:D190,D10:D73 comes back, as before
16) So delete bad ranges & close main dialog; reopen: now everything OK
Comment 1 Joel Madero 2016-07-08 05:02:33 UTC
We need the original document.

Marking as NEEDINFO - once you attach the document, mark it as UNCONFIRMED. Thanks
Comment 2 Thomas Maeder 2016-07-11 20:23:51 UTC
Created attachment 126173 [details]
demo file

This is not exactly the original file (private), but an equivalent that also has the problem.
1) Open file
2) Go to sheet "plan"
3) Open the conditional formatting management dialog
-> The indicated range should be G18:K29,F18,F20:F29
3) Click Edit & try to change to intended one, F18:K33
-> (LibreOffice 5.1.4.2 Mac OS X)change impossible
Comment 3 Buovjaga 2016-07-17 09:25:23 UTC
(In reply to Thomas Maeder from comment #2)
> Created attachment 126173 [details]
> demo file
> 
> This is not exactly the original file (private), but an equivalent that also
> has the problem.
> 1) Open file
> 2) Go to sheet "plan"
> 3) Open the conditional formatting management dialog
> -> The indicated range should be G18:K29,F18,F20:F29
> 3) Click Edit & try to change to intended one, F18:K33
> -> (LibreOffice 5.1.4.2 Mac OS X)change impossible

Yep, it refuses to add the :K33.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ab1b351840160655a9f0caedbb35e9fdf203c5a0
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on July 16th 2016
Comment 4 Markus Mohrhard 2016-09-18 14:03:26 UTC
I have a fix for this and a few related conditional format manager issues.
Comment 5 Commit Notification 2016-09-19 10:12:19 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b8c22379e2eae74f7ed78326ab89483db5c6624

tdf#96453, tdf#100793 rework transfer of data between cond format dlgs

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-10-13 16:03:19 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98b580b302267fb7c781e94ef6d175d696e9e848&h=libreoffice-5-2

tdf#96453, tdf#100793 rework transfer of data between cond format dlgs

It will be available in 5.2.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Zineta 2017-01-31 09:37:49 UTC
No more problem with adding ":K33".
Version: 5.3.0.0.beta1, Version: 5.2.4.1, 

Version: 5.4.0.0.alpha0+
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-30_01:52:54
Comment 8 Commit Notification 2018-07-27 09:29:11 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=86be39afd5b142f7cbdbe0107b394c5924c414cc

uitest for bug tdf#100793

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 raal 2019-12-07 18:54:38 UTC
The test exist, set status to Verified.