Download it now!
Bug 105114 - Conditional formatting dialog closes while editing any condition 2nd time
Summary: Conditional formatting dialog closes while editing any condition 2nd time
Status: RESOLVED DUPLICATE of bug 105544
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.4.2 release
Hardware: All All
: high normal
Assignee: Markus Mohrhard
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2017-01-04 21:14 UTC by karsten.henning
Modified: 2017-04-10 09:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
sheets with conditional formattings (128.69 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-01-05 20:05 UTC, karsten.henning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description karsten.henning 2017-01-04 21:14:08 UTC
Description:
When I editing any condition in conditional formatting i can do it only one time. The second time of editing of the same or another condition and click ok the window will be closed completely. The function "conditional formatting" crashed.

It don't work in win64 5.3.0.1 too but in Debx86_64 5.1.4.2.

Steps to Reproduce:
1.create some conditional formattings in calc
2.select Conditional formatting and then Edit
3.edit anyone condition and press ok
4. select the same or another contition for editing
5. after editing press ok

Actual Results:  
The window for conditional formatting will be closed completely. Changes for conditions are not saved.

Expected Results:
Return to the list of condition, change is confirmed and the next condition can be edited.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Jacques Guilleron 2017-01-05 11:04:04 UTC
Hi karsten,

Don't press OK until you have changed all you wish. All changes are available, including a new condition. They will be applied right after you will have pressed OK.
This changes will be save before Calc closing. 

Jacques
Comment 2 karsten.henning 2017-01-05 20:05:10 UTC
Created attachment 130186 [details]
sheets with conditional formattings
Comment 3 karsten.henning 2017-01-05 20:07:16 UTC
Hi Jacques,

sorry but i think, that it is a bug!
It works fine in LO 5.1.4.2 , but not in LO-Version 5.2.4.2 and 5.3.0.1 (Winx86_64).
Please have look to attached file, sheet "Planung". This sheet contains many Entries for conditional formatting. You can try to edit some of the conditions.
Normally you can toggle between list of condition and conditions itself by edit and ok or edit and cancel.
In LO 5.2.4.2 and LO 5.3.0.1 you can not edit more than one condition without crash of the function. LO don't crash completely it seems to work fine but if you want to edit an conditional formatting again you must restart LO!
Comment 4 Buovjaga 2017-01-12 18:45:43 UTC
(In reply to karsten.henning from comment #2)
> Created attachment 130186 [details]
> sheets with conditional formattings

Yes, it is true that with version 3.6.7.2, the "Manage conditional formatting" dialog does not close with the second edit, but I can just keep editing the different conditions.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: 2fd88ab1cbb4690a770ca2ca5d66157ec4906a2e
CPU Threads: 8; OS Version: Linux 4.8; UI Render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on January 12th 2016

Arch Linux 64-bit
Version 3.6.7.2 (Build ID: e183d5b)
Comment 5 Aron Budea 2017-01-28 07:16:57 UTC
This started with the same commit as bug 105544 (bibisect is in the other bug report).
Adding Cc: to Markus Mohrhard, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5b8c22379e2eae74f7ed78326ab89483db5c6624
author	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-09-18 14:14:35 (GMT)
committer	Markus Mohrhard <markus.mohrhard@googlemail.com>	2016-09-19 10:10:09 (GMT)

"tdf#96453, tdf#100793 rework transfer of data between cond format dlgs"
Comment 6 Timur 2017-01-30 17:23:40 UTC
Aron, since Bug 96453 is still open, why would this be a new bug? 
Do you think this one may be closed as a duplicate?
Comment 7 lore 2017-02-04 09:36:29 UTC
I'm having the exact same issue on MacOS and if you have a lot of conditions to edit this becomes really annoying.

I don't this this bug is the same as  Bug 96453. Also, it appears to me as anybody who replied did not test this out. Please do, there's no workaround for it.

Thanks
Comment 8 7qia0tp02 2017-03-12 16:57:59 UTC
Conditional formatting became broken a few releases ago.  The bugs are too erratic to report, but they're there.  

Sometimes editing a format causes the window to close immediately instead of going back to the Manage Conditional Formatting window (whether pressing Ok or Cancel).  Sometimes it works normally.

(When this happens I think the changes that were made are not applied?)

Sometimes highlighting a range and applying a conditional format to it works, other times it opens an existing conditional format instead, and doesn't allow you to create new ones (workaround is to close the document and re-open)
Comment 9 Markus Mohrhard 2017-04-09 20:38:13 UTC
Should be a duplicate of Bug 105544. Please test in master and close as duplicate if the bug is fixed.
Comment 10 Buovjaga 2017-04-10 09:25:18 UTC
Yep, confirmed fixed. Thanks, Markus.

*** This bug has been marked as a duplicate of bug 105544 ***