Bug 105626 - Breeze dark is hardly readable
Summary: Breeze dark is hardly readable
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.1 rc
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 111866 (view as bug list)
Depends on:
Blocks: UI-Theming Icon-Theme-Breeze
  Show dependency treegraph
 
Reported: 2017-01-30 21:56 UTC by Aron Budea
Modified: 2017-11-26 10:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Breeze Dark in Windows (31.12 KB, image/png)
2017-01-30 21:56 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-01-30 21:56:19 UTC
Created attachment 130773 [details]
Breeze Dark in Windows

Steve-_- noticed that Breeze Dark theme looks like this on Mac: http://imgur.com/a/63zij

It's almost the same in Windows with 5.3.0.3, except the icon art is white and not grey (see attachment).

Breeze Dark seems to be new in 5.3, at least in Windows. Is it supposed to be enabled?
Comment 1 Aron Budea 2017-01-30 21:57:48 UTC
Confirming, since both steve-_- and I saw this.
Comment 2 Heiko Tietze 2017-01-30 22:17:21 UTC
Breeze Dark is intentionally made with bright colors to get some contrast on dark backgrounds. You should rather use the normal Breeze icon theme on Windows (without any special theme).
Comment 3 Jean-Baptiste Faure 2017-08-18 21:15:45 UTC
*** Bug 111866 has been marked as a duplicate of this bug. ***
Comment 4 steve -_- 2017-11-26 00:40:16 UTC
NOTABUG? How so? Users are able to select Breeze Dark and will end up with unreadable icons. That's what I'd consider a bug. I understand that the icons are light and the idea is to have a dark background. But all that can not be required for users to be known prior knowledge before selecting "Breeze dark".

@Heiko could you elaborate why this is not a bug? If breeze dark is an expert only option it maybe should be treated as such?

Maybe we should still close this bug and file a new one regarding cross-platform usage of dark themes?

I am re-opening this bug for the time being. Feel free to close again if you disagree with my above statements.
Comment 5 Heiko Tietze 2017-11-26 08:18:41 UTC
(In reply to steve -_- from comment #4)
> NOTABUG? How so? Users are able to select Breeze Dark...

We do not keep users away from customization of meaningless setups. So why should we introduce one icon theme with two flavors and chose internally what is presented eventually rather than let the user decide (Breeze and Breeze-Dark are available; same for Sifr, the other monochrome theme )? In case of medium muted themes, e.g. Silver on Windows or Solaris on KDE4, it could easily be the wrong decision.

=> Still NAB, feel free to file a new issue with a clear use case.