Bug 105646 - In writer and Calc cell border dialogs, the image with the preview is corrupted (missing bitmaps)
Summary: In writer and Calc cell border dialogs, the image with the preview is corrupt...
Status: RESOLVED DUPLICATE of bug 104608
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-01-31 15:30 UTC by Andy
Modified: 2017-02-07 11:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the corrupted preview in Writer (40.20 KB, image/png)
2017-01-31 15:31 UTC, Andy
Details
The corrupted preview in Calc (42.38 KB, image/png)
2017-01-31 15:31 UTC, Andy
Details
the dialog windows with the arrows correctly shown (70.53 KB, image/jpeg)
2017-02-07 10:56 UTC, Andy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy 2017-01-31 15:30:36 UTC
Description:
In Writer, you have a cell border dialog for table management.
In Calc you have one for  cell formatting.
In both cases, on the left there is a real time preview of the borders you are setting.
In LO 5.3.0.3 this preview has become corrupted: some bitmaps are missing and missing image icon is shown all around the cell

Steps to Reproduce:
1. In writer, create a table: in Calc select some cells
2.In writer open the table properties dialog, and select the borders tab. In Calc open the format cells dialog and select the borders tab
3. look at the preview: it is corrupted with the "missing image" ico all around the previewed cell. See attachments to clarify matters.

Actual Results:  
The preview is corrupted

Expected Results:
You should see some small signs helping you to figure out what king of borders are you setting


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Andy 2017-01-31 15:31:19 UTC
Created attachment 130794 [details]
the corrupted preview in Writer
Comment 2 Andy 2017-01-31 15:31:41 UTC
Created attachment 130795 [details]
The corrupted preview in Calc
Comment 3 Buovjaga 2017-02-05 09:14:42 UTC
Andy: one person tested it, but didn't comment for some reason. Please try with Safe mode: Help - Restart in Safe Mode.
Maybe it is related to OpenGL or having Hardware acceleration enabled. Try it.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have further testing information.
Comment 4 Jacques Guilleron 2017-02-06 00:28:01 UTC
Hi Andy,

I don't reproduce with 
LO 5.3.0.2 and upper versions under windows 7 Home.
Did you try to reproduce it by renaming your user profile as "old", to keep your actual profile and to get this way a new profile?

Jacques
Comment 5 Andy 2017-02-06 10:29:40 UTC
Hi, I have disabled first openGL, then hardware acceleration, then both. Nothing changes, the problem is always there. sorry
I have not tried the new profile method yet; could you just specify the path for the profiles, so that I can rename the present one and try with a new one?
After this, to go back what do I need to do? just delete the new one and take the original one back to its original name, right?
Comment 6 Buovjaga 2017-02-06 14:56:33 UTC
(In reply to Andy from comment #5)
> Hi, I have disabled first openGL, then hardware acceleration, then both.
> Nothing changes, the problem is always there. sorry
> I have not tried the new profile method yet; could you just specify the path
> for the profiles, so that I can rename the present one and try with a new
> one?
> After this, to go back what do I need to do? just delete the new one and
> take the original one back to its original name, right?

With the Safe Mode, you don't have to mess with your profile. Did you try it like I asked: Help - Restart in Safe Mode
https://wiki.documentfoundation.org/UserProfile
Comment 7 Andy 2017-02-06 15:10:05 UTC
Thanks, I had overlooked this. I am trying safe node right now; there are many options: which one should I choose??
The alternatives are:
recover from backup copy
configure
extensions
recover from factory setting
please note that I do not want to delete my settings, especially regarding toolbars personalization...
Comment 8 Buovjaga 2017-02-06 15:20:25 UTC
(In reply to Andy from comment #7)
> Thanks, I had overlooked this. I am trying safe node right now; there are
> many options: which one should I choose??
> The alternatives are:
> recover from backup copy
> configure
> extensions
> recover from factory setting
> please note that I do not want to delete my settings, especially regarding
> toolbars personalization...

You can ignore the options, simply running in Safe Mode will give you the experience of a fresh user profile.
Comment 9 Andy 2017-02-06 23:47:33 UTC
I am sorry to bother but you HAVE to choose one of the four options... you cannot deselect all of them. And the default is the first one (recover from backup files). Do you mean that it doesn't matter what I choose??
Comment 10 Buovjaga 2017-02-07 07:03:23 UTC
(In reply to Andy from comment #9)
> I am sorry to bother but you HAVE to choose one of the four options... you
> cannot deselect all of them. And the default is the first one (recover from
> backup files). Do you mean that it doesn't matter what I choose??

When I restart in Safe Mode, I am shown the dialog, where I can optionally tick some boxes. I don't have to do any ticking, but can simply click the button "Continue in Safe Mode".

If you tick those boxes, they will do changes *outside* the Safe Mode. The point of Safe Mode is you don't have to worry about potentially destructive changes.

An issue of its own is whether the UI could be made more intuitive. Apparently the radio buttons are misleadingly conveying the sense that something will be changed even when the checkboxes are unticked.
Comment 11 Andy 2017-02-07 10:55:17 UTC
Ok thank you for the clarification.
So I have tried in safe mode and the situation is different:
- the "missing image" icon have disappeared
- however, the space around the cell border preview is now empty, where in previous releases there were some arrows helping with the settings preview (see my image attach from previous versions).

So the question is: these arrows were voluntarily deleted, or they are missing in safe mode too, even if it shows less dramatically???
Comment 12 Andy 2017-02-07 10:56:23 UTC
Created attachment 130980 [details]
the dialog windows with the arrows correctly shown
Comment 13 Buovjaga 2017-02-07 11:06:50 UTC
(In reply to Andy from comment #11)
> So the question is: these arrows were voluntarily deleted, or they are
> missing in safe mode too, even if it shows less dramatically???

They are not deleted voluntarily, I can see them myself.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 83e059af2203ec0cd15dea08cfa538555ba14bd7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_23:34:43
Locale: fi-FI (fi_FI); Calc: group
Comment 14 Buovjaga 2017-02-07 11:15:36 UTC

*** This bug has been marked as a duplicate of bug 104608 ***
Comment 15 Andy 2017-02-07 11:30:06 UTC
Now I see... it was not safe mode that changed things but the chosen icon set .... the "missing image" icons come out only with galaxy icons, all the others do not show the arrows but do not have the "missing image" icons.
In safe mode it reverts to Tango icons, hiding the problem