Bug Hunting Session
Bug 104608 - Icon broken in table Borders dialog for themes Galaxy and High Contrast
Summary: Icon broken in table Borders dialog for themes Galaxy and High Contrast
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 105646 (view as bug list)
Depends on:
Blocks: Icon-Theme-Galaxy
  Show dependency treegraph
 
Reported: 2016-12-12 16:04 UTC by Regina Henschel
Modified: 2018-12-25 14:11 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Compare version 5.4 and 5.2 (136.92 KB, application/vnd.oasis.opendocument.text)
2016-12-12 16:04 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-12-12 16:04:49 UTC
Created attachment 129534 [details]
Compare version 5.4 and 5.2

You can add borders to a table cell in the table properties dialog in Writer and in the cell properties dialog in Calc. This dialog has a part for user defined positions of the border. In that dialog the icons are missing in theme Galaxy. I have attached a document with screen shots.

The icons are there in version 5.2, but missing in version 5.4
Comment 1 Jacques Guilleron 2016-12-13 11:01:22 UTC
Reproduced with

LO 5.4.0.0.alpha0+ Build ID: cb598029835477326b190bc99abd31a487cc5a91
CPU Threads: 2; OS Version: Windows 6.1; UI Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-09_00:49:18
Locale: fr-FR (fr_FR); Calc: CL
LO 5.3.0.0.alpha1+ Build ID: b223028d65d24ffcd8e27974c29c2744a5df6227
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-11-16_23:38:55
Locale: fr-FR (fr_FR); Calc: CL

Icons existing in
LO 5.3.0.0.alpha1+ Build ID: bbd44f8f89839b5abb4ec6c7ea195431de5b2f48
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-26_23:19:45
Locale: fr-FR (fr_FR); Calc: CL

with theme Galaxy under windows 7 Home
Table Properties Borders in Writer
Format Cells Borders in Calc
Comment 2 Buovjaga 2017-02-07 11:15:36 UTC
*** Bug 105646 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2017-02-07 11:18:39 UTC
They work for me with Galaxy.

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 83e059af2203ec0cd15dea08cfa538555ba14bd7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-06_23:34:43
Locale: fi-FI (fi_FI); Calc: group
Comment 4 Andy 2017-02-07 11:29:54 UTC
Now I see... it was not safe mode that changed things but the chosen icon set .... the "missing image" icons come out only with galaxy icons, all the others do not show the arrows but do not have the "missing image" icons.
In safe mode it reverts to Tango icons, hiding the problem
Comment 5 Jacques Guilleron 2017-02-07 12:25:29 UTC
Happens also with High Contrast Theme.
Comment 6 Aron Budea 2017-02-18 08:48:08 UTC
Bibisection points to the commit referenced below. Adding Cc: to Tomaž Vajngerl, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c3043a3072465c489d3b20991b17d222771305eb
author		Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2016-10-31 12:28:26 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2016-10-31 14:49:57 (GMT)

"tdf#103591 icon theme name resolving, ui fixes, prioritize png"
Comment 7 Andy 2017-03-13 10:33:24 UTC
version 5.3.1.2 still has the problem, sorry to report this
Comment 8 Andy 2017-03-13 10:34:19 UTC Comment hidden (obsolete, spam)
Comment 9 Andy 2017-03-13 11:02:05 UTC Comment hidden (obsolete, spam)
Comment 10 Roman Kuznetsov 2018-12-25 14:11:12 UTC
Galaxy and High Contrast themes were removed in LO 6.1

Status->WontFix