Bug 105800 - caret-moved events are no longer emitted so LibreOffice is no longer usable by the blinds
Summary: caret-moved events are no longer emitted so LibreOffice is no longer usable b...
Status: RESOLVED DUPLICATE of bug 104381
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All All
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: accessibility, bibisected, regression
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2017-02-06 15:40 UTC by Alex ARNAUD
Modified: 2017-02-07 16:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Python caret-moved listenner (273 bytes, text/x-python)
2017-02-06 15:42 UTC, Alex ARNAUD
Details
ODT text doc (12.25 KB, application/vnd.oasis.opendocument.text)
2017-02-06 15:43 UTC, Alex ARNAUD
Details
git bisect log (2.17 KB, text/x-log)
2017-02-07 10:27 UTC, Alex ARNAUD
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex ARNAUD 2017-02-06 15:40:27 UTC
Description:
Dear all,

Environment :
- Debian 8.7
- Both in LibreOffice 5.3.x and 5.4.0.0.alpha0+ (GTK2)

After moving the caret on a line with the down arrow key, all the previous lines no longer emit a caret-moved event.

The caret-moved event is used by screen readers to announce the text on the screen to the blind user, so if this event isn't emitted it is not possible to read any text.

The issue is confirmed by the Orca (screen reader) community : https://mail.gnome.org/archives/orca-list/2017-February/msg00053.html

Best regards.

Steps to Reproduce:
1. Launch the python listener
2. Open the attached ODT document
3. Press down arrow
4. Press up arrow

Actual Results:  
No caret-moved events emitted

Expected Results:
caret-moved events should be emitted on you move the caret on each lines


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Alex ARNAUD 2017-02-06 15:42:51 UTC
Created attachment 130952 [details]
Python caret-moved listenner
Comment 2 Alex ARNAUD 2017-02-06 15:43:32 UTC
Created attachment 130953 [details]
ODT text doc
Comment 3 Julien Nabet 2017-02-06 21:40:48 UTC
On pc Debian x86-64 with master sources updated yesterday, I get this (I added "produced" comments):

/usr/lib/python2.7/dist-packages/pyatspi/registry.py:149: Warning: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
  Atspi.event_main()
object:text-caret-moved(3, 0, 0)
	source: [heading | ]
	host_application: [application | soffice]
(produced by down key)
object:text-caret-moved(3, 0, 0)
	source: [heading | ]
	host_application: [application | soffice]
object:text-caret-moved(0, 0, 0)
	source: [paragraph | ]
	host_application: [application | soffice]
(produced by up key)
Comment 4 José Vilmar Estácio de Souza 2017-02-06 23:47:20 UTC
The same behavior using 5.3.0.3 in an arch box.
Comment 5 Alex ARNAUD 2017-02-07 10:27:25 UTC
Created attachment 130976 [details]
git bisect log

Dear all,

I've bibisected on the repository "bibisect-linux-64-5.3".

It's my first bibisect on LibreOffice, let me know if I made something wrong :).

Best regards.
Comment 6 Aron Budea 2017-02-07 16:12:24 UTC
Thank you for the bibisection, Alex. So this is certainly a duplicate of bug 104381, and very serious, I'll add the results there.

*** This bug has been marked as a duplicate of bug 104381 ***