Bug 105936 - OSX 10.11 & LO 5.3: Terrible letter spacing, Initials don't work anymore
Summary: OSX 10.11 & LO 5.3: Terrible letter spacing, Initials don't work anymore
Status: RESOLVED DUPLICATE of bug 103322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2017-02-11 12:28 UTC by DeepFlight5
Modified: 2017-02-13 08:01 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
my Writer test document (19.37 KB, application/vnd.oasis.opendocument.text)
2017-02-11 12:30 UTC, DeepFlight5
Details
text display on LO 5.3 (200.05 KB, image/png)
2017-02-11 12:31 UTC, DeepFlight5
Details
text display on LO 5.2.4 (226.85 KB, image/png)
2017-02-11 12:32 UTC, DeepFlight5
Details
test display on LO 5.4 master 2017-02-09 (392.59 KB, image/jpeg)
2017-02-12 12:36 UTC, steve -_-
Details
view settings (52.81 KB, image/jpeg)
2017-02-12 12:37 UTC, steve -_-
Details
Writer bad, PDF export good (169.23 KB, image/png)
2017-02-12 13:49 UTC, DeepFlight5
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DeepFlight5 2017-02-11 12:28:03 UTC
Description:
New font engine of LO 5.3 destroys on OSX 10.11 font design of all old and newly created documents.

Main problems: Letters of words merge into another AND letter space in between words gets huge gaps like blanks - terrible to look at, terrible to work with, terrible to read. ALSO: Initials don't work anymore.

I went back to LO 5.2.4, might upgrade to 5.2.5, but with 5.3 it's not possible to work all day long. It's a pain to look at the broken letter display. Very sad. 

Please make this "cross-platform type uniformity" optional - I don't need it, I need readable documents, not some terrible 1990's or ancient Windows font rendering. This is a major downgrade! Thank you.

Steps to Reproduce:
Create Writer document, write or paste some text, look at it.

For broken Initials: Create a paragraph of text and chose to make an initial letter: it appears a blank space.

Actual Results:  
Broken font rendering.

Expected Results:
Font rendering like on LO 5.2.4 and older.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 DeepFlight5 2017-02-11 12:30:01 UTC
Created attachment 131092 [details]
my Writer test document
Comment 2 DeepFlight5 2017-02-11 12:31:17 UTC
Created attachment 131093 [details]
text display on LO 5.3
Comment 3 DeepFlight5 2017-02-11 12:32:55 UTC
Created attachment 131094 [details]
text display on LO 5.2.4
Comment 4 Jean-Baptiste Faure 2017-02-11 15:06:20 UTC
Not reproducible for me with LO 5.3.1.0.0+ built at home under Ubuntu 16.04 x86-64:
Version: 5.3.1.0.0+
Build ID: a60a6f514c59e4a7e7fee239823d2e932c499bf6
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; VCL : gtk3; Moteur de mise en page : nouveau; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: group

Not reproducible with
Version: 5.3.0.3
Build ID: 1:5.3.0~rc3-0ubuntu1~xenial1.1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: fr-FR (fr_FR.UTF-8); Calc: single

In both cases drop caps are visible. There is the bug 101664 with drop caps in 5.3.0 and 5.2.0 that is fixed in next versions 5.2.6 and 5.3.1.

Best regards. JBF
Comment 5 DeepFlight5 2017-02-12 11:23:16 UTC
I dug out Bug 89879 "Unify text layout to use HarfBuzz on all platforms". There it is written:

"HarfBuzz is a free software text layout engine, it is actively developed and supported, both Firefox and Chrome switched to using it on all platforms to avoid the situations outlined above, and I think LibreOffice should do the same."

OK, no problem with that. But in Chrome and Firefox for MacOS text rendering is (with HarfBuzz) excellent. So why is text rendering in LO 5.3 with HarfBuzz on MacOS not as good as on Firefox and Chrome? ("not as good" is an euphemism for terrible. See screenshots.)
Comment 6 steve -_- 2017-02-12 12:36:06 UTC
screenshot of what I see in LO master attached, which looks a lot better than what screenshot for 5.3 from OP shows.

Can also not confirm using 5.3.

@DeepFlight5: Please try two things: Open LO > Preferences > View and check you are using identical settings as shown in my second screenshot.
Comment 7 steve -_- 2017-02-12 12:36:49 UTC
Created attachment 131131 [details]
test display on LO 5.4 master 2017-02-09
Comment 8 steve -_- 2017-02-12 12:37:51 UTC
Created attachment 131132 [details]
view settings
Comment 9 steve -_- 2017-02-12 12:42:05 UTC
DeepFlight5, can you please copy paste the version info from Libreoffice > About (menubar).
Comment 10 DeepFlight5 2017-02-12 13:48:13 UTC
Version: 5.3.0.3 Build-ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1 CPU-Threads: 2; BS-Version: Mac OS X 10.11.6; UI-Render: Standard; Layout-Engine: neu; Gebietsschema: de-DE (de.UTF-8); Calc: group

Your LO 5.4 still looks bad (letters merging into another). Until LO 5.2.4 all was perfect.

I made a test screenshot of a LO 5.3 text and a PDF produced from this text by LO 5.3. It seems only a display problem in LO 5.3, the PDF export of LO 5.3 is perfect.

"View Settings" is as yours. I only have chosen "Small Toolbar Icons".
Comment 11 DeepFlight5 2017-02-12 13:49:39 UTC
Created attachment 131133 [details]
Writer bad, PDF export good
Comment 12 steve -_- 2017-02-12 15:05:24 UTC
DeepFlight5, can you please copy paste the version info from Libreoffice > About (menubar).
Comment 13 Buovjaga 2017-02-12 16:28:18 UTC

*** This bug has been marked as a duplicate of bug 103322 ***
Comment 14 Buovjaga 2017-02-12 16:32:15 UTC
DeepFlight5: Please create a separate report for the initials problem.