Bug Hunting Session
Bug 106000 - delete/edit comment in context box not an option if comment is escaped without writing anything in it.
Summary: delete/edit comment in context box not an option if comment is escaped withou...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.6.3 release
Hardware: All All
: lowest trivial
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.1
Keywords: bibisected, bisected, regression
: 122797 (view as bug list)
Depends on:
Blocks: Calc-Comments List-Combobox-RenderContext-regressions
  Show dependency treegraph
 
Reported: 2017-02-14 12:37 UTC by ayito
Modified: 2019-08-05 10:57 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ayito 2017-02-14 12:37:24 UTC
Description:
while in Calc, it is posible to insert a comment in a cell, but if escape button is escaped before writing anything in the comment, the red dot remains in the upper right corner of the cell, but there is no "edit comment" nor "delete comment" in the cell context menu.

in order to delete the comment, right click -> "insert comment", then write something, escape it and the option to edit or delete the comment will be present in the cell context menu.

Steps to Reproduce:
1. right click insert comment in a cell (red dot appearance top right corner in the cell, and comment area to write
2. press scape, do not write anything in the comment area.
3. right click and... cannot delete comment, the red dot will be there. It seems that it is posible to   
delete the comment only if something is written in it.
4. red dot is there, but it is posible to right click in the cell and "insert comment" again (don't know if it will edit the empty one or insert a new one, guess it will be       
the edit).
5. write some stuff in the comment area.
6. now it is posible to edit the comment or delete it. 

Actual Results:  
After step 2, there is no option in the cell's context menu to delete or edit the comment.

Expected Results:
After step 2, there should be an option in the cell's context menu to delete or edit the comment.


Reproducible: Always

User Profile Reset: No

Additional Info:
Id. de compilación: 1:5.3.0~rc3-0ubuntu1~yakkety1.1


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Buovjaga 2017-02-15 09:50:21 UTC
Repro.

Interestingly, does not happen in an older version (3.5)

Win 7 Pro 64-bit Version: 5.4.0.0.alpha0+
Build ID: 1d810b69a584fc33f4178c7012f68f551ba2e03b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-12_23:34:02
Locale: fi-FI (fi_FI); Calc: CL

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 raal 2017-03-24 18:47:03 UTC
resize the column and red dot disappear

This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl  ; Could you possibly take a look at this one?
Thanks

bibisect-50max$ 
b505bc823706dd51e2652098fabb911cbcdd77e1 is the first bad commit
commit b505bc823706dd51e2652098fabb911cbcdd77e1
Author: Matthew Francis <mjay.francis@gmail.com>
Date:   Wed May 27 22:45:22 2015 +0800

    source-hash-dca01def7885ad69cf66edd75cf8207a5adb64f9
    
    commit dca01def7885ad69cf66edd75cf8207a5adb64f9
    Author:     Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>
    AuthorDate: Thu May 7 14:18:37 2015 +0900
    Commit:     Jan Holesovsky <kendy@collabora.com>
    CommitDate: Thu May 7 09:57:50 2015 +0200
    
        refactor ListBox/ComboBox to use RenderContext
    
        Change-Id: I367d6e4f54375bd61e46f0c1437444306b127c68
Comment 3 ayito 2017-07-19 07:26:32 UTC
"resize the column and red dot disappear"

That is true, so now I guess it's something just annoying more than anything else, tested in:
 
Ubuntu 17.04 x86_64

Versión: 5.3.2.2
Id. de compilación: 1:5.3.2~rc2-0ubuntu1~yakkety0
Subproc. CPU: 4; SO: Linux 4.10; Repr. de IU: predet.; VCL: gtk3; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES.UTF-8); Calc: group
Comment 4 Xisco Faulí 2019-01-23 23:17:06 UTC
*** Bug 122797 has been marked as a duplicate of this bug. ***
Comment 5 Miklos Vajna 2019-07-19 15:27:20 UTC
I can still reproduce this. It smells like this was working by accident in the past. As we end the editeng editing of the (empty) comment, we update the various toolbars/sidebars and ~5 listboxes are also updated as part of that; and as a side effect this area was repainted in the past.

I'll try to see how to explicitly invalidate the relevant cell area.
Comment 6 Miklos Vajna 2019-07-22 07:46:40 UTC
It seems the root cause is a single ImplPaint() -> Invalidate() change in ImplListBoxWindow::SelectEntry(). ImplPaint() invokes maUserDrawHdl, while Invalidate() invokes Paint(), which invokes ImplDoPaint(), which does not invoke maUserDrawHdl. This means that when the comment edit mode is replaced by the normal tab view shell, the SvxFontNameBox / FontSizeBox does not invalidate the active cell.
Comment 7 Commit Notification 2019-07-22 17:44:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/d001492faddb0b95356c7744aa4d193aacb38d7d%5E%21

tdf#106000 sc ui: fix missing invalidation when cancelling note creation

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-07-24 19:37:21 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/+/f5f894e1608a75dffc07ddb3644b566fee1b6848%5E%21

tdf#106000 sc ui: fix missing invalidation when cancelling note creation

It will be available in 6.3.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 BogdanB 2019-08-05 10:57:41 UTC
Solved.
Checked in
Version: 6.4.0.0.alpha0+
Build ID: 9ee5ad5a0b84bfa652da34694ba4f75668f06087
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-07-30_13:21:44
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded