Download it now!
Bug 106042 - Calc does not use all the default template formatting when creating new sheet
Summary: Calc does not use all the default template formatting when creating new sheet
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 106971 (view as bug list)
Depends on:
Blocks: Sheet
  Show dependency treegraph
 
Reported: 2017-02-16 12:26 UTC by Sergey Nemna
Modified: 2017-07-11 22:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
«Normal» sheet and newly added sheet (65.60 KB, image/png)
2017-02-16 12:26 UTC, Sergey Nemna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Nemna 2017-02-16 12:26:01 UTC
Created attachment 131272 [details]
«Normal» sheet and newly added sheet

I created a new Calc template with the following cell formatting parameters changed compare to the default template:
1) font-face;
2) font size;
3) row height;
4) column width;
5) text alignment.

Than I declared my new template to be the default one. Newly created documents (each containing 3 sheets in my case) are based on that template, no problem. However, when I add a new sheet to the just-created document, it has row height, column width, text alignment as if I used the default Calc template. Only the font and size thereof are what I want them to be.

Almost the same problem is described in the bug № 81397 (see comment 8, Linux Mint 17.3 Cinnamon 64 bit). I decided to create a new bug per request by Kevin Suo (comment 9). I witnessed it in LO 5.3.0 on both Windows 7 x32 and Windows 7 x64. I believe this bug to be more serious than № 81397 is, since here something goes wrong with a few formatting parameters. I found description of that bug on several forums as well.

The only workaround I could invent is to clone any existing sheet and delete all cells of the clone. Neither exactly elegant, nor very convenient solution.
Comment 1 m.a.riosv 2017-02-17 23:25:28 UTC
Create a new sheet always have default options for columns and rows.

For 1)2)5) you can modify the default style, for save with your template. 

But there is a simple way to duplicate a sheet, dragging the sheet tab with [Ctrl] key pressed. Everything on the sheet will be duplicated, not only formats.

Resolved as not a bug, please if you are not agree, reopen it.
Comment 2 Sergey Nemna 2017-03-02 19:07:51 UTC
Thanks for reply, Manuel!

However, I am not quite sure we understood each other fully. You are right about possibility to modify the default style (actually, I have a few styles that suit my needs). But styles have nothing to do with row height/column width.

It's good to know about ability to clone sheet by dragging the sheet tab with [Ctrl] key pressed. Did not know about that. But again, you have to remove everything on the cloned sheet. It is not to say that is difficult or something, I just do not get why to do that. You create new sheet and it is automatically formatted according to your default template like the existing sheets. My feeling is that it is logical, transparent, intuitive behaviour. That is why I humbly disagree with you and why I have re-opened the bug.

Maybe, «bug» is not a proper word, it is not problematic to circumvent it with a few mouse clicks. Just not exactly logical behaviour, like I said. In case fixing this issue does not require a lot of efforts... please, consider it.
Comment 3 Sergey Nemna 2017-03-02 19:13:21 UTC
Sorry for wrong name, Miguel. My mistake.
Comment 4 Buovjaga 2017-04-23 12:45:46 UTC
Let's set to NEW. Assuming inherited from OOo.
Comment 5 Buovjaga 2017-04-23 12:45:53 UTC
*** Bug 106971 has been marked as a duplicate of this bug. ***