Bug 106971 - Additional sheets in calc do not use the default template
Summary: Additional sheets in calc do not use the default template
Status: RESOLVED DUPLICATE of bug 106042
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-05 11:48 UTC by alan
Modified: 2017-04-23 12:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alan 2017-04-05 11:48:17 UTC
Description:
Having set and saved a default template new spreadheets correctly open up using the default I had set up.
However, if I add any new sheets they all use the original default as opposed to my one.

This apears to be an axtension of bug 81397

LO Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~xenial1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-GB (en_GB.UTF-8); Calc: group
64 bit Linux Mint 18.3 M/C with a Cinnamon desktop

Steps to Reproduce:
1.Create a new calc spreadsheet and format all the cells, all the columns and all the rows by clicking in the upper left corner to select the entire sheet then set the preferred font and font size, number type, alignment & etc. Modify the required row and column settings to your desired options.
2. Follow the usual instructions to save the spreadsheet as your Default Calc template.
3.Open a new Calc spreadsheet. It will open using the Default template you have just set up.
4. Add an additional sheet (>Sheet>Insert sheet)

Actual Results:  
The newly inserted sheet will open using the original Default template rather than the one you just created

Expected Results:
The newly inserted shhet shoud have been opend using the Default template you just created


Reproducible: Always

User Profile Reset: No

Additional Info:
This bug appears to be an extension of bug 81397.
When I tried to enter it there I was told to create a new bug report.

WORKAROUND
If the additional sheet is known to be required at the start, selecting the entire sheet and using the Clone formatting tool then pasting the formatting into the new sheet by selecting all again then clicking in any cell will duplicate the 'correct' formattion. Of course, if the additional sheet is found to be required once you have started work on the original sheet the replicated version will reflect any changes you have made since it was new.




User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Buovjaga 2017-04-23 12:45:53 UTC

*** This bug has been marked as a duplicate of bug 106042 ***