Bug 106056 - EDITING: text cursor disappears after input of space or one of these characters: . , : ; _ / * ! ? % ' " into cell
Summary: EDITING: text cursor disappears after input of space or one of these characte...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.1
Keywords: bibisected, bisected, regression
: 106328 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-02-17 01:44 UTC by gilward.kukel
Modified: 2017-05-18 16:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gilward.kukel 2017-02-17 01:44:45 UTC
Description:
text cursor disappears after input of space or one of these characters: . , : ; _ / * ! ? % ' " into cell

Steps to Reproduce:
1. type a letter or digit into a cell
2. type a space or one of these characters: . , : ; _ / * ! ? % ' "

Actual Results:  
text cursor disappears

Expected Results:
text cursor does not disappear


Reproducible: Always

User Profile Reset: No

Additional Info:
It worked in 5.2.5.1.
Cursor reappears when you type another letter or digit.
Cursor does not disappear in formulas nor in the input line nor after the first character in a cell.



User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0
Comment 1 Xisco Faulí 2017-02-17 20:43:42 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 880033edde516fc30225005245253293a6a58ba4
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 2 Aron Budea 2017-02-18 08:00:51 UTC Comment hidden (bibisection)
Comment 3 Aron Budea 2017-02-18 08:01:42 UTC
Bibisection points to the commit referenced below. The behavior is not 100% deterministic, though. Adding Cc: to Justin Luth, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=a324e85cbbe62c8d8b6b6c0d0692746c17673453
author		Justin Luth <justin_luth@sil.org>	2016-09-07 10:54:37 (GMT)
committer	Justin Luth <justin_luth@sil.org>	2016-09-30 04:17:29 (GMT)

"tdf#101815 editeng SetMustRepaint when InsertText"
Comment 4 Justin L 2017-02-18 19:02:53 UTC
Justin Luth committed a patch related to this issue.

revert tdf#101815 editeng SetMustRepaint when InsertText

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a189b27ebeac8f179b9cce959e66862a16c4dd52
It will be available in 5.4.0.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9431ab38da9e8e1c438a88a97b9fc4172a3f7213&h=libreoffice-5-3
It will be available in 5.3.1.
Comment 5 gilward.kukel 2017-03-05 04:40:16 UTC
*** Bug 106328 has been marked as a duplicate of this bug. ***