Bug 106112 - Math formula editor misplaces vertical elements in to and from and dot modifiers
Summary: Math formula editor misplaces vertical elements in to and from and dot modifiers
Status: RESOLVED DUPLICATE of bug 104509
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-02-20 19:23 UTC by shannon
Modified: 2017-02-28 13:26 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing incorrect vertical spacing in formula (103.42 KB, image/png)
2017-02-20 19:25 UTC, shannon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description shannon 2017-02-20 19:23:49 UTC
Description:
Formulas are not formatted properly for vertical placement of certain operators. For example: dot and ddot 

Steps to Reproduce:
1. Create new formula in Writer or Impress
2. Attempt to use any operator with to and from modifiers
3. Use dot or ddot operators

Actual Results:  
The dot and ddot operators place the dots too high above the character.
The to modifier places the symbol in the middle of the integral symbol, rather than above it. Also, the spacing in the sidebar is distorted.

Expected Results:
dot and ddot symbols should be placed slightly above the base character. The to modifier should be placed above the integral symbol.


Reproducible: Always

User Profile Reset: Yes (safe mode)

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_3) AppleWebKit/602.4.8 (KHTML, like Gecko) Version/10.0.3 Safari/602.4.8
Comment 1 shannon 2017-02-20 19:25:14 UTC
Created attachment 131372 [details]
Screenshot showing incorrect vertical spacing in formula
Comment 2 Regina Henschel 2017-02-20 21:33:30 UTC
Please make sure, that the font OpenSymbol is properly installed on your system.
Comment 3 Xisco Faulí 2017-02-21 09:59:07 UTC Comment hidden (obsolete)
Comment 4 shannon 2017-02-21 17:24:56 UTC
(In reply to Regina Henschel from comment #2)
> Please make sure, that the font OpenSymbol is properly installed on your
> system.

The OpenSymbol font is NOT installed on my system. If it is required for LibreOffice to function properly, should it be included as part of the installation?
Comment 5 Regina Henschel 2017-02-21 18:46:10 UTC
I have no Mac and therefore cannot determine, whether it is a general bug.

The font file is in from https://cgit.freedesktop.org/libreoffice/core/tree/extras/source/truetype/symbol/opens___.ttf
Click on (plain) to actually download it. But I do not know, whether it can be directly installed on a Mac. So someone with a Mac needs to look at this issue.
Comment 6 shannon 2017-02-22 04:07:37 UTC
I was unable to install OpenSymbol from the link you sent. Font Book on macOS Sierra reports "1 serious error was found. Do not use this font."

I downloaded an OpenSymbol.ttf font from another font provider, which generated a "minor problem" report, but allowed installation. After installing this font, I tested LibreOffice and found the same behavior I originally reported. I've change the status back to "UNCONFIRMED" as requested by xiscofauli.

I also checked LibreOffice 5.3 on a Windows 10 machine, and the formula was formatted correctly. So perhaps this is a macOS-specific problem.
Comment 7 Khaled Hosny 2017-02-22 18:23:28 UTC
*** Bug 106135 has been marked as a duplicate of this bug. ***
Comment 8 Khaled Hosny 2017-02-22 21:52:19 UTC

*** This bug has been marked as a duplicate of bug 104509 ***
Comment 9 LibreTraining 2017-02-22 23:53:07 UTC
The version of OpenSymbol included with LibreOffice is not the same as versions found out on the the web at various font download sites.

Per the LO documentation the OpenSymbol font included "Contains LO-specific PUA symbols used in Math"
https://wiki.documentfoundation.org/Fonts

The font version included in LO 5.3.0.3 has 1,055 glyphs.
The font version found on some font sites has only 415 glyphs.

The first test done without the font installed would be missing required symbols.

Then installing a font found out on the web could still be missing those same required symbols.

So both tests may have been done without the required symbols available.


Have other Mac users reported problems installing this font?
Is this issue specific to a particular version of macOS?

The best solution may be to find out why MacOS has an issue with the font.

The font does show a lot of validation issues, but so do other fonts included in LO.
Comment 10 Khaled Hosny 2017-02-22 23:58:20 UTC
There is no need to install OpenSymbol or any bundled fonts, we have code to load the fonts we bundle without installing them. I don’t even know why we install OpenSymbol on some platforms, it is a very peculiar font and is unlikely to be usable with any other application.
Comment 11 Khaled Hosny 2017-02-23 00:00:39 UTC
The bug is already confirmed and fixed.
Comment 12 Dorange-Pattoret Didier 2017-02-23 07:23:39 UTC
Hello,
Thanks for your work.
Will the be fixed in LO 5.3.1 ?
Comment 13 Dorange-Pattoret Didier 2017-02-23 07:25:25 UTC
Sorry,
Will the bug be fixed in LO 5.3.1 ?
Comment 14 Khaled Hosny 2017-02-23 15:27:48 UTC
It will be available in at least 5.3.2, but hopefully it will make it to 5.3.1. Please check bug 104509 for updates.
Comment 15 Dorange-Pattoret Didier 2017-02-28 07:21:52 UTC
Hello,
I can't find some binarie to test in http://dev-builds.libreoffice.org/daily
Thanks.
Comment 16 V Stuart Foote 2017-02-28 13:26:49 UTC
(In reply to Dorange-Pattoret Didier from comment #15)
> Hello,
> I can't find some binarie to test in http://dev-builds.libreoffice.org/daily
> Thanks.

You needed to drill down a bit further. The patched nightly TinderBox builds for macOS are here:

of master (e.g. 5.4.0 -- has patch )
http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/

of 5.3 (last rolled on 2017-02-22, so the patch [1] not yet in a build)
http://dev-builds.libreoffice.org/daily/libreoffice-5-3/MacOSX-x86_64@49-TDF/

At the moment you'd need to test against master. And, you might prefer installing in parallel if you want to maintain existing profile configuration [2]

=-ref-=
[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=659a38ba7678c7a62ba0872f390c59329daadb90&h=libreoffice-5-3

[2] https://wiki.documentfoundation.org/Installing_in_parallel/OS_X