Download it now!
Bug 106147 - text-fit oddness ...
Summary: text-fit oddness ...
Status: RESOLVED DUPLICATE of bug 97630
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-02-22 21:50 UTC by Michael Meeks
Modified: 2017-02-23 00:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test file / template. (11.19 KB, application/vnd.oasis.opendocument.presentation-template)
2017-02-22 21:51 UTC, Michael Meeks
Details
what I see on load of OTP, and after save & re-load =) (114.62 KB, image/png)
2017-02-22 21:53 UTC, Michael Meeks
Details
and the ODP exported having loaded and saved & re-loaded this (for me) (10.49 KB, application/vnd.oasis.opendocument.presentation)
2017-02-22 22:24 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2017-02-22 21:50:18 UTC
This is very odd. I've chopped this OTP down to be rather minimal - but still - if I load this template - then save as ODP and re-load, I see a huge change in the size of the text in the text box.
Comment 1 Michael Meeks 2017-02-22 21:50:47 UTC
Aron - can you take another look at this ? is uses Liberation Sans for me now ;-)
Comment 2 Michael Meeks 2017-02-22 21:51:05 UTC
Created attachment 131416 [details]
test file / template.
Comment 3 Michael Meeks 2017-02-22 21:53:05 UTC
Created attachment 131417 [details]
what I see on load of OTP, and after save & re-load =)
Comment 4 Michael Meeks 2017-02-22 22:24:31 UTC
Created attachment 131418 [details]
and the ODP exported having loaded and saved & re-loaded this (for me)
Comment 5 Aron Budea 2017-02-23 00:12:55 UTC
This is the difference in styles.xml that is causing the huge text:
- huge text:
 <style:graphic-properties draw:stroke="none" draw:fill="none" draw:auto-grow-height="false" draw:fit-to-size="true">

- normal text:
<style:graphic-properties draw:stroke="none" draw:fill="none" draw:auto-grow-height="false" draw:fit-to-size="shrink-to-fit">

This happens if the ODF format used for saving is set to something other than 1.2 Extended. Regina has a very good writeup on the issue with a suggestion how to fix it.

*** This bug has been marked as a duplicate of bug 97630 ***