Bug Hunting Session
Bug 106161 - Writer crashes immediately after opening this .docx in Windows 7
Summary: Writer crashes immediately after opening this .docx in Windows 7
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression, wantBacktrace
Depends on:
Blocks: RTL-CTL DOCX-Opening
  Show dependency treegraph
 
Reported: 2017-02-23 15:14 UTC by Pedro
Modified: 2017-09-21 15:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature: ["rtl_uString_acquire","cppu::checkInterface"]


Attachments
Nearly 200 page Microsoft XML docx in Persian aka Farsi (221.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-02-23 15:14 UTC, Pedro
Details
Error message when loading sample document (10.32 KB, image/png)
2017-04-26 10:04 UTC, Pedro
Details
Error message when submitting crash report (21.80 KB, image/png)
2017-04-26 10:05 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2017-02-23 15:14:08 UTC
Created attachment 131431 [details]
Nearly 200 page Microsoft XML docx in Persian aka Farsi

This is a follow up from Bug#100813 (as suggested by Xisco)
The document is the same (a nearly 200 page docx in Persian aka Farsi)

This document caused LibreOffice to crash under Linux, Windows XP and Windows 10 but never under Windows 7.
Since version 5.3.0.3 it doesn't crash under any other OS except for Windows 7.

Crash report for 5.3.0.3
crashreport.libreoffice.org/stats/crash_details/b1030498-e942-42c0-bc23-ef68b9d688ac

Crash report for 5.3.1.1 (with a blank profile)
crashreport.libreoffice.org/stats/crash_details/700f6008-729d-4542-a23d-4425cf2557f6
Comment 1 V Stuart Foote 2017-02-24 15:50:02 UTC
Confirmed.

On a VM of Windows 7sp1 Ultimate 32-bit with
Version: 5.3.1.1
Build ID: 72fee18f394a980128dc111963f2eefb05998eeb
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

But a different crash signature, but similar stack for the reflow:

http://crashreport.libreoffice.org/stats/crash_details/fd85713a-797e-4338-86fc-7f8d1b2ae04a

http://crashreport.libreoffice.org/stats/crash_details/2267982d-6039-4625-8af5-2b939798973a
Comment 2 Pedro 2017-02-24 15:54:14 UTC
I'm taking the liberty of changing the Status to NEW since it has been confirmed by Stuart
Comment 3 Xisco Faulí 2017-02-28 16:38:08 UTC
I can reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: eb7b03b052ffe8c2c577b2349987653db6c53f76
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2017-02-26_22:34:18
Locale: es-ES (es_ES); Calc: group

crashreport.libreoffice.org/stats/crash_details/895d18a2-ee1c-42bf-9975-7cb9c6c3a38b

and

Versión: 5.3.0.3
Id. de compilación: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Subpr. de CPU: 1; Versión de SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

crashreport.libreoffice.org/stats/crash_details/012cc1e1-5259-4b70-a465-d04fadab4cc1

after opening the file and scrolling down
Comment 4 Caolán McNamara 2017-03-02 11:41:41 UTC
backtrace of comment #1 suggests table in a footnote and perhaps its a11y related.
Comment 5 Caolán McNamara 2017-03-02 14:12:34 UTC
FWIW couldn't reproduce this under windows (10) and this document, might very well be something that needs the exact same set of fonts installed to get the same layout that hits whatever the edge case is.
Comment 6 V Stuart Foote 2017-03-02 15:12:49 UTC
(In reply to Caolán McNamara from comment #5)
> FWIW couldn't reproduce this under windows (10) and this document, might
> very well be something that needs the exact same set of fonts installed to
> get the same layout that hits whatever the edge case is.

Pedro, Xisco and I all were getting the crash on Windows 7. Not sure about Xisco, but like you document does open for Pedro and I on Windows 10 also. 

So seems specific to Windows 7 OS. Guess available fonts could impact this, but if this faults at determining XAccessible context of flowfrm for a RTL table is that point of layout even font dependent? Unless it occur as it breaks over page margins--which these footnote tables do when expanded. Hmm...
Comment 7 Xisco Faulí 2017-03-02 15:18:52 UTC
Yes, I forgot to mention I reproduced the crash on Win 7 as well...
Comment 8 Xisco Faulí 2017-03-02 18:08:20 UTC
@Aron, could you please bisect this one if you have win 7?
Comment 9 Aron Budea 2017-03-03 00:45:42 UTC Comment hidden (bibisection)
Comment 10 Aron Budea 2017-03-03 00:48:59 UTC
The crash started with the commit referenced below. Adding Cc: to Justin Luth, please take a look.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3d5ccc1577ff89bd13c26a8cde787a39482a8b81
author		Justin Luth <justin_luth@sil.org>	2016-12-23 10:49:19 (GMT)
committer	Justin Luth <justin_luth@sil.org>	2017-01-05 04:29:15 (GMT)

"tdf#99616 writerfilter: hideMark shouldn't force min size"
Comment 11 Justin L 2017-03-03 06:46:21 UTC
I don't have Windows, so I can't do anything with this bug report.

I don't know how to read the crash details report, but it (and the related bugs) seem to highly suggest that the crash is occurring in the layout section?  If so, then this change has probably exposed a different bug elsewhere, and is not really caused by my change.
Comment 12 Pedro 2017-04-26 10:04:18 UTC
Created attachment 132847 [details]
Error message when loading sample document

The problem still occurs in version 5.3.3.1 but now there is no bug report. Just error messages. I hope these are useful.
Comment 13 Pedro 2017-04-26 10:05:42 UTC
Created attachment 132848 [details]
Error message when submitting crash report
Comment 14 Xisco Faulí 2017-05-02 16:25:24 UTC
Still reproducible in

Version: 5.4.0.0.alpha1+
Build ID: 591ac7e604fa47304a5ddc1a4f9badbba1199903
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-02_09:00:13
Locale: es-ES (es_ES); Calc: group
Comment 15 Timur 2017-05-03 09:09:03 UTC
When I open it in Windows 7 64-bit with:
LO 5.3.2.1 64-bit it's OK, no crash or error. 
LO 5.4+ 64-bit TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2017-04-13 I get crashreport.libreoffice.org/stats/crash_details/5b63f748-7029-4fef-bb50-1a477e242e23.
LO 5.4+ 32-bit TinderBox: Win-x86@39, Branch:master, Time: 2017-04-28 I get fatal error: 'querying for interface "": no interface type'.
Comment 16 Pedro 2017-05-05 10:31:37 UTC
The document crashes LibreOffice 5.3.3.2 under Windows 7 but the crash reports are working again (thank you to whoever fixed this)

http://crashreport.libreoffice.org/stats/crash_details/aa013946-f652-4d9b-b7a9-e4a42c33a8d2

Hope this helps!
Comment 17 Xisco Faulí 2017-05-13 11:27:24 UTC
I can no longer reproduce the crash in

Version: 5.4.0.0.alpha1+
Build ID: 2a955057623d4cd14326bcaa8a2c52d76c121c21
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2017-05-13_01:18:24
Locale: es-ES (es_ES); Calc: group

I guess it was fixed by one of the recent commits done by Michael Stahl in the header/footer area but I can't tell which one. Anyway, all his commits are being backported to 5.3 branch, so this should be fixed in release 5.3.4 as well.

CLosing as RESOLVED WORKSFORME.
Comment 18 Pedro 2017-06-15 07:14:13 UTC
Verified fixed with version 5.3.4.1 x64 under Windows 7 Pro x64 SP1

Thank you!
Comment 19 zahra 2017-06-22 15:08:47 UTC
hi.
today i downloaded libreoffice 5.3.4.2 and installed it.
its extremely great and compatible with xp beyond my immagination!
i dont know how to appreciate God for its great favor, also you and all developers to helped me eventually find my favorite version and open all of my books properly!
This the first version that can not only open my books without crash, but I could navigate in there tables and footnotes.
i have more than 90 islamic books in different folders!
they are realy divine treasury for me and I extremely love these valuable books.
its incredible and one divine miracle for me!
i am extremely happy and i cant discribe my happiness and feeling in english.
i should be grateful to this favor for my lord.
because God says in the quran:

And as for the favor of your Lord, do announce [it].
i also should appreciate you and your great work.
i sincerely pray for you in my five times obligatory prayers because God says:

And when you are greeted with a greeting, greet with a better [greeting] than it or return it; surely Allah takes account of all things.
and also i pray for you and i am sure for acceptance in the divine court.
because God is extremely merciful, accepts our prayers and said:

And when My servants ask you concerning Me, then surely I am very near; I
answer the prayer of the suppliant when he calls on Me, so they should answer My
call and believe in Me that they may walk in the right way.

you presented me the best version of your program for free, and i present my sincere and honest prayer which i always remember you, your kindness and i request divine infinite mercy, graces, blessings, bounties and favors for you all.
Specially in these times which you presented me the best version of your product, its the best month.
Now is the Month of prayer, the doors of heaven is open and this month is special for divine banquet and mercy.
The prophet Mohammad (blessings of God upon him and his progeny) said in one cerman:
O People! The month of Allah has come with His mercies and blessings. This is the month that is the best of all months in the eyes of Allah. Its days are the best of days, its nights are the best of nights, its hours are the best of hours. This is a month in which you have been invited by Him. You have been given the opportunity in this month to receive the honors from Allah, the Merciful.
In this month if you fast as ordained by Allah, every breath you take has the reward of Tasbeeh, and your sleep has the reward of worship. Your good deeds are rewarded more than usual, and your duas are accepted.
The special time for all people.
God wants us to pray and promised to accept.
Comment 20 V Stuart Foote 2017-06-22 15:18:59 UTC
(In reply to zahra from comment #19)

Stuart -> Nasrin, a simple "It works at 5.3.4.2, thanks!" would suffice. We're glad the issue with handling the MSO formatting in your documents, but please contain your joy--the extra exclamations do not belong here.

On a side note, you should probably be testing with 5.4.0 beta 2, and keep in mind that Windows XPsp3 and Vista will not be supported for the 6.0 release.
Comment 21 zahra 2017-06-24 00:42:49 UTC
(In reply to V Stuart Foote from comment #20)
> (In reply to zahra from comment #19)
> 
> Stuart -> Nasrin, a simple "It works at 5.3.4.2, thanks!" would suffice.
> We're glad the issue with handling the MSO formatting in your documents, but
> please contain your joy--the extra exclamations do not belong here.
> 
> On a side note, you should probably be testing with 5.4.0 beta 2, and keep
> in mind that Windows XPsp3 and Vista will not be supported for the 6.0
> release.

hi stuart.
thanks for all of your great efforts.
my real name is zahra as stated here and nasrin is for the name of my email address.
i tried to change it, but without success.
because i always pray for you every day in my five times obligotary prayers and i cant forget your kindness.
just saying thanks everyone say!
but i wanted to show you my special gratitude and appreciation.
specially in these days which is the month of ramadhan and i explaned about this month!
this a special month for all people to recieve special mercy of God and his forgiveness and blessings.
Comment 22 zahra 2017-09-21 15:13:42 UTC
(In reply to zahra from comment #19)
> hi.
> today i downloaded libreoffice 5.3.4.2 and installed it.
> its extremely great and compatible with xp beyond my immagination!
> i dont know how to appreciate God for its great favor, also you and all
> developers to helped me eventually find my favorite version and open all of
> my books properly!


hello every one again.
as i promised to use only the first version of libreoffice that can open all of my books without any problem in all platforms,
so, the first and best version for me is 5.3.4.1 which i downloaded the next month and decided to use this version forever to fulfill my promise!
one of the important signs of muslims which is introduced by God in verse 8 of chapter 23 of the holy Quran:
And those who are keepers of their trusts and their covenant,

i found my best version after three years that i became familiar with libreoffice!
i never forget your kindness, i pray for you sincerely every day and request divine infinite mercy, prosperity, salvation and special blessings, graces and favours for you in every day of my praying sincerely.
also, i forgot to ask in my previous comment,,
can you please add target milestone for this bug?
as this bug is completely fixed in 5.3.4.1 completely in all platforms, (which is the book that causes crash after openning by libreoffice since many years)
also i found the best version of libreoffice, sincerely appreciate you and pray for you,
i wish that you add milestone libreoffice 5.3.4.1 for this bug!