Bug 100813 - Writer crashes immediately after opening this .docx or on scroll (Linux fixed here, Windows in other bug)
Summary: Writer crashes immediately after opening this .docx or on scroll (Linux fixed...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: highest critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.1.5 target:5.2....
Keywords: filter:docx
Depends on: HarfBuzz
Blocks: rtl-meta DOCX-OPENING
  Show dependency treegraph
 
Reported: 2016-07-08 12:00 UTC by zahra
Modified: 2017-05-04 14:58 UTC (History)
10 users (show)

See Also:
Crash report or crash signature: ["SwContentFrame::MoveFootnoteCntFwd(bool,SwFootnoteBossFrame *)","rtl_uString_acquire"]


Attachments
this is the problematic document that i could not open it in libreoffice because of the crash. (259.94 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-07-08 12:00 UTC, zahra
Details
Backtrace of v5.1.5.1 x64 crash under Windows 10 (15.79 KB, text/plain)
2016-07-20 23:22 UTC, Pedro
Details
Backtrace of LO 5.3+ 32-bit crash under Windows 7 x64 (12.59 KB, text/plain)
2016-07-21 08:19 UTC, Timur
Details
stack trace end of initial load of attachment 126239 (9.40 KB, text/plain)
2016-07-21 16:10 UTC, V Stuart Foote
Details
analyze -v and trace when trying to scroll (7.51 KB, text/plain)
2016-07-21 16:11 UTC, V Stuart Foote
Details
stack trace on scroll of original attachment 126127 with 2016-07-21 TB39 build (50.36 KB, text/plain)
2016-07-21 16:39 UTC, V Stuart Foote
Details
Backtrace of LO 5.3+ 32-bit crash with master~2016-07-21_23.52.45 (9.28 KB, text/plain)
2016-07-22 10:32 UTC, Timur
Details
Backtrace of v5.2.0.4 x64 crash under Windows 10 (14.95 KB, text/plain)
2016-08-02 22:48 UTC, Pedro
Details
Backtrace of v5.2.1.1 x64 crash under Windows 10 (10.30 KB, text/plain)
2016-08-11 22:39 UTC, Pedro
Details
comparison MSO Writer 2010 and master (126.94 KB, image/png)
2017-01-26 10:58 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zahra 2016-07-08 12:00:25 UTC
Created attachment 126127 [details]
this is the problematic document that i could not open it in libreoffice because of the crash.

hi every one. 
i have a very valuable docx document. 
every times, when i want to open this document, libreoffice crashes immediately and wants to recover my document. 
but unfortunately recovery also has no result and libreoffice crashes for me after completion of recovery. 
i tested this documents on windows and also i realized that this file makes libreoffice crash even on linux, i dont know about mac and other operating systems. 
this file can be open in openoffice and microsoft office without any error and crashes. 
i use windows xp and even it causes the crash on windows ten. 
i tested many versions of libreoffice since version 4.3.0 and even the newest version which is 5.1.4.2 now. 
i am not shure about the previous versions before 4.3.0

steps to reproduce:
1- double click in this document. 
current behaviour:
sometimes libreoffice crashes and wants to recover this file. 
sometimes fatal error SEH exception access violation. 
expected behaviour:
this document can be opened properly without any crash. 
hope you solve this bug for me. 
i pray for you and request Allah's mercy and grace for you.
Comment 1 MM 2016-07-08 13:07:39 UTC
Unconfirmed with v3.3.4 under windows 7 x64.
Confirmed with v5.1.4.2 under windows 7 x64.
Confirmed with v4.1.6.2 under mint 16 x64.

Opens fine, but seems to crash on doing repagination ?!
Comment 2 Commit Notification 2016-07-08 15:45:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f374e01af32c7752b31455642e7d76f2056a2aeb

Resolves: tdf#100813 crash during pagination of particular docx

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 zahra 2016-07-09 07:05:26 UTC
hi. 
could you please solve this bug in libreoffice 5.1 for me to use on windows xp? 
version 5.3 forshure does not support xp and i cant use my document. 
what was the document's problem? 
as i mentioned, for me after many seconds after openning, libreoffice crashes. 
fatal error seh exception access violation 
and sometimes, do to unexpected error, libreoffice crashed. 
and wants to recover my file and again crash! 
i even cant read its content because of crash shure i cant set page number which you told it crashes after pagination.
Comment 4 Caolán McNamara 2016-07-09 14:48:25 UTC
its in review queue as https://gerrit.libreoffice.org/#/c/27051/
Comment 5 Commit Notification 2016-07-12 19:19:07 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2dcce9155ddd9444f65b26c59c3b873ac603091&h=libreoffice-5-1

Resolves: tdf#100813 crash during pagination of particular docx

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-07-15 12:54:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df89407a3827d5c1f0bf97490337d55660a8321d&h=libreoffice-5-2

Resolves: tdf#100813 crash during pagination of particular docx

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Pedro 2016-07-15 13:35:24 UTC
Hi Caolán

(In reply to Commit Notification from comment #5)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "libreoffice-5-1":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=f2dcce9155ddd9444f65b26c59c3b873ac603091&h=libreoffice-5-1
> 
> Resolves: tdf#100813 crash during pagination of particular docx
> 
> It will be available in 5.1.5.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

Version 5.1.5.1 x64 (RC1) still crashes when opening the attached file under Windows 10.
Maybe patch was not included in time for 5.1.5.1 (compiled on Jul 13th)?
Comment 8 Timur 2016-07-20 16:59:39 UTC
Pedro, you can see for yourself (by clicking on 5.1) that it was included: wiki.documentfoundation.org/ReleasePlan
Caolán, I also have a crash with libo-master~2016-07-12_09.25.31_LibreOfficeDev_5.3.0.0.alpha0_Win_x86. Should this one be reopen?
Comment 9 Caolán McNamara 2016-07-20 19:58:38 UTC
caolan->timur:

I definitely fixed *a* bug with this cause it doesn't crash for me under Linux anymore and if I revert my fix it crashes again. I guess there must be another problem. Is there any automated crash report backtrace associated with your master windows failure ?
Comment 10 Pedro 2016-07-20 23:22:56 UTC
Created attachment 126333 [details]
Backtrace of v5.1.5.1 x64 crash under Windows 10

Thank you for the tip on the Release Plan, timur. But because the patch was added the day before RC1 was compiled I wasn't sure it was in. If it is, then here is the backtrace.
Comment 11 Commit Notification 2016-07-21 08:10:50 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e1b90609d50b9b8bb48e7c6548b197ed7de77253

Related: tdf#100813 crash in this doc on scrolling past page 44

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Timur 2016-07-21 08:19:03 UTC
Created attachment 126337 [details]
Backtrace of LO 5.3+ 32-bit crash under Windows 7 x64

(In reply to Caolán McNamara from comment #9)
> Is there any automated crash report backtrace associated with your master windows failure ?

I'm aware of automated crash report from 5.2. but I don't know how it's used, and how backtrace is created. https://wiki.documentfoundation.org/ReleaseNotes/5.2 doesn't say, and it should.
I attach my backtrace from WinDBG.
Comment 13 Caolán McNamara 2016-07-21 08:51:28 UTC
The most recent bug I found here in scrolling past page 44 was in SwFlowFrame::IsKeep which is at the top of Pedros bt, so that's promising.

Timur's though is in some other place which hasn't triggered locally yet.
Comment 14 Caolán McNamara 2016-07-21 09:37:47 UTC
Timur's one though does state that the unwind info might be wrong, while Pedro's doesn't. Perhaps they are the same underlying problem. Lets wait until there are builds available with the above fix and have another test then.
Comment 15 Caolán McNamara 2016-07-21 10:37:28 UTC
*** Bug 100959 has been marked as a duplicate of this bug. ***
Comment 16 Commit Notification 2016-07-21 15:58:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f02c8042d0dd368b31b4245c1179a51c6f0b29f&h=libreoffice-5-2

Related: tdf#100813 crash in this doc on scrolling past page 44

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 V Stuart Foote 2016-07-21 16:10:24 UTC
Created attachment 126346 [details]
stack trace end of initial load of attachment 126239 [details]

attachment 126239 [details] from bug 100959

stack trace taken at the end of filter import load of the document, a second analyze -v trace from initial attempt to scroll the page that hangs things in GetVbaEventProcessor
Comment 18 V Stuart Foote 2016-07-21 16:11:33 UTC
Created attachment 126348 [details]
analyze -v and trace when trying to scroll
Comment 19 V Stuart Foote 2016-07-21 16:39:13 UTC
Created attachment 126350 [details]
stack trace on scroll of original attachment 126127 [details] with 2016-07-21 TB39 build

will revisit both documents when another TB39 build with today's patch to flowfrm.cxx rolls
Comment 20 Timur 2016-07-22 10:32:40 UTC
Created attachment 126359 [details]
Backtrace of LO 5.3+ 32-bit crash with master~2016-07-21_23.52.45

Again crash on fileopne, without scrolling, with master~2016-07-21_23.52.45_LibreOfficeDev_5.3.0.0.alpha0_Win_x86.
Comment 21 Caolán McNamara 2016-07-22 16:29:17 UTC
Presumably pBoss is null, but without being able to reproduce it its probably pointless to continue to handle each local oddity as they come up. I might have a windows environment in a few weeks to be try and reproduce the full set of issues, until then someone else can have a try.
Comment 22 V Stuart Foote 2016-07-22 17:17:42 UTC
On todays TB39 build with second patch.

On Windows 10 Pro 64-bit en-US with
Version: 5.3.0.0.alpha0+
Build ID: 9dc3356f1499a2b90078be86ca7470eb2e96aba8
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-07-21_23:52:45
Locale: en-US (en_US); Calc: CL

Running with OpenGL disabled (what one would expect for a user still on Windows XP) neither test document "crashes", the first scrolls backward and forward across page 44.  The second takes a loooong time to open, but then behaves scrolling and paging.

And, no apparent issue with OpenGL enabled.

With 32-bit WinDbg attached, had some issues with RTL in en-US local, but those were are 1st & 2nd instance hangs.  Without the debugger attached the documents seemed to function.
Comment 23 Commit Notification 2016-07-28 14:34:46 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=be1cd0aded725d307ee9b53529c1122655b2a391&h=libreoffice-5-1

Related: tdf#100813 crash in this doc on scrolling past page 44

It will be available in 5.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Pedro 2016-07-31 15:27:12 UTC
(In reply to Commit Notification from comment #23)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "libreoffice-5-1":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=be1cd0aded725d307ee9b53529c1122655b2a391&h=libreoffice-5-1
> 
> Related: tdf#100813 crash in this doc on scrolling past page 44
> 
> It will be available in 5.1.6.

Was this patch committed only to the 5.1 branch? Unfortunately there aren't any Windows daily builds except for the Master branch.

I tried a daily from the Master branch and it still crashed

crashreport.libreoffice.org/stats/crash_details/c6a87fff-47a9-4ec7-8a89-0397fcb1fea9

Version: 5.3.0.0.alpha0+
Build ID: 4a6329badc9c8679945d1a1ec225e26e15d7bfd2
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-07-30_10:25:39
Locale: pt-PT (pt_PT); Calc: CL
Comment 25 V Stuart Foote 2016-07-31 17:30:21 UTC
(In reply to Pedro from comment #24)
> 
> Was this patch committed only to the 5.1 branch? Unfortunately there aren't
> any Windows daily builds except for the Master branch.
> 
> I tried a daily from the Master branch and it still crashed
> 
> crashreport.libreoffice.org/stats/crash_details/c6a87fff-47a9-4ec7-8a89-
> 0397fcb1fea9
> 
> Version: 5.3.0.0.alpha0+
> Build ID: 4a6329badc9c8679945d1a1ec225e26e15d7bfd2
> CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
> TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-07-30_10:25:39
> Locale: pt-PT (pt_PT); Calc: CL


There are two patches to flowfrm.cxx on master and both have been back-ported to the 5.1, and 5.2 builds. Both present on current master, and 5.2.0.4--but just the first is in 5.1.5.2

1.
--- a/sw/source/core/layout/flowfrm.cxx
+++ b/sw/source/core/layout/flowfrm.cxx
@@ -2017,6 +2017,9 @@ bool SwFlowFrame::MoveBwd( bool &rbReformat )
     }
 
     SwFootnoteBossFrame * pOldBoss = m_rThis.FindFootnoteBossFrame();
+    if (!pOldBoss)
+        return false;
+
     SwPageFrame * const pOldPage = pOldBoss->FindPageFrame();
     SwLayoutFrame *pNewUpper = nullptr;
     bool bCheckPageDescs = false;

2.
--- a/sw/source/core/layout/flowfrm.cxx
+++ b/sw/source/core/layout/flowfrm.cxx
@@ -227,9 +227,9 @@ bool SwFlowFrame::IsKeep( const SwAttrSet& rAttrs, bool bCheckIfLastRowShouldKee
                 {
                     const SwAttrSet* pSet = nullptr;
 
-                    if ( pNxt->IsInTab() )
+                    SwTabFrame* pTab = pNxt->IsInTab() ? pNxt->FindTabFrame() : nullptr;
+                    if (pTab)
                     {
-                        SwTabFrame* pTab = pNxt->FindTabFrame();
                         if ( ! m_rThis.IsInTab() || m_rThis.FindTabFrame() != pTab )
                             pSet = &pTab->GetFormat()->GetAttrSet();
                     }
Comment 26 Pedro 2016-08-02 22:48:08 UTC
Created attachment 126529 [details]
Backtrace of v5.2.0.4 x64 crash under Windows 10

If those patches are included in 5.2.0.4 than I'm afraid it's not fixed yet.
The document still crashes LO 5.2.0.4 under Win10 x64 and WinXP x86 (no problem with Win7 x64). Added a backtrace under Win 10 x64
Comment 27 Björn Michaelsen 2016-08-04 19:52:31 UTC
making this "platform: Windows" as per comment 9 this doesnt happen to crash on Linux anymore ...
Comment 28 Pedro 2016-08-05 09:49:55 UTC
(In reply to Björn Michaelsen from comment #27)
> making this "platform: Windows" as per comment 9 this doesn't happen to crash
> on Linux anymore ...

Actually it crashes LibreOffice on Win XP AND on Windows 10 but not on Windows 7.
Comment 29 Pedro 2016-08-11 22:39:24 UTC
Created attachment 126765 [details]
Backtrace of v5.2.1.1 x64 crash under Windows 10
Comment 30 Pedro 2016-08-31 14:43:08 UTC
(In reply to Björn Michaelsen from comment #27)
> making this "platform: Windows" as per comment 9 this doesn’t happen to crash
> on Linux anymore ...

Setting Platform back to All. Document consistently crashes LibreOffice 5.2.0.4 under Ubuntu 14.04 LTS 64-bit
Comment 31 Xisco Faulí 2016-09-12 12:27:23 UTC
Adding keyword 'bibisectRequest'.
Comment 32 Caolán McNamara 2016-10-03 20:14:02 UTC
Does this now become a duplicate of bug 102073 ?
Comment 33 Pedro 2016-10-04 08:32:14 UTC
(In reply to Caolán McNamara from comment #32)
> Does this now become a duplicate of bug 102073 ?

The document in this bug report does not contain any images at all so the problem is not the same. But maybe the patch for 102073 also solved this problem. I will check when 5.2.3 is out.
Comment 34 raal 2016-10-12 16:54:12 UTC
no crash with Version: 5.3.0.0.alpha0+
Build ID: e2f6c7f0d0cc14f851d7028ff846c5dc658a81c6
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-11_00:37:49

I can reproduce crash on win7: Version: 5.3.0.0.alpha0+
Build ID: a9717054dcb59010c95bdbfdb440ac12e8703796
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-12_06:32:34
Comment 35 Timur 2016-11-04 10:07:14 UTC
It seems that this remains Windows-only fileopen bug now, as already noted, since Linux can be open. Tested with master.

This is crash report with LO 5.2.0.4 on Windows 7:
crashreport.libreoffice.org/stats/crash_details/58616547-7caa-4311-ac55-5c8ea5cb75e6
This is crash report with LO 5.2.3.3 on Windows 7:
crashreport.libreoffice.org/stats/crash_details/a8ddf995-7fcd-402a-9c7c-e7f607db222a
Windows master also crashes.

This docx has 202 pages in MSO, 170 pages in OO 3.3. (aligned left), 17 pages in LO 4.1.6 (still aligned left) 18 pages in LO 4.2.8. (aligned right), how to find for versions which crash on fileopen or scroll started from LO 4.3, 241 pages in Linux 5.3+ master (which is actually rather fine).
If bibisectRequest makes sense here at all, that would be for fileopen bug. But I wouldn't call this a regression, so I remove it.
Comment 36 Xisco Faulí 2016-11-12 13:00:24 UTC
Removing 'bibisectRequest' keyword as this is not a regression as per comment 35
Comment 37 Pedro 2016-11-12 15:09:58 UTC
(In reply to Xisco Faulí from comment #36)
> Removing 'bibisectRequest' keyword as this is not a regression as per
> comment 35

Added back regression and bibisectRequest

Took a little time to test with older versions (because the document never crashed OpenOffice): LibreOffice branches 3.3, 3.4 and 3.5 load the document without crash. The first branch that crashes is 3.6 (tested with version 3.6.7.2 under Windows 10)
Comment 38 Aron Budea 2016-12-13 17:33:36 UTC
Found a different crash with this document, and reported it in bug 104649.
Comment 39 MarjaE 2016-12-23 02:10:21 UTC
Crashes in LO 5.2.2.2 on MacOS.
Comment 40 Pedro 2016-12-28 15:10:47 UTC
Document now opens correctly under Windows 10 running version 5.3.0.1!
Was there a specific patch committed that can be back-ported to branch 5.2?
Comment 41 Timur 2016-12-29 08:39:30 UTC
LO 5.3 beta 1 on Windows opens it with 199 pages and scrolls without crash. Seems like solved in 5.3. So this should be WorksForMe.
But, since there were fixes here, I close as Fixed and change title to note that Windows fix came in another bug. 

PS I don't get why reports in http://crashreport.libreoffice.org/stats/signature/SwContentFrame::MoveFootnoteCntFwd%28bool,SwFootnoteBossFrame%20*%29 don't refer to bugs like this one.
Comment 42 Khaled Hosny 2016-12-29 10:48:35 UTC
Does it still crash when using the old layout engine?
Comment 43 Timur 2016-12-30 17:04:41 UTC
(In reply to Khaled Hosny from comment #42)
> Does it still crash when using the old layout engine?
Yes.
For testers: The layout is seen in Help-About. To use disable new/use old layout engine it one needs to set environment variable SAL_NO_COMMON_LAYOUT=1.
Comment 44 Pedro 2016-12-30 19:38:35 UTC
(In reply to Timur from comment #43)
> (In reply to Khaled Hosny from comment #42)
> > Does it still crash when using the old layout engine?
> Yes.
> For testers: The layout is seen in Help-About. To use disable new/use old
> layout engine it one needs to set environment variable
> SAL_NO_COMMON_LAYOUT=1.

Thank you for the instructions, Timur. I can confirm that with Layout Engine: old the document still crashes LibreOffice. This means that the bug is fixed in 5.3 but can not be back-ported, right?
Comment 45 Timur 2017-01-04 15:29:48 UTC
This is not about simple bugfix that can be backported, it's new development, Harfbuzz layout engine from 5.3. 
Note: Since old code is dropped in 5.4, no layout is shown in Help-About there.
Comment 46 Pedro 2017-01-14 16:28:02 UTC
FYI The document still crashes 5.3.0.1 under Windows XP.
Comment 47 V Stuart Foote 2017-01-14 16:42:06 UTC
(In reply to Pedro from comment #46)
> FYI The document still crashes 5.3.0.1 under Windows XP.

That is fine, please post the crashreport link for its stacktrace and the signature it shows.
Comment 48 Pedro 2017-01-16 14:07:26 UTC
(In reply to V Stuart Foote from comment #47)
> (In reply to Pedro from comment #46)
> > FYI The document still crashes 5.3.0.1 under Windows XP.
> 
> That is fine, please post the crashreport link for its stacktrace and the
> signature it shows.

Unfortunately there is no Crash Report link. The Crash Report dialog just shows Error.
Any suggestions?
Comment 49 V Stuart Foote 2017-01-16 15:20:35 UTC
(In reply to Pedro from comment #48)
> (In reply to V Stuart Foote from comment #47)
> > (In reply to Pedro from comment #46)
> > > FYI The document still crashes 5.3.0.1 under Windows XP.
> > 
> > That is fine, please post the crashreport link for its stacktrace and the
> > signature it shows.
> 
> Unfortunately there is no Crash Report link. The Crash Report dialog just
> shows Error.
> Any suggestions?

That is a shame, if the "Breakpad" based report gatherer is not running to catch a minidump and submit it to the project crashreport server, you have to revert to catching the dump/mini-dump yourself and analyze--or catch the stack trace--either done with WinDbg against symbols for the project.

=-ref-=

https://mmohrhard.wordpress.com/2016/06/19/crash-reporting-for-libreoffice/

https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 50 Pedro 2017-01-18 14:25:26 UTC
Unfortunately the document now crashes LibO 5.3.0.2 under Win7 x64.
This is the first version that crashes LibO under Win7

Maybe this is related to the changes in issue #104969 ?

Here is the Crash Report

crashreport.libreoffice.org/stats/crash_details/c04bc87c-dbec-4a56-b3b2-28b4db85f06b
Comment 51 Xisco Faulí 2017-01-18 14:42:49 UTC
(In reply to Pedro from comment #50)
> Unfortunately the document now crashes LibO 5.3.0.2 under Win7 x64.
> This is the first version that crashes LibO under Win7
> 
> Maybe this is related to the changes in issue #104969 ?
> 
> Here is the Crash Report
> 
> crashreport.libreoffice.org/stats/crash_details/c04bc87c-dbec-4a56-b3b2-
> 28b4db85f06b

It doesn't crash for me in

Version: 5.4.0.0.alpha0+
Build ID: db4badfc971b9cc60809c3408f579bae04a77c34
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-10_23:25:07
Locale: es-ES (es_ES); Calc: group
Comment 52 Pedro 2017-01-18 15:06:45 UTC
(In reply to Xisco Faulí from comment #51)
> (In reply to Pedro from comment #50)
> > Unfortunately the document now crashes LibO 5.3.0.2 under Win7 x64.
> > This is the first version that crashes LibO under Win7
> > 
> > Maybe this is related to the changes in issue #104969 ?
> > 
> > Here is the Crash Report
> > 
> > crashreport.libreoffice.org/stats/crash_details/c04bc87c-dbec-4a56-b3b2-
> > 28b4db85f06b
> 
> It doesn't crash for me in
> 
> Version: 5.4.0.0.alpha0+
> Build ID: db4badfc971b9cc60809c3408f579bae04a77c34
> CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
> TinderBox: Win-x86@42, Branch:master, Time: 2017-01-10_23:25:07
> Locale: es-ES (es_ES); Calc: group

Another crash, with an empty profile
crashreport.libreoffice.org/stats/crash_details/b3748eb2-0ab0-4c4c-bbfd-11525f4dff24

Version: 5.3.0.2 (x64)
Build ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
Locale: pt-PT (pt_PT); Calc: group
Comment 53 V Stuart Foote 2017-01-18 16:52:44 UTC
So, those both are crashes against signature "rtl_uString_acquire", added to the signature block.

http://crashreport.libreoffice.org/stats/signature/rtl_uString_acquire

And with 5.3.0.2 on Windows 8.1 64-bit I also reproduce a crash, but at a different location and more in line with the issues that Caolán had already squashed.

But on Windows 8.1 Ent 64-bit en-US with
Version: 5.3.0.2 (x64)
Build ID: 5ad7b2889021c491af62f7930a4b1cb631392f16
CPU Threads: 8; OS Version: Windows 6.29; UI Render: GL; Layout Engine: new; 
Locale: en-US (en_US); Calc: group

With and without OpenGL rendering with new rendering, on scrolling through the document I receive the original crash between page 36 and 44.



STR.

Open attachment 126127 [details] the .docx religious text in RTL Persian with "Traditional Arabic" font.

Scroll or page to page 36, at the bottom there is a large block of footnotes held as rows in a table. On opening, they are compressed over top of each. A zoom into the page causes the table to expand removing the over written. Continue to scroll to page 43 there is another large table holding foot notes, it too will expand.  Scroll back up to page 36 and then down to 43.  Shortly have a crash.


=-crash reports-= 
against SwContentFrame::MoveFootnoteCntFwd(bool,SwFootnoteBossFrame *)

http://crashreport.libreoffice.org/stats/crash_details/b038ea46-6a6d-4a86-88b1-407edb7578a6

http://crashreport.libreoffice.org/stats/crash_details/250693a9-e55c-45cd-bd99-d9a7769a2d7e

http://crashreport.libreoffice.org/stats/crash_details/c30e660d-77e6-437c-ab11-4ff3c27edd09

http://crashreport.libreoffice.org/stats/crash_details/33c9e0ca-e690-4fd4-b324-c3b7f396a401

http://crashreport.libreoffice.org/stats/crash_details/3c5f5143-49ed-4c23-9b00-669f36c58a86
Comment 54 Xisco Faulí 2017-01-18 19:58:00 UTC
following Stuart's steps I can reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: db4badfc971b9cc60809c3408f579bae04a77c34
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-10_23:25:07
Locale: es-ES (es_ES); Calc: group

but not in

Version: 5.4.0.0.alpha0+
Build ID: 4b3e8de6b3cb971b02aa0cb90aceb9e104071d3b
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Raising severity and priority
Comment 55 Caolán McNamara 2017-01-19 10:40:42 UTC
I can reproduce a crash under Linux with that table on page 43 if I click in it and then press tab a lot to move around inside it.
Comment 56 Caolán McNamara 2017-01-19 10:55:20 UTC
commit 1281bd5d87361fa516cdf247b055aeb4bb5e13fb
Author: Mike Kaganski <mike.kaganski@collabora.com>
Date:   Wed Jan 18 09:25:55 2017 +0300

    tdf#104181 related: don't throw on this document

added a check for the null pOldBoss I see in 5.3 to master to make it assert in debugging versions and continue without crashing in non-debug versions. I've added a 5-3 variant to not crash at https://gerrit.libreoffice.org/#/c/33304/ and 5-3 at https://gerrit.libreoffice.org/#/c/33305/

this may help the windows crash
Comment 57 Commit Notification 2017-01-19 15:44:22 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2671816be19e541941b9b3cbd3f085ea3748261d&h=libreoffice-5-2

Related: tdf#100813 don't crash traversing table in page 43

It will be available in 5.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 58 Commit Notification 2017-01-20 10:13:39 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7140efd3e2ea9c25264ac9a513480a2586610af4

Related: tdf#100813 don't crash traversing table in page 43 master has...

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 59 zahra 2017-01-22 04:53:31 UTC
hi Caolán
thanks extremely for your efforts to resolve my issues.
i realy appreciate it and admire it.
i pray for you and request divine extreme mercy for you in my five times daily prayers.
could you please also solve it for libreoffice 5.2.5.2 also?
i realy wish that open all of my books without any problem with libreoffice.
most of my books are in docx format which the users of microsoft office give me.
and also does it solve my issue related to bug 100859?
it was a very important book for me and God bless you for solving it.
Comment 60 zahra 2017-01-22 07:18:41 UTC
(In reply to Commit Notification from comment #57)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "libreoffice-5-2":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=2671816be19e541941b9b3cbd3f085ea3748261d&h=libreoffice-5-2
> 
> Related: tdf#100813 don't crash traversing table in page 43
> 
> It will be available in 5.2.6.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

(In reply to Commit Notification from comment #58)
> Caolán McNamara committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=7140efd3e2ea9c25264ac9a513480a2586610af4
> 
> Related: tdf#100813 don't crash traversing table in page 43 master has...
> 
> It will be available in 5.4.0.
> 
> The patch should be included in the daily builds available at
> http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
> information about daily builds can be found at:
> http://wiki.documentfoundation.org/Testing_Daily_Builds
> 
> Affected users are encouraged to test the fix and report feedback.

hi pedro, stuart and all testers and programmers that helped me to use libreoffice more properly and without worried about openning and reading my books!
you are very helpful and i dont forget your kindness and goodness!
in the five times daily prayers, i remember you and request divine special blessings and graces for you all.

also hi Caolán
i realy appreciate your efforts and endeaversto resolving my issues.
i sincerely pray for you in my five time daily prayers and request divine extremely mercy and blessings for you.
could you please provide the patch for version 5.2.5.2 of libreoffice too?
i realy admire you and your tireless efforts to help people even for free!
i realy wish that can open all of my documents properly without any hang or crash with libreoffice.
most of my documents are in docx format which users of microsoft office give me.
does your patch also resolve the problems with other books which i have?
i mean that is this bug duplicate of the

https://bugs.documentfoundation.org/show_bug.cgi?id=101125
and also this bug which you mentioned its a duplicate of this bug?
i mean
https://bugs.documentfoundation.org/show_bug.cgi?id=100859
could you please test these two bugs and compare the result with the current one?
could you please solve this issue with libreoffice 5.2.5.2 also?
i tried different versions of openoffice since 4.1.1 until the current version 4.1.3 and it does not crash for me.
i mentioned this and asked these questions because i am not a programmer and i am completely unfamiliar with coding and computer  programming.
but also i realy wish that i can open my documents and read all of them completely as soon as possible!
Comment 61 Commit Notification 2017-01-25 15:39:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d7858b0d23f88a3ecec4ed7cc863ee0867086209&h=libreoffice-5-3

Related: tdf#100813 don't crash traversing table in page 43

It will be available in 5.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 62 Xisco Faulí 2017-01-26 10:58:36 UTC
Created attachment 130693 [details]
comparison MSO Writer 2010 and master

I can no longer reproduce the crash in

Version: 5.4.0.0.alpha0+
Build ID: b41186a2fc49e440890b8c86e5367352ffaf9cd6
CPU Threads: 1; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-26_01:50:40
Locale: es-ES (es_ES); Calc: group

However, I see that some of the table's data isn't display now. Is that expected?
See the image attached
Comment 63 Caolán McNamara 2017-01-26 11:44:04 UTC
yeah, basically writer doesn't support tables in footnotes (try it in the ui and its not allowed) but the apis the docx import uses don't enforce that, so you get glitches with tables in footnotes. Not crashing is good enough for this bug.
Comment 64 Pedro 2017-02-04 11:15:36 UTC
(In reply to Caolán McNamara from comment #63)
> yeah, basically writer doesn't support tables in footnotes (try it in the ui
> and its not allowed) but the apis the docx import uses don't enforce that,
> so you get glitches with tables in footnotes. Not crashing is good enough
> for this bug.

But since MS Word does allow to insert tables (and apparently people use it) wouldn't it make sense for LibreOffice to use it too?

Furthermore, when a document containing a footnote table is saved as ODT the whole table is simply eliminated without any warning (and the user will only realize this when the document is reopened)

Is there some document rule that says that tables in footnotes are not acceptable?

If such a rule exists, then the text in the table should be converted to footnote text, if not then tables in footnotes are a missing feature...
Comment 65 zahra 2017-02-13 06:36:15 UTC
(In reply to zahra from comment #59)
> hi Caolán
> thanks extremely for your efforts to resolve my issues.
> i realy appreciate it and admire it.
> i pray for you and request divine extreme mercy for you in my five times
> daily prayers.
> could you please also solve it for libreoffice 5.2.5.2 also?
> i realy wish that open all of my books without any problem with libreoffice.
> most of my books are in docx format which the users of microsoft office give
> me.
> and also does it solve my issue related to bug 100859?
> it was a very important book for me and God bless you for solving it.

excuse me, sorry for my mistake.
i meant bug
100959
and 101125
i could open my books in versions 5.1.6 and 5.2.5 under windows xp.
i cant access newer versions of windows and i appreciate you if you test them in 5.2.5, 5.1.6 and 5.3.0 with different windows.
i did not test these books with 5.3.0 and i am grateful to your help.
Comment 66 Pedro 2017-02-23 09:41:26 UTC
This document consistently crashes LibreOffice 5.3.1.1 under Windows 7 x64 (but not under Windows 10 x64)

Here is the crashreport (with a blank profile)
crashreport.libreoffice.org/stats/crash_details/700f6008-729d-4542-a23d-4425cf2557f6
Comment 67 Xisco Faulí 2017-02-23 12:36:58 UTC
(In reply to Pedro from comment #66)
> This document consistently crashes LibreOffice 5.3.1.1 under Windows 7 x64
> (but not under Windows 10 x64)
> 
> Here is the crashreport (with a blank profile)
> crashreport.libreoffice.org/stats/crash_details/700f6008-729d-4542-a23d-
> 4425cf2557f6

It doesn't crash for me in

Versión: 5.3.0.3
Id. de compilación: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Subpr. de CPU: 1; Versión de SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

However, I would suggest to create a follow-up bug as this one is quite large already. Thanks
Comment 68 zahra 2017-02-24 09:23:10 UTC
hi.
today i downloaded libreoffice 5.2.6.1 and installed it.
its extremely great and compatible with xp beyond my immagination!
i dont know how to appreciate God for its great favor, also you and all developers to helped me eventually find my favorite version and open all of my books properly!
i have more than 90 islamic books in different folders!
they are realy divine treasury for me.
today i tested them and i could open them in 5.2.6.1 without crash!
its incredible and one divine miracle for me!
i dont know how appreciate God for this extremely great favor and also you all developers and programmers that helped me my dream (openning my documents without crash and complete compatibility with windows xp) became a reality!
i am extremely happy and i cant discribe my happiness and feeling in english.
even openning my books speed is increased very much in 5.2, i dont have any crash after exiting on windows xp and i study all of my books without any afraid!
i should be grateful to this favor for my lord.
because God says in the quran:

And as for the favor of your Lord, do announce [it].
i sincerely pray for you in my five times obligotary prayers because God says:

And when you are greeted with a greeting, greet with a better [greeting] than it or return it; surely Allah takes account of all things.
and also i pray for you and i am sure for acceptance in the divine court.
because God is extremely merciful, accepts our prayers and said:

And when My servants ask you concerning Me, then surely I am very near; I
answer the prayer of the suppliant when he calls on Me, so they should answer My
call and believe in Me that they may walk in the right way.

you presented me the best version of your program for free, and i present my sincere and honest prayer which i always remember you, your kindness and i request divine infinite mercy, graces, blessings, bounties and favors for you all.