Bug 104649 - Crash after deleting all text from a particular document, and then undoing it
Summary: Crash after deleting all text from a particular document, and then undoing it
Status: RESOLVED DUPLICATE of bug 107568
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha1
Hardware: All Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: interoperability target:5.4.0
Keywords: filter:docx, haveBacktrace
Depends on:
Blocks: RTL-CTL Undo-Redo
  Show dependency treegraph
 
Reported: 2016-12-13 17:29 UTC by Aron Budea
Modified: 2017-05-17 15:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (109.88 KB, text/plain)
2016-12-13 17:50 UTC, Xisco Faulí
Details
bt with symbols (11.66 KB, text/plain)
2016-12-14 23:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-12-13 17:29:38 UTC
Bug 100813 is about a crash when opening/scrolling attachment 126127 [details], and has been fixed in Linux. However, there's still a crash upon deleting the text and undoing the deletion.

1. open attachment 126127 [details],
2. select all,
3. delete,
4. undo.

=> crash

Tested with 5.3beta2 / Ubuntu 16.04.
Comment 1 Xisco Faulí 2016-12-13 17:44:13 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: 634589b340316ba64b731b4d923c1056be415494
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Xisco Faulí 2016-12-13 17:50:39 UTC
Created attachment 129598 [details]
backtrace
Comment 3 Julien Nabet 2016-12-14 23:08:04 UTC
Created attachment 129650 [details]
bt with symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
The weird thing is I get a different bt than Xisco's one.
Comment 4 Julien Nabet 2016-12-19 18:40:46 UTC
Xisco: if you give a try with a build containing https://cgit.freedesktop.org/libreoffice/core/commit/?id=b052b5d890be70dd22b9aea36a356074a2c39871, perhaps you'll get my bt.
(I gave a new try with a build containing it, I still reproduce the same bt I had attached)
Comment 5 Xisco Faulí 2016-12-20 00:30:54 UTC
I can reproduce it in

Version: 5.2.0.0.alpha1+
Build ID: 5b168b3fa568e48e795234dc5fa454bf24c9805e
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; 
Locale: ca-ES (ca_ES.UTF-8)
Comment 6 Xisco Faulí 2016-12-20 15:37:15 UTC
In

Version: 5.0.0.0.alpha1+
Build ID: 0db96caf0fcce09b87621c11b584a6d81cc7df86
Locale: ca-ES (ca_ES.UTF-8)

it doesn't crash but it LibreOffice hangs when doing Ctrl+Z
Comment 7 Terrence Enger 2016-12-22 16:38:10 UTC
Just a couple of observations from debian-stretch ...

(*) daily Linux dbgutil bibisect repository version 2016-12-22 exits
    before displaying any GUI.

(*) bibisect-43all version oldest segfaults before dislaying any GUI.

I wonder if this bug has been present since the beginning of LibreOffice.
Comment 8 Per 2016-12-30 12:39:52 UTC
Also fails on my win64 lo 5.2.4 released (AMD hw) on Win7.
I get unexpected crash and lo attempt to repair the document (always failing with new crash in a loop - never actually seeing the document). When skipping the repair, the document finally opens but I get "SEH Exception: ACCESS VIOLATION" and lo writer disappears without a trace...
Writer feels more unstable generally than previous release (I often get unexpected crash and repair also in other more simple documents in odt-format)
Comment 9 Xisco Faulí 2017-02-27 10:45:10 UTC
Issue still reproducible in

Version: 5.4.0.0.alpha0+
Build ID: e9e6228533b336317aa809a7aaaa4fd1c338d4f7
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 10 Xisco Faulí 2017-05-02 15:53:35 UTC
Hi Michael,
Would you mind taking a look at it when you have some time ?
Comment 11 Xisco Faulí 2017-05-13 00:21:09 UTC
Fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6785b99a3f7e7531c8ef7ed16402cc4e02c9750 which is the fix for bug 107568, so both bugs have the same root cause.

Tested in

Version: 5.4.0.0.alpha1+
Build ID: 2e399f32e7505bdcf855112d8a48ae0edefe5bbc
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
Locale: fo-FO (ca_ES.UTF-8); Calc: group

Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 107568 ***
Comment 12 Commit Notification 2017-05-17 15:27:39 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cdf6330ebc6f365a545c648eb6672aa51858c015

tdf#104649: Add uitest

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.