Bug Hunting Session
Bug 106319 - (Windows 10 pro 64bit) Font preview text garbled in Paragraph Styles when Open GL is ticked on
Summary: (Windows 10 pro 64bit) Font preview text garbled in Paragraph Styles when Ope...
Status: RESOLVED DUPLICATE of bug 103831
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-04 15:06 UTC by mondfabrik
Modified: 2017-03-04 15:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Open GL device log from %appdata% (319 bytes, text/plain)
2017-03-04 15:07 UTC, mondfabrik
Details
Preview screenshot (55.17 KB, image/png)
2017-03-04 15:11 UTC, mondfabrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mondfabrik 2017-03-04 15:06:23 UTC
Description:
Fonts appear all garbled(very condensed) in the font preview pane in the paragraph style tab when OpenGl is selected in the options while the font previews that appear in the drop down menu in the main pane work just fine. It looks like this: http://imgur.com/a/SjFI8. It happens regardless of the font selected and whether the said font is truetype or OTF.

Disabling "Use OpenGl for all rendering" and restarting solves the problem.


Steps to Reproduce:
1.Launch Libre Office
2.Go to Styles
3. Right click on style and choose "modify"


Actual Results:  
Font preview text garbled (super condensed kerning) regardless of the settings chosen

Expected Results:
Font preview should display according to the settings specified by the user


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36
Comment 1 mondfabrik 2017-03-04 15:07:13 UTC
Created attachment 131627 [details]
Open GL device log from %appdata%
Comment 2 mondfabrik 2017-03-04 15:11:18 UTC
Created attachment 131628 [details]
Preview screenshot
Comment 3 mondfabrik 2017-03-04 15:13:50 UTC
Graphics adapter: Radeon HD 5700 
Driver version: 15.201.1151.1008
Comment 4 Dennis Roczek 2017-03-04 15:18:41 UTC
@mmeeks: blacklist the driver again?
Comment 5 mondfabrik 2017-03-04 15:29:35 UTC
From help/about Libre Office: 

Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: fr-FR (fr_FR); Calc: group
Comment 6 mondfabrik 2017-03-04 15:29:46 UTC
Version: 5.3.0.3
Build ID: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
CPU Threads: 8; OS Version: Windows 6.2; UI Render: default; Layout Engine: new; 
Locale: fr-FR (fr_FR); Calc: group
Comment 7 V Stuart Foote 2017-03-04 15:59:35 UTC
Dupe of bug 104939 but cause is our DirectWrite implementation used with OpenGL rendering. Corrected for bug 103831 by reverting to GDI+ calls while we refactor the DirectWrite. The GDI+ based Default rendering is not affected.

Please test with current nightly build of master to verify correct behavior. While the revert to GDI+ calls in the 5.3 branch is up for review [1] and should be ready for the 5.3.2 build.

=-ref-=
https://gerrit.libreoffice.org/#/c/34862

*** This bug has been marked as a duplicate of bug 103831 ***