Bug 106380 - autocorrect incorrectly includes characters in change tracking
Summary: autocorrect incorrectly includes characters in change tracking
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: László Németh
URL:
Whiteboard: target:7.2.0 target:7.1.0.2
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2017-03-07 11:13 UTC by Pranav Kant
Modified: 2021-01-07 09:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pranav Kant 2017-03-07 11:13:47 UTC
- While change tracking is turned off, write 'as'
- Turn change tracking on
- Write 'df'
- Hit space
- The autocorrect will capitalize first character ('a' -> 'A') and include that character in the change tracking.

Expected behavior:
The capitalized 'A' should not be included in the change tracking
Comment 1 Xisco Faulí 2017-03-09 10:46:22 UTC
Confirmed in

Version: 5.4.0.0.alpha0+
Build ID: d3676ceeec55a41337ce5e6bc596f4f100d0638e
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

and 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Aron Budea 2017-03-10 21:45:40 UTC
Why shouldn't it be? The replacement was made after enabling track changes.

In fact, I think the incorrect part is that the replaced "a" isn't included (eg. it should look very similar to going back, and changing "a" to "A" manually after enabling track changes).
Comment 3 Pranav Kant 2017-03-17 12:00:33 UTC
(In reply to Aron Budea from comment #2)
> Why shouldn't it be? The replacement was made after enabling track changes.

I would argue it was not a user change, it was a change made by libreoffice itself. To be honest, not sure what should be the correct behavior here.

> 
> In fact, I think the incorrect part is that the replaced "a" isn't included
> (eg. it should look very similar to going back, and changing "a" to "A"
> manually after enabling track changes).

Yeah, this too.
Comment 4 QA Administrators 2018-03-18 03:35:26 UTC Comment hidden (obsolete)
Comment 5 Aron Budea 2018-03-18 23:12:29 UTC
Same behavior in 6.0.2.1 / Windows 7.
Comment 6 QA Administrators 2019-03-19 03:49:33 UTC Comment hidden (obsolete)
Comment 7 Aron Budea 2020-04-27 01:17:18 UTC
Same in 7.0.0.0.alpha0+ (850b8de31c5be5127eac16a4f5cc18c26a582e53) / Ubuntu.
Comment 8 László Németh 2020-11-05 13:41:39 UTC

*** This bug has been marked as a duplicate of bug 83419 ***
Comment 9 László Németh 2020-12-09 11:20:52 UTC
This is not a duplicate: we must track the deletion of the (originally not tracked) lower letter, too, i.e. replacing silently with a tracked insertion is really incomplete:

Instead of

asḏf̱ -> A̱sḏf̱ 

we need

asḏf̱ -> a̶A̱sḏf̱
Comment 10 Commit Notification 2021-01-05 18:33:31 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/aecb7364713871ce068effdb59a5da68ab4b2e53

tdf#106380 sw AutoCorrect: track deletion at capitalization

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2021-01-07 09:41:19 UTC
Verified in

Version: 7.2.0.0.alpha0+
Build ID: 6bb6eb1692d7dd432103d0e7278534390084caf6
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@László Németh, thanks for fixing this issue. Should it be closed as RESOLVED FIXED ?
Comment 12 Commit Notification 2021-01-07 09:42:21 UTC
László Németh committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2c25f59fae2201ef57237bf67625dcdcf238d5ed

tdf#106380 sw AutoCorrect: track deletion at capitalization

It will be available in 7.1.0.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 László Németh 2021-01-07 09:46:37 UTC
@Xisco: thanks for verification and feedback!