Download it now!
Bug 106562 - No sane accelerator path for Format->Character (Ubuntu Unity integration)
Summary: No sane accelerator path for Format->Character (Ubuntu Unity integration)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: All All
: medium minor
Assignee: Aron Budea
URL:
Whiteboard: target:5.4.0
Keywords: bibisected, regression
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2017-03-16 04:34 UTC by john
Modified: 2017-04-17 22:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2017-03-16 04:34:45 UTC
Description:
There is no keystroke defined for Format->Character in Impress.
It used to be Alt-O-H, but that seems to have disappeared.
I'm not sure when it happened, but at some point all of the muscle-memorized keystrokes of LibreOffice were thrown out the window, changed and disappeared. It would be so great if someone could do a methodical study of this and ensure that features are available by keyboard. Confiscate the mouses of a few developers for a few days and it will all be fixed :-)

Steps to Reproduce:
Open Impress, a default setup (no customised keystrokes), create a text box, select some text (using the keyboard), try to type CO2 with 20%-lowered subscript '2'. This requires the Format->Character dialog; it cannot be achieved using the sidebar options.

(Side comment: there is no way to turn off 'Automatic' with the keyboard, in the Format->Character dialog, either)

Actual Results:  
The only way to access Format->Character with Libreoffice Impress is currently
Alt F DOWN DOWN DOWN DOWN DOWN DOWN ENTER...

(I'm on Ubuntu 16.04 with Unity)

Expected Results:
Alt F H ("C_haracter" with 'h' underlined)



Reproducible: Always

User Profile Reset: N/A (No)

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Buovjaga 2017-03-16 10:17:58 UTC
Weird, it is still Alt-O-H for me!

I wonder, if it's something Ubuntu-specific?

Win 7 Pro 64-bit, Version: 5.2.5.1 (x64)
Build ID: 0312e1a284a7d50ca85a365c316c7abbf20a4d22
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: fi-FI (fi_FI); Calc: CL

Version: 5.4.0.0.alpha0+
Build ID: eb7b03b052ffe8c2c577b2349987653db6c53f76
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2017-02-26_22:34:18
Locale: fi-FI (fi_FI); Calc: CL
Comment 3 Xisco Faulí 2017-03-17 15:58:19 UTC
bibisecting it with lo-linux-dbgutil-daily-till42 gives me a different range: https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=856ceb2cc5d78c36c7a8fc6118254d85f990d7e6..3e7b69ae3504a32e142cbf538b751ade38fbfdba
Comment 4 Aron Budea 2017-03-19 00:55:01 UTC
(In reply to Buovjaga from comment #1)
> Weird, it is still Alt-O-H for me!
> 
> I wonder, if it's something Ubuntu-specific?

The issue seems to be with Unity integration. With a TDF build that doesn't have it, Alt-O-H works fine. In these versions the menu bar appears separately from the top bar.

With the bundled 5.1.6.2 or bibisect-linux-64-5.4 the menu bar appears as part of the top bar, and Alt-O works, but H doesn't, and if I press a different valid accelerator, like A for Paragraph, all accelerators appear for the menu items, but Character has none.
Comment 5 Buovjaga 2017-03-19 16:12:23 UTC
Yeah, I confirm with
Version: 5.2.3.2
Build ID: 1:5.2.3~rc2-0ubuntu1~xenial1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: fi-FI (en_US.UTF-8); Calc: group

Björn: what do you think?
Comment 6 Xisco Faulí 2017-03-19 16:20:00 UTC
Just for you information. Aron pushed a patch to gerrit for this issue: https://gerrit.libreoffice.org/#/c/35418/