Bug Hunting Session
Bug 106717 - Text becomes blurred after upgrading to 5.3.2.1
Summary: Text becomes blurred after upgrading to 5.3.2.1
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.2.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2017-03-23 08:23 UTC by Franklin Weng
Modified: 2017-04-22 16:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of version 5.3.1.2 with OpenGL turnned off (144.68 KB, image/png)
2017-03-23 08:24 UTC, Franklin Weng
Details
Screenshot of version 5.3.2.1 with OpenGL turnned off (198.86 KB, image/png)
2017-03-23 08:25 UTC, Franklin Weng
Details
Screenshot of version 5.3.2.1 with OpenGL turnned on (198.39 KB, image/png)
2017-03-23 08:26 UTC, Franklin Weng
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franklin Weng 2017-03-23 08:23:23 UTC
Description:
In the same PC using Windows 7, when using LibreOffice 5.3.1.2 (official fresh release) the text is clear (with OpenGL turned off).  However, when using LibreOffice 5.3.2.1 (downloaded from http://dev-builds.libreoffice.org/pre-releases/win/x86/LibreOffice_5.3.2.1_Win_x86.msi ) the text becomes blurred.

Not sure if it is OpenGL's problem.

User profile has been reset but no difference.

Several screenshot will be attached soon.

May be related to bug #104869 but not sure.

Steps to Reproduce:
1. Upgrade to version 5.3.2.1 (rc)
2.
3.

Actual Results:  
Text blurred

Expected Results:
Text should be clear


Reproducible: Always

User Profile Reset: Yes, no difference

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36
Comment 1 Franklin Weng 2017-03-23 08:24:49 UTC
Created attachment 132091 [details]
Screenshot of version 5.3.1.2 with OpenGL turnned off

You can see the text is clear.
Comment 2 Franklin Weng 2017-03-23 08:25:44 UTC
Created attachment 132092 [details]
Screenshot of version 5.3.2.1 with OpenGL turnned off

You can see the text becomes blurred (you can zoom out the picture to observe)
Comment 3 Franklin Weng 2017-03-23 08:26:40 UTC
Created attachment 132093 [details]
Screenshot of version 5.3.2.1 with OpenGL turnned on

Seems not different from the result with OpenGL turned off.
(You can zoom out to observe it)
Comment 4 V Stuart Foote 2017-03-23 12:55:17 UTC
On Windows builds at 5.3.2.1, with OpenGL rendering the horizontal scaling of glyphs has been moved from DirectWrite to GDI+ calls and so should match the rendering of Default.

Your screen clips with 5.3.2.1 with and with-out OpenGL rendering seem to show that, with the GUI both similarly rendered. 

However there does seem to be a degradation in the crispness of the font as rendered.

I do not see similar on Windows 10 Pro 64-bit en-US for my locale with OS default Segoe UI font used for the User Interface. 

Perhaps force a font replacement in LibreOffice for the CJK font used with Windows 7 OS (that is MS Mincho right?).

@Khaled, Mark?
Comment 5 Khaled Hosny 2017-03-23 22:55:20 UTC
We now use DirectWrite by default for text rendering on Windows whether OpenGL is on or off, and fallback to GDI for the cases we don’t handle well with DirectWrite yet (rotated/vertical text, horizontal scaling). DirectWrite by design does anti-aliasing (smoothing) unlike GDI. I think you can change the system font settings to disable font smoothing if you wish so.
Comment 6 V Stuart Foote 2017-03-24 01:04:39 UTC
(In reply to Khaled Hosny from comment #5)
> We now use DirectWrite by default for text rendering on Windows whether
> OpenGL is on or off, and fallback to GDI for the cases we don’t handle well
> with DirectWrite yet (rotated/vertical text, horizontal scaling).
> DirectWrite by design does anti-aliasing (smoothing) unlike GDI. I think you
> can change the system font settings to disable font smoothing if you wish so.

Thanks, good to know the distinction--and that we do anti-alaising by default, just not sub-pixel rendering, right?
Comment 7 odinatlas 2017-03-26 08:06:17 UTC Comment hidden (off-topic)
Comment 8 Franklin Weng 2017-03-26 08:27:08 UTC
I'm not talking about font anti-alias.  All the screenshot showed that anti-alias has been disabled, but in 5.3.2.1 the font became blurred than 5.3.1.2.  I didn't quite get what you were talking about.  Did you mean that DirectWrite would do anti-alias automatically, and that's why the text became blurred?

(In reply to V Stuart Foote from comment #4)
> However there does seem to be a degradation in the crispness of the font as
> rendered.
> 
> I do not see similar on Windows 10 Pro 64-bit en-US for my locale with OS
> default Segoe UI font used for the User Interface. 
> 
> Perhaps force a font replacement in LibreOffice for the CJK font used with
> Windows 7 OS (that is MS Mincho right?).
> 
> @Khaled, Mark?

And the problem also shows on the GUI, not the document area only.  I wonder if font replacement would work or not.
Comment 9 Buovjaga 2017-03-29 06:15:30 UTC
Bug 106634 seems to be complaining about the same thing.
I do notice it myself, but I didn't see it as a problem.